New Fibaro Switch FGS-223 is driving me nuts

It’s in the database editor. It’s probably already set but I don’t know what devices you actually have so I’m not 100% sure (there are many versions of these devices).

In any case, it doesn’t matter as the log shows that this isn’t the problem - the device isn’t using the BASIC class (hence why it’s always good to look at the logs :slight_smile: ).

What is node 27? The title of this thread is FGS223, but you’ve then mentioned FGS211 and FGS222… Probably the issue here is that the database is probably using EP1 and the device isn’t using the multi-channel for this endpoint so we probably just need to swap the database channels.

I’m using FGS221 and FGS222, both with the same problem. This issue is similar and related to this topic:

But that topic was related to OH1. Now I have the same problem with OH2.

Node 27 in this case is a “FGS222 Double Relay Switch 2x1.5kW”

Please can you check that the log shows the same thing - I really don’t like assuming it’s “the same problem” - as we’ve already seen - the problem isn’t what you thought.

Also, please can you provide the actual devices that you have - there are 4 versions of the FGS221 alone, so we can’t just go on model number as they are likely different.

I have these four devices:

openhab@main()> things | grep FGS
zwave:device:22160db1:node22 (Type=Thing, Status=ONLINE, Label=Z-Wave Node 22: FGS222 Double Relay Switch 2x1.5kW, Bridge=zwave:serial_zstick:22160db1)
zwave:device:22160db1:node27 (Type=Thing, Status=ONLINE, Label=Z-Wave Node 27: FGS222 Double Relay Switch 2x1.5kW, Bridge=zwave:serial_zstick:22160db1)
zwave:device:22160db1:node28 (Type=Thing, Status=ONLINE, Label=Z-Wave Node 28: FGS222 Double Relay Switch 2x1.5kW, Bridge=zwave:serial_zstick:22160db1)
zwave:device:22160db1:node11 (Type=Thing, Status=ONLINE, Label=Z-Wave Node 11: FGS211 Relay Switch 1x3kW, Bridge=zwave:serial_zstick:22160db1)

What further information do you need?
The devices where key 1 will not send an update are the FGS222 nodes.

I’d like to know the version number - it’s displayed in the device properties (Attributes section in HABmin).

Firmware version for all FGS222 is 2.2

Thanks - but what about the FGS221? There’s four different versions of these.

That one has firmware version 2.1 with type id / ID 0400:100a.

Thanks - I’ll try and take a look at this tomorrow if I get a chance.


So, for these devices there should be 3 channels shown - “Switch”, “Switch 1” and “Switch 2”. Switch and Switch 1 should both control the first relay - if you use the one called Switch, it should also receive reports I think due to the way Fibaro is sending the responses.

Let me know if that is the case and we could update the database to make it clearer.

That solved the problem! Changed switch1 to switch did the trick, I thought “switch” would be for both switches at once.
So it would make sense to update the database to make that clearer.
Thank you very much!

Hello @chris,

I too have a problem with the FGS223. I installed it in my livin room, but want to activate the scenes, so I can trigger alternate scenes from my mail light pushbutton.

But I think the options from the scene activation are wrong:
You are able to activate the scene for every one option, but not the combinations:

Like I want to set it to 7, (1, 2 and 3 combined).

Thanks for your input!

Best regards,

I’ve updated these configurations to be free entry.

So what does it do when you set it to 7? Does it not accept that value?
You don’t need to have that “7” in “Available Settings”.

Edit: Upps, too late :heart_eyes:

Wow, thanks for the fast reaction!!

This also applies to the Single Switch, I’ve submitted a database change.

Ok - thanks. I’ll export a database update later this morning for both of these.

Hey could you please tell me where can i find the latest zwave jar?

Thanks Chris, i downloaded the binding and now i see online (green) the FGS223 in habmin. It also update the status in OH from the wall switch but i think there is a problem with the instant power consumption.
My items looks like this:
Number kitchen_power "w [%.1f W]" zwave="6:command=SENSOR_MULTILEVEL,meter_scale=E_W" }
Number kitchen_energy "kwh [%.2f kWh]" {zwave="6:command=METER,meter_scale=E_kWh" }
At the kwh item i see 0.1 so i suppose this is the total w consumed since i installed the device (before Christmas) but on the instant power there’s no value displayed when the light is on.

Thanks for any advice.
Happy holidays all!