New Fibaro Switch FGS-223 is driving me nuts

Ok I will give OH2 a go and report back.
Thanks for the help.

I just did it, BUT it remains the same problem (an by the way also with the Qubino devices), the issues are NOT resolved with the OH2 binding.
See also this thread

I can confirm the same problem on OH2. I can see the association is now using MULTI_INSTANCE_ASSOCIATION commands however the it has not fixed the problem.

Please provide a log of this - from the logs @vossivossi provided, it shows it was NOT using the multi channel association so if yours is I’d be interested to see what’s happening…

I have just checked and I am seeing the same as @vossivossi, it is only using it for the GET not the SET.

Ok- thanks - at least it’s consistent. I’ve had a look at the code - I need to think it through a little more but I’ll likely make a change to try at some stage - probably later tonight, but let’s see how it goes as I’ve been travelling for the past 24 hours so without much sleep…

I think I have spotted the bug in the code. If I can work out how to get the dev environment setup I will make a change and test it!

I know what is stopping it working - the question is how to solve it in a way that is compliant to the spec since there are some specific requirements on how this is used.

Please can you post the XML for the new FGS223 (@smee204), and also for the Qubino (@vossivossi). I want to check that the information ties in with the slightly complex conditions imposed on this in the standards.

This is the FGS223.
node9.xml (30.5 KB)

I’ve made a change, but I’m not sure it will work for you yet. Since this only affects group 1, and there are other problems preventing you changing group 1, this change may not actually do anything. If you exclude the device and add it back it might work. Make sure you keep a log so we can see what happened during the initialisation if it didn’t work.

Sure, here is the Qubino XML-File.
node101.xml (24.9 KB)

I recently got an FGS-213 to use to monitor my floor heating, I’ve noticed some stuff were missing.
For openhab2 I’ve updated the database for the Single switch 2 FGS-213 the same updates should probably be done for FGS-223 (if they are correct)

Added the Sensor_power command class and added the meter_reset, please review when you have the chance.

Regards, S

Are those issues above solved? @Lyve, @Woutch, @ossostborn?
I’m thinking about buying three of those devices and don’t like to burn my money :grinning:

Hello @sihui,

I can confirm that the input for the scene value now works. But I’m not able to test it at the moment.

For the rest, I have no issue with my FGS223, but I have only one in use now driving 4 LED spots.

If you need more info, please ask!

Best regards,


Thanks a lot!

Which version (OH2 and Zwave binding) do you use? The official 2.0 packages?

Hello @vossivossi,

I’m followoing the snapshots for openhab 2. And update around every week / 2 weeks.

Last update was from yesterday I think :slight_smile:

Thank you for this information. So I should also move from the release version to snapshot. Do you download it from cloudbees? (As I am running OH on Windows I need to install and update manually).

I also can confirm that the Fibaro FGS223 now works correctly (reporting correctly the different endpoints for Switch1 and Switch2).
BUT: The Qubino ZMNHBD is still NOT working (I tested tonight with Z-Wave binding build I excluded and freshly reincluded 2 of the devices to be sure. The results:

  1. When only the lifeline association is set, no reporting is done to endpoints 1 and 2 (neither for Switch 1/2 nor Power(Watts)1/2).
  2. Even when the association groups for Switch binary or Basic On/Off are set (or both, also tested), NO update comes to the controller for Switch 1/2.
  3. When the assocation groups for power reporting are set, the Power Consumption (Watts) is reported correctly for both endpoints separately(!)

Is there a chance to also get the status reporting of the switches correctly? I have moren than 10 of them installed and can provide any kind of debug log if you tell me what you need. Thanks for your help!