New Homeseer WD200+ Switches Coming

I’m a huge fan of the Homeseer WD100+ dimmer switches, as that’s all i been outfitting and installing in my house. They have announced version 200 of their switches which has a really cool feature that i have dreamed about for notifications (door open, timer running, etc) as well as tap selection from 1-5 for scene control. Currently the WD100’s have only single, double and tripple tap, so we are getting 2 more tapes.

The vertical LED dim indicators are now RGB and can be individually controlled as a notification message. Super cool! Can’t wait till they are available on the 30th as i want to get some :slight_smile:

Looks like you can add to cart now. I was thinking of picking one up to check out, though it may take some time for it to be added to the zwave database, and I’m also not quite sure how that is going to work. As of right now, I don’t know that there is a way to send devices things like this(RGB), it’s typically done in the settings, but I don’t think there is a way to programmically(through a rule) send those updates to the lights.

It’ll be cool for sure once it’s all working.

@Python Did you purchase one of these? I too am very interested but as mentioned by @bhomeyer I’m not sure how this would work in OH.
If you have one, could you let us know your experiences getting it integrated into OH?

I have not, i’m waiting for to carry them as i have a credit with them from a switch i returned.

Out of the box it won’t work till get our hands on one and can add it to the database for zwave @

Thanks for the reply. Even once it is added to the DB won’t there still be issues controlling the LEDs since, according to the manual, they are set via z-wave configuration params which as @bhomeyer was saying can’t be set via rules?
I’m hoping I’m wrong and you have a way round this, what are your thoughts?

It looks like they’ve managed to control it on SmartThings via a custom Device Handler:

Any idea if this works with OH? I am starting from scratch and liked the look of this switch.

I sent an email over via the webpage contact form.

I recieved a quick response and the operations manager quickly replied that they had no plans to support OH.

I think the problem is that these switches require zwave configuration properties to be sent to control the LEDs.
As far as I know there is not way to send configuration properties via rules in OpenHAB, the only way is to adjust them via PaperUI which is of course a manual user-driven action.

I hope I am wrong and would really like to hear from anyone who has ideas for changing zwave configuration properties via rules. Maybe @chris as the developer of the zwave binding could shed some light on the subject.

You are :slight_smile:

There’s no way to adjust any configuration parameter, but it is possible to add a channel that allows configuration of a specified config parameter. This needs to be added to the database…

Can you tell me what parameter needs to be added and I can add it (if there’s a number, then I’ll add the first one and someone can add more, but I’d request to keep the number to an absolute minimum).

Hi @chris, thanks for replying. I am so happy to be wrong! :slight_smile:
So I don’t think any of us on this thread own this new Homeseer switch yet but since you say it’s possible to control the params I will likely be purchasing one.

I would however love to learn how to add channels for parameters as I have other devices I would like to control in this way. May I suggest the following for you to update so we can learn how to do it on others:
This is the GE-45605 Outlet that has a nightlight LED. You already have the config property entered in the DB but could you add a channel to control it and then I think we could take it from there.

I’m very excited about this feature for other deivces but do want to ask why you are concerned about keeping the number to a minimum? Why is it not a good idea to expose most/all configuration properties as channels?
I understand that some properties are unlikely to need to be changed after initial setup but I still think there will be devices with quite a few properties that make sense to expose as channels.

Simply because adding “hundreds” of channels into the system isn’t very nice. They appear in everyones PaperUI, and many people use automatic linking, so that means “hundreds” of extra items. If parameters are needed, then I have no issue adding them of course, but I don’t want to simply add a channel for every parameters if that’s what you are getting at?

Apologies in advance for my newbie question… I just installed the latest daily build of OH2.3 last night on my Pi. I have a Zwave+ USB stick connected and currently just one HS-WD200+ switch. I added the Zwave binding and searched for devices. While searching, I tapped the paddle up on the switch and OH found the switch but it reports it as an unknown device. I see it in the DB via a browser but it isn’t shown as a supported device. Originally I installed 2.2 stable and then upgraded to latest daily. I had to reinstall the Zwave binding afterward which I thought would give me the latest DB, yet the HS-WD200+ doesn’t show as a supported device within PaperUI. Am I doing something wrong (entirely possible since I’ve never touched OH before yesterday)? If not, do you have any idea when this switch will be supported?

Thanks in advance for your assistance…

I think that is what I am getting at, and understood.
For the WD200+ it of course makes sense to add channels for the config params that control the LEDs so it’s just a case of adding them to the DB entry.
I hope you would agree that the same could be said for the nightlight feature of the GE-45605 I mentioned.

Could you point me towards any information for adding a channel to the device DB for a config param? I am eager to add the ones I think would be useful but I haven’t found a simple guide to doing so.

Looks like the device is in the DB:
So I’m not sure why it is showing as an unknown device for you. I know in the past it sometimes takes a little while before all of the info is retrieved from a device before it is fully recognised by OH so it may start working for you after some time.

As I mentioned in my comment to Chris, I am not sure how to expose zwave config params as channels and as far as I can see the DB entry for the WD200+ does not have any of the config params exposed as channels as we would need. (I may be wrong as I don’t think I have ever seen a DB entry for a device with config params exposed ad channels so not sure what I am looking for)

Hopefully someone can explain to us how to do this and we can update the DB entry for this and other devices.

I didn’t look too hard to be honest, but if it’s needed, then let’s add it. I’m not trying to stop channels being added if they are really needed for normal use - I just ask that we don’t blindly add everything “just in case” :slight_smile:

Below is an example of a device that has a parameter added - hopefully it explains what to do.

This is the Cooper RF9542.

In the Endpoint 0, you should see CONFIGURATION. There will be a green + button which you need to click on to add the parameter.

You will then get a screen along the following lines -:

Fill in the exact same channel name (ie with config_decimal) and add the parameter=XX where XX is the parameter number.

That’s it… If there are options in the parameter configuration, the database will create a channel with these options when the database is exported. You can see this if you go and click on the export button at the top of the page -:

When you’re done, click the request approval button and I’ll take a look. I try and do an export into the binding once or twice a week…

1 Like

Fantastic! Thanks @chris this is exactly what I needed. :+1:
I have updated the GE 45605 and ‘requested review’.

Please remind me on the next steps - when the DB is exported what do I need to do to see the updates?
I use .things files and .items files to mange my devices and am running OH2.x

Thanks to the info from Chris above I think we have what we need in order to update the WD200+ DB entry to expose the config params as channels.
Looking at the DB entry however it shows a red warning and a yellow warning so this may be a reason why the device is not being recognised for you.
I am not sure how to fix this unfortunately.

If I click on Configuration->Bindings->Z-wave Binding, the HS-WD200+ is not in the “Supported Things” list. So, I don’t believe the version of the database containing the entry is in this version of the binding and waiting will not solve the problem in this case. I assume we need to wait for Chris to export the DB to the binding and it’s not something I can do myself locally. Maybe I’ll try to peruse the source for the binding and try to determine what version of the DB is contained within it.

Update: Looking at the source for the z-wave binding in GitHub, I can see that homeseer_hswd200 is not in the ESH-INF/things directory and the last commit to the master branch was 5 days ago. Looking in the DB, the device does exist was created 4 days ago, but it contains 2 errors. I’m going to register on the DB site and ask for permission to update as the errors seem trivial to fix.

When I review the database I will resolve these - you won’t be able to resolve them yourself.

As I said above, I do an export once or twice a week - otherwise I’d spend all my time just maintaining the database :frowning: . Probably I’ll do this tomorrow.

@nealg Looks like Chris has updated the WD200+ entry in the DB. I am not sure of the steps to import the latest device changes - possibly just delete the thing and re-add it but I may be wrong. Anyway, you may have more luck adding it to now the errors are fixed.