New HTTP binding in OH3 - systematic invalid URI error message

Hello everyone,

I’m in the process of migrating to OH3 and one of the step is to migrate my HTTP stuff to the new HTTP binding. And I’m stuck at the very beginning with an erroe that don’t know how to interpret.

I installed the HTTP binding, created a thing to get access to the file I’m interested in and this is how it looks like:

UID: http:url:ecodevicesstatusXML
label: Eco Device Status
thingTypeUID: http:url
  ignoreSSLErrors: false
  refresh: 30
  commandMethod: GET
  timeout: 3000
  bufferSize: 2048
  - id: compteurgaz
    channelTypeUID: http:number
    label: Compteur Gaz
    description: ""
    configuration: {}

And I get the follow error in the log file immediately (while the thing appears nicely “online”):

2021-01-09 18:45:18.599 [WARN ] [ttp.internal.http.RefreshingUrlCache] - Creating request for '' failed: Invalid URI host: null (authority: null)

I have checked that the URL I use is accessible from the openhab machine.

Any suggestion of where to look? Thanks in advance.

Did you try

I tried at least 5 times yes, but now it seems that it just worked… Not sure what happened…

Thanks a lot for the super fast answer.