New Nest 2.2 Binding 409 Error

Since upgrading, I’m trying to configure the thing I created to gain access to the Nest API and I’m getting the following error:

2017-12-19 17:11:26.660 [hingStatusInfoChangedEvent] - ‘nest:account:nest_account’ changed from UNKNOWN: Starting poll query to OFFLINE (CONFIGURATION_ERROR): Token is invalid and could not be refreshed: Pincode is empty

Anyone else experiencing this?

It works just fine for me @lysol. Did you also follow the authorization instructions to setup a Product and getting a Pincode?

hmmm… I can get a new pin code all day long. For some reason, the binding isn’t getting an access token from my provided product id, product secret, and pin code. Do I have to do something different in the nest developer page with the new binding?

This is my thing btw…

Bridge nest:account:nest_account [ productId="", productSecret=“mysecrethere>” ]

Then in PaperUI, the thing shows up prepopulated with the product id and the product secret I typed in the nest.thing file and I enter the pin code in Paper UI and click the check mark. That’s when I get the error.

I removed the config file from /var/lib/openhab2/config/org/openhab/nest.conf and restarted the openhab2 service to verify it is getting populated from the config file at /etc/openhab2/services/nest.cfg which it is.

I see you are using files based configuration. So you’ll also need to store the accessToken in the .things file or it will get lost.

The easiest way is probably to first obtain the token using Paper UI by configuring a Nest Account (with the Pincode). Then you can find the access token in the Nest Account when viewing the details and clicking “Show More”. Then delete the Nest things from Paper UI and use the accessToken for your Nest things in the .things file.

1 Like

I had tried at one point to add pinToken="" in my .thing file with no success of the pin token being successfully used. I just tried accessToken="" and now the thing doesn’t show in paper ui anymore.

Where at in paper ui are you referring to “configuring a Nest Account”?

I just uninstalled the nest binding, removed the config files, and reinstalled it with the same behavior.

EDIT - I would like to add that after reinstalling it, there are no services config files anymore. I assume that those were left over from the old nest binding.

Paper UI -> Inbox -> Big Plus (+) Action Button -> Nest Binding -> Add Manually -> Nest Account

nest.cfg is for the openHAB 1.x binding and unused by the new binding.


That got me up and running. Thanks. I just realized that all the temps are in celsius… lol. Looks like I either uninstall the binding and install the .jar someone thankfully created that shows in fahrenheit or wait for a future fix.

Thanks Again!

Great! And enjoy the fahrenheit JAR I’ve created! :wink:

1 Like

Hahahaha… That was you??? Thank you so much!!

Yes but it does not contain several bugfixes so it may be a bit buggier than what is part of OH 2.2.0 now. Maybe I just need to create a new one then!

Quick side question… Do you know why the battery health status is a switch?

Also, is there not a “Last Connection” channel? I have a status page in Habpanel I like to get a quick overview of things in the house and that was a nice thing to see to make sure what I wasn’t seeing old data. It was the last time a Nest device connected with their servers.

It’s reusing a so called systemwide channel that is the same on a lot of bindings:

low-battery system.low-battery Switch Battery Represents a low battery warning with possible values on/off.

There are still some more channels that need to be added and this may be one of them!

Here’s a org.openhab.binding.nest-2.2.0-fahrenheit.jar with all the features and fixes as in the final openHAB 2.2.0 release but using Fahrenheit instead of Celsius.


Thank you for this! May I suggest we add this to the Nest Binding details in the User Manual? This bit wasn’t so clear for me, perhaps it will help others as well?