Hi there

Went to order an RFXTRX433e last week to control some Somfy blinds and the seller informed me that the device is been replaced with the RFXTRX433XL. Anybody have any ideas if a new binding might be required for this new item or will the existing RFXTRX binding(s) work with it?


The RFXtrx433XL has the same receiver and transmitters as the RFXtrx433E and is able to transmit at 433.42MHz for Somfy RTS and SIMU.
The interface protocol is the same for all RFXtrx devices and the existing RFXTRX binding should operate if build using the latest RFXtrx SDK. The 6th byte in the Set Mode command should be 0x53 if the latest SDK is implemented.

you got this thing to work?
Got the same, but cannot seem to get it going.

Yes, I got it to work. No problems.

Can you explain to me how?
Cause all thing i found and tried are not working, or want to connect on ttyUSB0, but mine is on ttyUSB1.

It’s quite some time ago since I initially setup my old RFXCOM device, I just plugged in my new device and it was picked up by my Pi immediately.

Maybe the below link might help?

Will check, my pi recognises it aswell, only i cannot select it in the things setup.

well, don’t know how to fix this, but everytime i connect this to my pi running arch linux arm, my zwave stick and dsmr go offline, and i get Serial Error: Port {0} does not exist on all devices.
dsmr cable -> /dev/ttyUSB0
zwave stick -> /dev/ttyACM0
rfxcom -> /dev/ttyUSB1

i tried creating a bridge file:

Bridge rfxcom:bridge:usb1 "RFXCOM Controller" @ "Local" [ serialPort="/dev/ttyUSB1" ]

i tried setting a udev rule for it, content of the 50-usb-serial.rules:

SUBSYSTEM==“tty”, ATTRS{idVendor}==“0403”, ATTRS{product}==“RFXtrx433XL”, ATTRS{serial}==“DO2VI16Z”, SYMLINK+=“USBrfxcom”

even tried this, but don’t know where to add the JAVA_ARGS

my openhab runs as root, so permissions wouldn’t be a problem?

[49282.684681] usb 1-1.3: new full-speed USB device number 6 using dwc_otg
[49282.840816] usb 1-1.3: New USB device found, idVendor=0403, idProduct=6015
[49282.845844] usb 1-1.3: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[49282.850785] usb 1-1.3: Product: RFXtrx433XL
[49282.855819] usb 1-1.3: Manufacturer: RFXCOM
[49282.859671] usb 1-1.3: SerialNumber: DO2VI16Z
[49282.869964] ftdi_sio 1-1.3:1.0: FTDI USB Serial Device converter detected
[49282.873812] usb 1-1.3: Detected FT-X
[49282.878293] usb 1-1.3: FTDI USB Serial Device converter now attached to ttyUSB1

i added to /etc/default/openhab and openhab2 and root the following to JAVA_ARGS:
ls -l /dev/tty*
crw-rw---- 1 root uucp 166,  0 Sep 14 20:52 /dev/ttyACM0
crw-rw---- 1 root uucp 204, 64 Sep 14 20:52 /dev/ttyAMA0
crw-rw---- 1 root uucp 188,  0 Sep 14 20:52 /dev/ttyUSB0
crw-rw---- 1 root uucp 188,  1 Sep 14 20:52 /dev/ttyUSB1

well after trying for almost 2 weeks now, i give up, nothing works after i connect the RFXtrx433XL, network binding fails, dsmr binding fails, zwave binding fails, evohome binding fails, openweathermap binding fails.
And when i try to add the rfxcom binding manual, i only can select /dev/ttyUSB0, nothing else.

Even after rebooting, openhab doesn’t even start automaticly.