NEW RPi OS install - error in installation guild (Wget) in Documentation / Raspberry Pi / Instantiation of openhab

  • Platform information:
    • Hardware: RPi 4
    • R PI OS (recommended) Release date: March 4th 2021 Kernel version: 5.10 Size: 2,868MB
    • Java Zulu 11 installed but not the problem
    • openHAB version: Stable 3.0.1 (or -2)
  • Following the instructions in the undeer the Rasberry Pi, Manual setup down to Install of openHab.
    People have not been able understand the above link description so here is a link to the Documenation / Raspbery Pi / Instation of openhab

from the terminal log :-

pi@pg-p4-2-407:/opt/jdk $ wget -qO - ‘’ | sudo apt-key add -
pi@pg-p4-2-407:/opt/jdk $ sudo apt-get update
Get:1 buster InRelease [15.0 kB]
Hit:2 buster InRelease
Fetched 15.0 kB in 1s (17.4 kB/s)
Reading package lists… Done

As stated the wget reply’s “OK”

But when I next do a “sudo apt-get update” only has the inrelease buster repository and none of the Openhab repositry.

The wget statment does not work says OK, but has not included the entries in to the repo list for “apt-get”

Had run wget with out -qO but due to a small accident lost the RPI 4 and 1TB hdd to Coke spillage.

(How luck - RPI4 and 1TB hdd are fine)

That the error is to do with the “username=openhab” .

From terminal (using modified “wget” removed -qO)

wget - ‘’ | sudo apt-key add -
–2021-04-05 04:04:51-- http://-/
Resolving - (-)… failed: Name or service not known.
wget: unable to resolve host address \u2018-\u2019
–2021-04-05 04:04:51--
Resolving (…
Connecting to (||:443… connected.
HTTP request sent, awaiting response… 200 OK
Length: unspecified [application/octet-stream]
downloadSubjectPublicKey?username=openhab: Permission denied

Cannot write to \u2018downloadSubjectPublicKey?username=openhab\u2019 (Permission denied).
gpg: no valid OpenPGP data found.

There is no user on the RPI at this point called “openhab” only user "root / pi /other specific to RPI OS)

from terminal :-

cat /etc/passwd
list:x:38:38:Mailing List Manager:/var/list:/usr/sbin/nologin
gnats:x:41:41:Gnats Bug-Reporting System (admin):/var/lib/gnats:/usr/sbin/nologin
systemd-timesync:x:100:102:systemd Time Synchronization,:/run/systemd:/usr/sbin/nologin
systemd-network:x:101:103:systemd Network Management,:/run/systemd:/usr/sbin/nologin
systemd-resolve:x:102:104:systemd Resolver,:/run/systemd:/usr/sbin/nologin
avahi:x:108:113:Avahi mDNS daemon,:/var/run/avahi-daemon:/usr/sbin/nologin
lightdm:x:109:114:Light Display Manager:/var/lib/lightdm:/bin/false
pulse:x:111:119:PulseAudio daemon,:/var/run/pulse:/usr/sbin/nologin
hplip:x:113:7:HPLIP system user,:/var/run/hplip:/bin/false
colord:x:114:123:colord colour management daemon,:/var/lib/colord:/usr/sbin/nologin
systemd-coredump:x:996:996:systemd Core Dumper:/:/usr/sbin/nologin

No openhab user configure at this point in the install from a clean OS starting point.

the -qO - is neeses to make the command function. Basically you changed the command & broke it. I just tried it and it functions as expected.

wget -qO - '' | sudo apt-key add -

Your post is confusing. What do you mean by that? Quote the link.

There is no such thing in standard RPi OS.
Sounds like you use openHABian ?

Blockquote the -qO - is neeses to make the command function. Basically you changed the command & broke it. I just tried it and it functions as expected.

wget -qO - '' | sudo apt-key add -

Had run the instruction as stated abd ogot the “OK” reply but when I idid a install for apt-transporrt-https (next line in the instruction.

There was no entires and only 2 Buster entries.

So having read the wget options the -qO read to me as just stopping error messages

says the same thing – Getting The Output Of A GET request On The Command Line (You need to put the URL and parameters inside “” if using more than 1 parameter) To show full connection information and errors too: Options used: -q turns off the output of log, including error information.-O -, equivlalent to -O /dev/stdout, means dump the web…

Sorry but that makes your answer in error (does not change fuctionallity)

You did not read the big RPI foundation forum whrere they where telling all that as Rasbian (not really even the correct name for the OS as it was named for some other project - all from memory) was no more it was Rasberry Pi OS from now on about the relase of PI4 (will have to look it up on their forums to be able to give you the full. see what the Foundation says there are three version of RPI OS


OK i accept that a link to the problem would help so here it is :-

the wget is in the first black box under the “instation of openHAB”

Sorry that you find my English is not up to standard but as a GB born person with dislexia (word Blindness) IF YOU DO NOT KNOW that means I have difficulty with spelling and sentence creation.

What was formerly RASPbian is now called Raspberry Pi OS.

guess what, I did.

That’s a pretty ancient document you better ignore, it’s probably not up to date any more.
Better go install openHABian. It’s based on latest R Pi OS.

It’s for the manual instaltion of OPENHAB as I want to be able to use the GUI on the PI as I have problems with the CLI. Which means I will be having problems within openhab.

Can not agree it’s not out of date it does give the correct instrutions for ZULU 11 for Java.

Just because the wget does not add the repository entries when a NEW FRESH install of the RPI OS is used it does work on old buster installs, just not the clean install from Pi Foundation.