New Setup not working direct after installation

Hello,
I just installed a new Eclipse setup with openhab-main. After everything is installed Eclipse opens. If I run it out of the app.bndrun I get the following error:

It does start after all with no more errors in the console. However there is no standard webpage shown on

localhost:8080

If I run then again Resolve I get the following errors:

image

I guess I need to update “org.apache.tomcat-embed-jasper”. But how do I do that? I am still puzzled as this is a complete clean installation.

Or any other suggestions?

As nobody is capable to help me so far, I tried to get it together. I developed successful a binding 6 months ago and was thinking to contribute a new one again. As my old development environment is not working anymore and as it was with 3.0, I thought to start from scratch. I think it is still too complicated to provide a complete running Dev environment even for someone who did it once but is not doing it on a daily basis. Isn’t there a better way to deploy a complete Dev setup packed with everything what is needed?

However I found out that if I don’t update the optional stuff when I hit Resolve it does run. On the first try the web page appears. After a while and when I try to include my binding and hit Resolve the error appears again and I end up on blank white on localhost:8080.

To be a bit more precise what I did:

  1. I reinstalled Eclipse with the Omph installer on Windows 10 as described in the developer guide
  2. I just checked out openhab-development
  3. I have Java 11 JDK already installed on my PC
  4. I do have already Maven installed 3.x → which is the correct version I might need with the actual 3.2 Snapshot?
  5. After I try to add my binding in the workspace and hit Resolve I end up trapped with the error and a blank page.

Any further help?

Sorry, but still now success. I am trying now since almost a week without success.
Any help from @hilbrand or @wborn please?
It is impossible to get it running under Windows.