New setup question: Does the Java 64 bit still not work with the Z-Wave?

zwave
rpi
hardware
Tags: #<Tag:0x00007f1826216bb0> #<Tag:0x00007f1826216a20> #<Tag:0x00007f1826216890>

(michael maceachran) #1

I am new to this, and I am looking to start fresh. I am looking for hardware recommendations. I am a Linux/Java guy by profession, so I was a little put off by reading that Z-Wave will not work on a 64bit implementation.

I was looking at the RPi3 but that is 64bit.

I am looking to just start with lights, but want to move to home security, video surveillance for the house, etc… Will the RPi handle that? Or should I look into a dedicated desktop for this?

I am looking for a minimum viable setup, but also one that can expand for the whole house.


(Chris Jackson) #2

I don’t think this is a general “64 bit” issue with Z-Wave. I think the issue you might be referring to is that there is (or maybe, was) no 64 bit serial driver for ARM machines. I use a 64 bit processor, but it’s Intel based - no problem…


(michael maceachran) #3

That can’t mean that Z-Wave does not work on say Android devices does it? I did a couple of personal apps, but i never did any professional apk’s. Or does the Android app just use the 32bit version?


(Chris Jackson) #4

I’m not sure that OH runs under Android does it? I know some people were looking at this a while ago, so maybe it’s working, but I’ve not seen it, or tried it myself.

Found this -:


(Jim) #5

I have openHAB with z-wave running on both RPi3 and Odroid C2 (both 64 bit) without problem. There were some problems earlier with the 64 bit implementation of the serial stuff, but it seems to be working now as long as your systems are using current OSes. There are some library version issues if running older OSes.

As for Android, I use it only as a client with the mobile client app.


(Nicola) #6

Hi,
what version of raspbian are you using that works correctly on RPi3? I’m migrating my openhab installation from centOS to RPi3 and I have Z-wawe USB-stick, so for me it’s important to have the right version.

OT: how do you feel with Odroid? It seems much better than RPi3, do you confirm it?
Thanks,