New Somfy Tahoma Device

Hello All,

I’ve just got new somfy controlled shutters and ordered the next day the somfy connectivity kit.
Now I’ve installed everything including the Somfy Tahoma binding and the shutters are not discovered.
So I follow now the instructions form the Somfy Tahoma documentation, by posting the logs from the binding discovery.

55075 2022-07-26 14:03:07.071 [INFO ] [very.SomfyTahomaItemDiscoveryService] - Detected a new unsupported device: Shutter with widgetName: DynamicShutter
55076 2022-07-26 14:03:07.071 [INFO ] [very.SomfyTahomaItemDiscoveryService] - If you want to add the support, please create a new issue and attach the information below
55077 2022-07-26 14:03:07.071 [INFO ] [very.SomfyTahomaItemDiscoveryService] - Device definition:
55078 Commands: { close (params: 0); goToAlias (params: 1); identify (params: 0); open (params: 0); saveAlias (params: 1); setClosure (params: 1); setName (params: 1); stop (params: 0); }
55079 States: {core:AvailabilityState (values: available, unavailable); core:ClosureState (values: ); core:ErrorState (values: ); core:ErrorsState (values: ); core:FirmwareHashState (values: ); core      :FirmwareRevisionState (values: ); core:NameState (values: ); core:NewFirmwareAvailableState (values: ); core:OpenClosedState (values: closed, open); core:ReachedAliasesState (values: ); core:      RemovableState (values: ); core:SignalQualityState (values: ); }
55080 2022-07-26 14:03:07.072 [INFO ] [very.SomfyTahomaItemDiscoveryService] - Current device states:
55081 {name='core:NameState', type=3, value=Blinds Left}
55082 {name='core:AvailabilityState', type=3, value=available}
55083 {name='core:ErrorsState', type=10, value=[]}
55084 {name='core:FirmwareRevisionState', type=3, value=5145654A14}
55085 {name='core:FirmwareHashState', type=3, value=5145654A14}
55086 {name='core:OpenClosedState', type=3, value=open}
55087 {name='core:ClosureState', type=1, value=0.0}

I would be thankful for any help…:slight_smile:

Thank you in advance.

Hello again,

Still no solution…
To me it seems like I need to add my new device in some device repository. Maybe somebody can point me to the location of a file, if any, where I could add my device… Or am I completely mistaking?
Again, I would be glad of any help.

Hello, have you tried the lastest openHAB and the latest somfytahoma binding? Shutters are supported…

Hi Ondrej,
since the latest update of the Tahoma Box, the connection is down since them. Is this a common problem?

unfortunately I cannot confirm the problem is a common one, but might be. I am using the official local API with the Tahoma box and I have no issues at all.
Have you tried the debug or trace mode to find out what is happening there?

Hi Ondrej,

I know this is an old thread but I have the problem that I can’t connect Openhab 3.4 with the Tahoma binding to my Tahoma box. I keep getting the message “Cannot get login cookie” when using or

The credentials are correct, the app on my phone is working and I called Somfy to check on my account but there is no block or ban on my account.

The refresh rate is 3600 seconds, so I don’t think it’s a rate limiting issue.

Any suggestions?


maybe Somfy has changed something, can you enable the trace log and send it to me, please?
I do not use Tahoma cloud anymore.

Hi Ondrej,

I’ll try to reinstall and if that doesn’t work I’ll create a log.

Just out of curiosity: if you aren’t using the Tahoma cloud anymore, how did you connect your Smofy/Tahoma equipment to OpenHab then?


So I reinstalled the module, it took the old settings and all came online and started working. No clue why, but I am happy.

Hi, I am glad it works now. I am using the developer mode, so only authentication goes against cloud and the rest of the communication goes over the LAN.
No throttling, a bit faster, I recommend it to everyone.

1 Like