New z-wave device? show home ZW37

Hello, I purchased a couple of 2 channel z-wave switches on eBay from an organization called inovelli. When I included it with my z-wave network it said that the device was not in the database. I contacted the manufacturer who I guess added it to the z-wave alliance site (I couldn’t find it there prior) and he gave me the XML file that I assume I can use to add to the database. I tried registering for an account on www cd-jackson com to add it to the database, but I do not have the blue add button shown in the screenshots, and to be honest I am very new to all of this and I wanted to confirm that this is not just a clone of some other manufacturer that needs to be associated. I saw that the maintainer of the database Chris responds here a lot so I hope this is the best place to post it.

I can provide the XML if needed
Here is a link to the product on eBay:
Here is a link to the product on Z-Wave Alliance:

I can give you access to the database - just let me know your user name.

That said, it’s highly unlikely the manufacturer will provide the information needed - the XML file comes from OH itself if the device is successfully initialised by OH - it will be in the etc/zwave folder in OH1, or the userdata/zwave folder in OH2…

Thank you sir, my username is oedo808 and I can pull the XML file from OH2 to add the device.

Thanks Tony - I’ve updated your access so you should be able to edit - any problems, just let me know…


Thank you Chris, I have uploaded the device and submitted a review request. Once you have added it do I just update openhab2 with apt-get? I installed the z-wave binding through Paper UI.

Thanks for all your help!

Yes - once the binding is updated, you can just update to the latest binding. Just uninstall and re-install again in PaperUI and it will pick up the latest…

1 Like

I’m just building a new Raspberry PI with OpenHAB. I also just purchased the Inovelli 2-channel plug-in module mentioned in this post. It’s not being recognized – it comes up as “Unknown Device”. I tried the “apt-get update” mentioned but it doesn’t seem to have made a difference. I deleted and re-added the device and it still shows as unknown once re-discovered. Can I assume that the device should now be in the central database since this question was resolved in December 2016? Or is there some other action that I need to take so this device can be recognized?

I was just looking through the list of devices and I see “zwave:willis_zw37_00_000” which is identified as this Inovelli switch, but in my system it’s identified as “zwave:device:7b4a5172:node3” with the default name “Z-Wave Node 3 (0312:B221:251C:20.17)”. Did the manufacturer change an identifier that’s affecting recognition? The properties show
zwave_class_basic ROUTING_SLAVE
zwave_class_generic BINARY_SWITCH
zwave_frequent false
zwave_neighbours 1
zwave_version 20.17
zwave_listening true
zwave_plus_devicetype ON_OFF_POWER_SWITCH
zwave_deviceid 9500
zwave_nodeid 3
zwave_routing true
zwave_beaming true
zwave_class_specific POWER_SWITCH_BINARY
zwave_manufacturer 786
zwave_devicetype 45601

I too have purchased a few of the Inovelli devices and have been able to add it to my Openhabian openHAB 2.1.0-1 (Release Build) RPi via the Z-Stick Gen5, but it says it is not in the database. What is the process to add it to the database?

I have removed and re-installed them and they still show as an “Unknown Device” for the two of them.

Tim, you did not get a response… have you figured it out?


I don’t think this device is included in 2.1 database. I’d suggest to use the latest snapshot.

Thanks for the quick response Chris. I was over reading your site -

I see NZW37 has been added and was trying to understand how to update my installation with the database?

Per your suggestion I am looking into updating to the latest Snapshot.

I too am a sys eng and am doing this on my spare time. I’m very excited at where OH2 has gone. I appreciate all the work and hope to contribute where able.
I’m working on RTSP on the HaBPanel.



I have upgraded to OpenHAB 2.2 Snapshot and NZW37 2-Channel Dual Smart Plug is listed and works. Nice work. I’ll have to add the 1-Channel version from Inovelli. I purchased both the single and double outlet versions.

Glad it’s working. If you register on the site, drop me an email and I’ll update your access so you can add/edit.


Ticket was created. I can send an email too.


I updated your access last night, so you should be good to go :slight_smile: .

I see I’m late to the party in replying, but yes I got it to work and I did it by upgrading to the snapshot. It was an easier process than I expected. There was an option in the GUI.

Hi Chris,

I’d like to migrate to OpenHAB some day. I am testing OpenHAB 2.3.0 on A Raspberry Pi OpenHabian. I am using a Aeotec ZStick as Zwave controller whcih was discovered properly. However, my Inovelli NZW37 ZWave smart plug was not and displayed as undefined. The ZWave binding version 2.3.0 show that it is indeed supported. Would you be able to enlighten me?

I have downloaded the xml file from the manufacturer. I am not sure how to use it to config devices locally.

Thanks for the good work. Regards

I would suggest to update to a more recent version. 2.3 is now very old and if the device was added in the last 5 months, you need to use a newer version or it will not be detected by the binding.

Thanks for the update. Isn’t 2.3.0 the most recent version? Just discovered the problem was with the ZStick’s previous metwrol configs. After resetting it back to factory default, OpenHab discovered the plug and performed as expected.

It’s the most recent stable version. But that is pretty old related to @chris’s speed on developing the zwave binding. :grinning:
Take a look at the Milestone builds or even Snaphots.