New Z-Way Binding

Tags: #<Tag:0x00007f433644a428>

Anyone else having problems installing zway under latest oh2 snapshot?

/S

no, but possibly you’re missing the serial binding => feature:install openhab-transport-serial

After upgrading from 2.1 STABLE to latest SNAPSHOT i have numerous warnings like:

11:18:05.538 [WARN ] [core.internal.events.OSGiEventManager] - Dispatching event to subscriber 'org.eclipse.smarthome.core.thing.internal.CommunicationManager@1c0a912' takes more than 5000ms.

I believe there is something linked to Z-Way binding.
I’m running latest openHAB 2.2 SNAPSHOT, Z-Way binding 2.2.0.201711121147 and openHAB Connector 0.1.7.
The DEBUG log:

11:20:49.272 [WARN ] [core.internal.events.OSGiEventManager] - Dispatching event to subscriber 'org.eclipse.smarthome.core.thing.internal.CommunicationManager@1c0a912' takes more than 5000ms.
11:20:49.594 [DEBUG] [g.zway.handler.ZWayZWaveDeviceHandler] - Handle update for channel: sensorMeterW-ZWayVDev_zway_49-0-50-2 with new state: 3.52
11:20:49.634 [DEBUG] [g.zway.handler.ZWayZWaveDeviceHandler] - Refresh last update for Z-Wave device
11:20:53.977 [DEBUG] [.discovery.ZWayDeviceDiscoveryService] - Z-Way device found with 3 virtual devices - device types: switchBinary, sensorMultilevel, sensorMultilevel
11:20:54.596 [WARN ] [core.internal.events.OSGiEventManager] - Dispatching event to subscriber 'org.eclipse.smarthome.core.thing.internal.CommunicationManager@1c0a912' takes more than 5000ms.
11:20:57.238 [DEBUG] [g.zway.handler.ZWayZWaveDeviceHandler] - Handle update for channel: switchPowerOutlet-ZWayVDev_zway_40-0-37 with new state: OFF
11:20:57.304 [DEBUG] [g.zway.handler.ZWayZWaveDeviceHandler] - Refresh last update for Z-Wave device
11:21:00.489 [DEBUG] [.discovery.ZWayDeviceDiscoveryService] - Z-Way device found with 10 virtual devices - device types: switchControl, switchBinary, sensorMultilevel, sensorMultilevel, sensorMultilevel, sensorMultilevel, sensorMultilevel, sensorBinary, sensorBinary, sensorBinary
11:21:02.242 [WARN ] [core.internal.events.OSGiEventManager] - Dispatching event to subscriber 'org.eclipse.smarthome.core.thing.internal.CommunicationManager@1c0a912' takes more than 5000ms.
11:21:03.762 [DEBUG] [g.zway.handler.ZWayZWaveDeviceHandler] - Checking link state of channel: Window Sensor - Bedroom
11:21:03.784 [DEBUG] [g.zway.handler.ZWayZWaveDeviceHandler] - Refresh items that linked with channel: Window Sensor - Bedroom
11:21:08.147 [DEBUG] [g.zway.handler.ZWayZWaveDeviceHandler] - Handle update for channel: switchPowerOutlet-ZWayVDev_zway_46-0-37 with new state: OFF
11:21:08.185 [DEBUG] [g.zway.handler.ZWayZWaveDeviceHandler] - Refresh last update for Z-Wave device
11:21:13.154 [WARN ] [core.internal.events.OSGiEventManager] - Dispatching event to subscriber 'org.eclipse.smarthome.core.thing.internal.CommunicationManager@1c0a912' takes more than 5000ms.
11:21:13.857 [DEBUG] [g.zway.handler.ZWayZWaveDeviceHandler] - Checking link state of channel: Current power (#42)
11:21:13.880 [DEBUG] [g.zway.handler.ZWayZWaveDeviceHandler] - Refresh items that linked with channel: Current power (#42)
11:21:14.638 [DEBUG] [g.zway.handler.ZWayZWaveDeviceHandler] - Handle update for channel: sensorMeterW-ZWayVDev_zway_74-1-50-2 with new state: 0
11:21:14.691 [DEBUG] [g.zway.handler.ZWayZWaveDeviceHandler] - Refresh last update for Z-Wave device
11:21:19.641 [WARN ] [core.internal.events.OSGiEventManager] - Dispatching event to subscriber 'org.eclipse.smarthome.core.thing.internal.CommunicationManager@1c0a912' takes more than 5000ms.
11:21:20.703 [DEBUG] [g.zway.handler.ZWayZWaveDeviceHandler] - Handle update for channel: switchPowerOutlet-ZWayVDev_zway_44-0-37 with new state: OFF
11:21:20.739 [DEBUG] [g.zway.handler.ZWayZWaveDeviceHandler] - Refresh last update for Z-Wave device
11:21:25.704 [WARN ] [core.internal.events.OSGiEventManager] - Dispatching event to subscriber 'org.eclipse.smarthome.core.thing.internal.CommunicationManager@1c0a912' takes more than 5000ms.
11:21:27.457 [DEBUG] [g.zway.handler.ZWayZWaveDeviceHandler] - Handle update for channel: switchPowerOutlet-ZWayVDev_zway_74-2-37 with new state: OFF
11:21:27.559 [DEBUG] [g.zway.handler.ZWayZWaveDeviceHandler] - Refresh last update for Z-Wave device
11:21:32.462 [WARN ] [core.internal.events.OSGiEventManager] - Dispatching event to subscriber 'org.eclipse.smarthome.core.thing.internal.CommunicationManager@1c0a912' takes more than 5000ms.
11:21:34.335 [DEBUG] [.discovery.ZWayDeviceDiscoveryService] - Z-Way device found with 3 virtual devices - device types: switchControl, switchBinary, switchBinary
11:21:37.468 [DEBUG] [g.zway.handler.ZWayZWaveDeviceHandler] - Handle update for channel: switchPowerOutlet-ZWayVDev_zway_74-1-37 with new state: OFF
11:21:37.517 [DEBUG] [g.zway.handler.ZWayZWaveDeviceHandler] - Refresh last update for Z-Wave device
11:21:40.718 [DEBUG] [.discovery.ZWayDeviceDiscoveryService] - Z-Way device found with 4 virtual devices - device types: switchControl, sensorMultilevel, thermostat, battery
11:21:42.473 [WARN ] [core.internal.events.OSGiEventManager] - Dispatching event to subscriber 'org.eclipse.smarthome.core.thing.internal.CommunicationManager@1c0a912' takes more than 5000ms.
11:21:43.928 [DEBUG] [g.zway.handler.ZWayZWaveDeviceHandler] - Refresh last update for Z-Wave device
11:21:48.149 [DEBUG] [g.zway.handler.ZWayZWaveDeviceHandler] - Handle update for channel: battery-ZWayVDev_zway_51-0-128 with new state: 78
11:21:48.184 [DEBUG] [g.zway.handler.ZWayZWaveDeviceHandler] - Refresh last update for Z-Wave device
11:21:50.310 [DEBUG] [g.zway.handler.ZWayZWaveDeviceHandler] - Checking link state of channel: Aeotec Electric Meter (#42)
11:21:50.334 [DEBUG] [g.zway.handler.ZWayZWaveDeviceHandler] - Polling for device: Aeotec Home Energy Meter not possible (channel Aeotec Electric Meter (#42) not linked
11:21:50.361 [DEBUG] [g.zway.handler.ZWayZWaveDeviceHandler] - Refresh last update for Z-Wave device
11:21:53.155 [WARN ] [core.internal.events.OSGiEventManager] - Dispatching event to subscriber 'org.eclipse.smarthome.core.thing.internal.CommunicationManager@1c0a912' takes more than 5000ms.
11:21:53.466 [DEBUG] [g.zway.handler.ZWayZWaveDeviceHandler] - Handle update for channel: switchPowerOutlet-ZWayVDev_zway_40-0-37 with new state: OFF
11:21:53.506 [DEBUG] [g.zway.handler.ZWayZWaveDeviceHandler] - Refresh last update for Z-Wave device
11:21:56.610 [DEBUG] [g.zway.handler.ZWayZWaveDeviceHandler] - Checking link state of channel: Door Sensor - Front Door
11:21:56.631 [DEBUG] [g.zway.handler.ZWayZWaveDeviceHandler] - Refresh items that linked with channel: Door Sensor - Front Door
11:21:58.471 [WARN ] [core.internal.events.OSGiEventManager] - Dispatching event to subscriber 'org.eclipse.smarthome.core.thing.internal.CommunicationManager@1c0a912' takes more than 5000ms.
11:21:59.803 [DEBUG] [g.zway.handler.ZWayZWaveDeviceHandler] - Handle update for channel: switchPowerOutlet-ZWayVDev_zway_46-0-37 with new state: OFF
11:21:59.849 [DEBUG] [g.zway.handler.ZWayZWaveDeviceHandler] - Refresh last update for Z-Wave device
11:22:04.806 [WARN ] [core.internal.events.OSGiEventManager] - Dispatching event to subscriber 'org.eclipse.smarthome.core.thing.internal.CommunicationManager@1c0a912' takes more than 5000ms.
11:22:07.483 [DEBUG] [g.zway.handler.ZWayZWaveDeviceHandler] - Handle update for channel: switchPowerOutlet-ZWayVDev_zway_50-0-37 with new state: OFF
11:22:07.522 [DEBUG] [g.zway.handler.ZWayZWaveDeviceHandler] - Refresh last update for Z-Wave device
11:22:09.008 [DEBUG] [g.zway.handler.ZWayZWaveDeviceHandler] - Starting polling for device: Window Sensor - Balcony
11:22:09.036 [DEBUG] [g.zway.handler.ZWayZWaveDeviceHandler] - Checking link state of channel: Window Sensor - Balcony
11:22:09.078 [DEBUG] [g.zway.handler.ZWayZWaveDeviceHandler] - Refresh items that linked with channel: Window Sensor - Balcony
11:22:12.485 [WARN ] [core.internal.events.OSGiEventManager] - Dispatching event to subscriber 'org.eclipse.smarthome.core.thing.internal.CommunicationManager@1c0a912' takes more than 5000ms.
11:22:12.986 [DEBUG] [.discovery.ZWayDeviceDiscoveryService] - Z-Way device found with 4 virtual devices - device types: sensorBinary, sensorBinary, sensorBinary, battery
11:22:14.855 [DEBUG] [g.zway.handler.ZWayZWaveDeviceHandler] - Starting polling for device: Window Sensor - Kitchen
11:22:14.877 [DEBUG] [g.zway.handler.ZWayZWaveDeviceHandler] - Checking link state of channel: Fibaro Battery (#61)
11:22:14.901 [DEBUG] [g.zway.handler.ZWayZWaveDeviceHandler] - Refresh items that linked with channel: Fibaro Battery (#61)
11:22:16.217 [DEBUG] [g.zway.handler.ZWayZWaveDeviceHandler] - Handle update for channel: sensorMultilevel-ZWayVDev_zway_74-1-50-0 with new state: 0.37
11:22:16.254 [DEBUG] [g.zway.handler.ZWayZWaveDeviceHandler] - Refresh last update for Z-Wave device
11:22:21.222 [WARN ] [core.internal.events.OSGiEventManager] - Dispatching event to subscriber 'org.eclipse.smarthome.core.thing.internal.CommunicationManager@1c0a912' takes more than 5000ms.

On 2.1 STABLE I never noticed any warnings like that…
Does anybody have a clue?
@pathec Patrick, are you still maintining this binding?
Thanks

Hi @Mihai_Badea

I see similar Warnings in my upgraded Version (Build #1080). But I cannot see, whether it its related to the ZWay-Binding or another configuration.
I upgraded from #101x or something (I could have a look at it if needed).

I am running my openHAB2 on an Raspberry 3, but from time to time I have to restart the software to get it running again. It feels like with the new version the time for a restart of openHAB gets shorter and shorter. Even the Alexa service latency increases with the new version.

So like you I would like to know what causes this issue.

Where is your instance running on? I download and update every new snapshot-version via this script here (https://github.com/xsnrg/OpenHAB2-tools/blob/master/makeHAB). So it is a manual installation.

cheers

Running also on a RPi 3, but an apt installation.
I stayed a long time on STABLE, but I decided to try SNAPSHOT and it seems a little slow.

From what I can see those warnings appear related to Z-Way so that’s why I’m posting here.
I keep thinking to roll back to STABLE…

Well Ok.

I´ll see whether I can find some relations too.
I changed logging according to Log4j2 Sample Config

Same here, see OSGiEventManager / ThingLinkManager delays in OH 2.2 or https://github.com/eclipse/smarthome/issues/4419

So, yeah. My instance stops working after a short while. I did a rollback to 2.2.0-Snapshot Build #999.

This Version does its task for a while and needs a restart some days after its start, but until then it does its job.

Well, in the mean time I downgraded to STABLE.
openHAB 2.1 and Z-Way are running smoothly so I guess that the problem is between Z-Way binding and openHAB 2.2… Perhaps the binding must be updated.
Unfortunately, as @pathec didnt’t yet respond I’ll stick to 2.1.
Maybe Patrick is busy with other things and he didn’ t notice the thread…
Let’s hope he’ll find the time to look over this :pray:

Any chance that we see a fix here in the near future, @pathec ?
If you are not working on the project anymore, please let us know.
Thanks.

Could someone please tell me a version of Openhab, Z-Way Binding and OpenhabConnector that work together.

I am getting unknown and error showing in the OpenhabConnector debug screen. I have tried multiple different versions with no success with the connection staying working.

Further to the above, my system displays the below after a reboot. It can be seen that all devices are in error state for the openhab connector, I only get updates to openhab by polling the Z-Way Device.

I am running Openhab 2.1.0-1 Stable, Openhab Connector 0.1.7, Z-Wave 1.7.1, Razberry Firmware 2.3.6.

I have just done a total clean install and this issue persists, any help appreciated.

I’m using a RPi3 with Raspbian Jessie, openHAB 2.1.0 STABLE, raZberry firmware 2.3.6, openHAB connector 0.1.7 and everything works…

image

Thanks for the reply, the below seems to be the issue:

Callback execution error: TypeError: Cannot read property ‘error’ of undefined
at Function.http.request.error (automation/userModules/OpenHABConnector/index.js:403:107)

My setup is a RPI2 with the Razberry Board running z-wave. I then have a Ubuntu VM running Openhab. My Openhab is not on localhost per the logs rather http://192.168.80.2:8080, but I presume that is how it communicates?

Any ideas greatly appreciated. I started fresh yesterday with the Ubuntu VM. Considering doing the same with the RPI2 but seems excessive.

Hi,
I’m running:

  • openHAB 2.2.0-Snapshot Build #999
  • ZWay/RaZberry v2.3.6 (with the Shield on the Rasberry Pi 3)
  • OpenHAB Connector 0.1.7

But I have to restart my openHAB from time to time as it stops working after some days. But it isn’t quite working with newer openHAB-Snapshot versions.


I got the Errors only when I changed some things like:

  • item/thing-names in openHAB (are you linking them by hand or through the system? To do it by hand you have to disable the, how is it called, simple linking? switch in openHAB-PaperUI system preferences)
  • I think low battery in devices etc.

Perhaps it helps removing the connection between openHAB and ZWay and reestablish it (delete the configuration of the zway-binding and the openHAB-server in zway-openhab connector preferences).
But after this, of course, you have to reconfigure youre devices like you did it before.

regards
André

I went ahead and installed Openhab2 on the Raspberry Pi that z-wave runs on (localhost). Z-Wave Openhab connector immediately works in this configuration.

What I couldn’t get to work was have the Openhab Connector work correctly with a remote Openhab2 instance

As @pathec didn’t respond in a VERY long time I’m thinking that he dropped this project…
I’m considering switching from Z-Way to Z-Wave binding… but… OMG! :cry:

Yes it seems so. My setup is working ok now. I have had to install OH2 on my “Slave” RPI2 that has the z-wave Daughter Board on it and the Openhab Connector works perfectly with this “localhost” setup with instant update to OH2.

I am now setting up MQTT event-bus to send everything from this slave z-wave device to my main instance of OH2. Things are looking much better with instant update vs the waiting 60 seconds previously waiting for the polling to kick in. I have ended up losing a heap of configuration after re-imaging everything but as this is the base of the new system, seems worth it… regular snapshots from here forward to backup.

OFF TOPIC:
Why not sharing the razberry over network? https://community.openhab.org/t/share-z-wave-dongle-over-ip-usb-over-ip-using-ser2net-socat-guide/34895

1 Like

I just upgraded to 2.2 STABLE and Z-Way is working normally :blush:
For the ones interested I applied the following steps (not sure that the approach to update makes any difference or the STABLE is different from SNAPSHOTs I was trying)

  1. sudo apt-get remove openahb2
  2. sudo apt-get update
  3. sudo apt-get upgrade
  4. sudo reboot
  5. sudo apt-get install openhab2
  6. sudo systemctl enable openhab2
  7. sudo systemctl start openahb2

and, after waiting for the initial startup of openhab, now everything appears to run smoothly - including Z-Way :wink:

1 Like