New Z-Way Binding

binding
Tags: #<Tag:0x00007f6cefdff328>

(Mihai Badea) #221

Running also on a RPi 3, but an apt installation.
I stayed a long time on STABLE, but I decided to try SNAPSHOT and it seems a little slow.

From what I can see those warnings appear related to Z-Way so that’s why I’m posting here.
I keep thinking to roll back to STABLE…


(devTechi) #222

Well Ok.

I´ll see whether I can find some relations too.
I changed logging according to Log4j2 Sample Config


(Schnicki) #223

Same here, see OSGiEventManager / ThingLinkManager delays in OH 2.2 or https://github.com/eclipse/smarthome/issues/4419


(devTechi) #224

So, yeah. My instance stops working after a short while. I did a rollback to 2.2.0-Snapshot Build #999.

This Version does its task for a while and needs a restart some days after its start, but until then it does its job.


(Mihai Badea) #225

Well, in the mean time I downgraded to STABLE.
openHAB 2.1 and Z-Way are running smoothly so I guess that the problem is between Z-Way binding and openHAB 2.2… Perhaps the binding must be updated.
Unfortunately, as @pathec didnt’t yet respond I’ll stick to 2.1.
Maybe Patrick is busy with other things and he didn’ t notice the thread…
Let’s hope he’ll find the time to look over this :pray:


(Schnicki) #226

Any chance that we see a fix here in the near future, @pathec ?
If you are not working on the project anymore, please let us know.
Thanks.


(James Hammond) #227

Could someone please tell me a version of Openhab, Z-Way Binding and OpenhabConnector that work together.

I am getting unknown and error showing in the OpenhabConnector debug screen. I have tried multiple different versions with no success with the connection staying working.


(James Hammond) #228

Further to the above, my system displays the below after a reboot. It can be seen that all devices are in error state for the openhab connector, I only get updates to openhab by polling the Z-Way Device.

I am running Openhab 2.1.0-1 Stable, Openhab Connector 0.1.7, Z-Wave 1.7.1, Razberry Firmware 2.3.6.

I have just done a total clean install and this issue persists, any help appreciated.


(Mihai Badea) #229

I’m using a RPi3 with Raspbian Jessie, openHAB 2.1.0 STABLE, raZberry firmware 2.3.6, openHAB connector 0.1.7 and everything works…

image


(James Hammond) #230

Thanks for the reply, the below seems to be the issue:

Callback execution error: TypeError: Cannot read property ‘error’ of undefined
at Function.http.request.error (automation/userModules/OpenHABConnector/index.js:403:107)

My setup is a RPI2 with the Razberry Board running z-wave. I then have a Ubuntu VM running Openhab. My Openhab is not on localhost per the logs rather http://192.168.80.2:8080, but I presume that is how it communicates?

Any ideas greatly appreciated. I started fresh yesterday with the Ubuntu VM. Considering doing the same with the RPI2 but seems excessive.


(devTechi) #231

Hi,
I’m running:

  • openHAB 2.2.0-Snapshot Build #999
  • ZWay/RaZberry v2.3.6 (with the Shield on the Rasberry Pi 3)
  • OpenHAB Connector 0.1.7

But I have to restart my openHAB from time to time as it stops working after some days. But it isn’t quite working with newer openHAB-Snapshot versions.


I got the Errors only when I changed some things like:

  • item/thing-names in openHAB (are you linking them by hand or through the system? To do it by hand you have to disable the, how is it called, simple linking? switch in openHAB-PaperUI system preferences)
  • I think low battery in devices etc.

Perhaps it helps removing the connection between openHAB and ZWay and reestablish it (delete the configuration of the zway-binding and the openHAB-server in zway-openhab connector preferences).
But after this, of course, you have to reconfigure youre devices like you did it before.

regards
André


(James Hammond) #232

I went ahead and installed Openhab2 on the Raspberry Pi that z-wave runs on (localhost). Z-Wave Openhab connector immediately works in this configuration.

What I couldn’t get to work was have the Openhab Connector work correctly with a remote Openhab2 instance


(Mihai Badea) #233

As @pathec didn’t respond in a VERY long time I’m thinking that he dropped this project…
I’m considering switching from Z-Way to Z-Wave binding… but… OMG! :cry:


(James Hammond) #234

Yes it seems so. My setup is working ok now. I have had to install OH2 on my “Slave” RPI2 that has the z-wave Daughter Board on it and the Openhab Connector works perfectly with this “localhost” setup with instant update to OH2.

I am now setting up MQTT event-bus to send everything from this slave z-wave device to my main instance of OH2. Things are looking much better with instant update vs the waiting 60 seconds previously waiting for the polling to kick in. I have ended up losing a heap of configuration after re-imaging everything but as this is the base of the new system, seems worth it… regular snapshots from here forward to backup.


(Mihai Badea) #235

OFF TOPIC:
Why not sharing the razberry over network? https://community.openhab.org/t/share-z-wave-dongle-over-ip-usb-over-ip-using-ser2net-socat-guide/34895


(Mihai Badea) #236

I just upgraded to 2.2 STABLE and Z-Way is working normally :blush:
For the ones interested I applied the following steps (not sure that the approach to update makes any difference or the STABLE is different from SNAPSHOTs I was trying)

  1. sudo apt-get remove openahb2
  2. sudo apt-get update
  3. sudo apt-get upgrade
  4. sudo reboot
  5. sudo apt-get install openhab2
  6. sudo systemctl enable openhab2
  7. sudo systemctl start openahb2

and, after waiting for the initial startup of openhab, now everything appears to run smoothly - including Z-Way :wink:


(Schnicki) #237

@Mihai_Badea motivated me to spend my Friday night to do the same, which seemed to work at first glance. But now, only a few hours later, the symptoms are the same like in the snapshot version.
Looking at the logs, you dont even sse, whats happening exactly, the thing handler timeout messages disappered, devices dont execute commands.

After a bundle:stop which took abput two minutes, the console log is flooded by all the notifications that had been stuck. Restarting the binding after another minute or two brings back functionality partly: switching a light from paper ui or a motion sensor both take 2-3 seconds from command to execution. the same command on the z-way instance directly is executed immediatey.

After a stop openhab2.service and start, items in Paper UI are only partly restored. Only a reboot of the RPi restores funtions completely for the next few hours (I guess).

What a frustrationg waste of time again.

In 2.1.0 everything worked like a charm for weeks without a reboot necessary. Either 2.2.0 is a not too stable version at all or the Z-Way Binding is not usable any more with > 2.1.0, the maintainer @pathec disappeared.

The WAF will go down to zero today, I see a lot of my investment in ZWave tech getting worthless…:disappointed_relieved:


(Travellingkiwi) #238

I swapped to the zWave serial driver… You lose the ZWay server functionality & ability to run them on separate hosts, but gain a lot… Stability, the ability to differentiate between multiSensor channels, etc.

Over all, a disappointment, but at least there’s the choice… The zWave serial isn’t all good though… I also gained random 500 server errors from the REST interface, but it looks like it’s a known issue…


(Alberto V.) #239

Dear @pathec
I just posted a topic on runtime section but after I found that the problem seems to be related to zway binding.
Are you using the old version of openhab? Did you planned any future release of your great binding?


(Schnicki) #240

I am still struggeling with the Z-Way server, which I really would like to keep instead of the OH Zwave Binding. But testing to replace the Z-Way Binding with MQTT showed me, that I am riding on a dead horse. The MQTT App in Z-Way does not work at all, maintainer does not reply. Z-Way Support doesn‘t either reply for my roadmap question concerning MQTT.