New Z-Way Binding

binding
Tags: #<Tag:0x00007f182728faf0>

(devTechi) #41

Ah. There you go. Didn’t find that.
Thanks.


(Fintan Keogh) #42

Hello,
I am new to OpenHab and Z-wave. I have a fresh install of both on 2 seperate Raspberry PI. That is OpenHAB2 on a RPI3 and Z-way Smarthome with a razberry board on a RPI2. I followed the getting started guide, but it did not work. On the zway smarthome device the OpenHAB connector app never appeared. I tried both methods, the token code and the Git with service restart and even device reboot in both cases.
I looked in the z-way-server .log, but found no reference to the OpenHAB connector.

On the OpenHab2 device the config steps were ok wxcept as expected it did not find the OpenHAB connector on the zway server.

The binding reported “OpenHAB Connector doesn’t exist in Z-Way server”

any Ideas?


(Patrick) #43

Hello,

Which Z-Way version do you have? Did you install Z-Way via: wget -q -O - razberry.z-wave.me/install | sudo bash or a specific version wget -q -O - razberry.z-wave.me/install/v2.0.0 | sudo bash? You can also check the version under Z-Way / Management / Info.

Have you cloned the Git repository in the directory automation/userModules. The module directory name must be OpenHABConnector.

Regards
Patrick


"OpenHAB Connector doesn't exist in Z-Way server" error
(Fintan Keogh) #44

Hi Patrick,
I am running version V2.2.3. I ran the wget command without specifying a version.

I cut and pasted the Git command direct from the getting started guide and the directory name and path are correct.

pi@razberry:/opt/z-way-server/automation/userModules/OpenHABConnector $ ls -al
total 92
drwxr-xr-x 5 pi pi 4096 Oct 19 08:45 .
drwxrwxr-x 4 pi pi 4096 Oct 19 08:45 …
-rw-r–r-- 1 pi pi 1309 Oct 19 08:45 CHANGELOG.md
drwxr-xr-x 8 pi pi 4096 Oct 19 08:45 .git
drwxr-xr-x 2 pi pi 4096 Oct 19 08:45 htdocs
-rw-r–r-- 1 pi pi 24468 Oct 19 08:45 index.js
drwxr-xr-x 2 pi pi 4096 Oct 19 08:45 lang
-rw-r–r-- 1 pi pi 35147 Oct 19 08:45 LICENSE.txt
-rw-r–r-- 1 pi pi 1691 Oct 19 08:45 module.json
-rw-r–r-- 1 pi pi 2227 Oct 19 08:45 README.md
pi@razberry:/opt/z-way-server/automation/userModules/OpenHABConnector $

Fintan


(Patrick) #45

Please look at Local Apps in the category selection. To me it has already happened that here Featured Apps was selected but all All Apps must be selected.


(Fintan Keogh) #46

That was it , thank you.
I can see my zwave devices in openHAB. Great.
I already love this binding. I had terrible trouble fighting with the zwave binding , for some reason I could not resolve the serial port, but this so far is easier. :slight_smile:

Thanks
Fintan


(Stein Tore) #47

What is the status of this binding?

I managed to install it, but could not link to any items in the PaperUI.

Are you planning to support other levels of the API?
I would like a support for Configuration, as I use this to set my floor heating thermostats,


(Patrick) #48

Hi,

The work is in progress, but I have made a pull request with basic functionality that could be reviewed.

Have you installed the binding and there are no devices in the Inbox? Or have you already added devices as Things and no Items are created?
What kind of devices do you have? Only the thermostat?
What version of openHAB and Z-Way do you use?

I am currently working on another synchronization mechanism. Currently, openHAB items are registered as observers in Z-Way. I try using WebSockets and MQTT to reduce the coupling of the two systems. Therefore, I have not worked on the unsupported device types.

The support for thermostats is planned. What exactly do you mean with configuration?
I have an older thermostat for test purposes. Z-Way generates the following virtual devices for this thermostat:

  • Thermostat Operation (unsupported)
  • device type: switch binary
  • probe type: thermostat_mode
  • possible states: off, heat, cool
  • Thermostat Heat (unsupported)
  • device type: thermostat (thermostat_set_point)
  • Thermostat Cool (unsupported)
  • device type: thermostat (thermostat_set_point)
  • Thermostat Temperature
  • device type: sensor multilevel

These devices will work in the near future. Or do you need to configure Z-Wave associations?

Regards,
Patrick


(Stein Tore) #49

Seems like the pull request has some errors, that is why I asked again;

I’ll come back with more details on my problem later.

I have do have 6 heatit (http://heatit.com/) thermostats for my floors, normally the operation of these will be covered by the Thermostat detail you described in your post.

But for some of my thermostat I do not have a temperature measurer in the floor, so I have to use the thermostat in another mode. This mode is Power regulator-mode (value from 0 to 10).
To set this mode I actually have to access the current Z-Way-API like this:
(HTTP GET - where %2$s represents the value from 0 to 10)

/ZWaveAPI/Run/devices[27].Configuration.Set(12,%2$s)

To get the actual value from the ZWaveAPI, I’ll have to do this:

/ZWaveAPI/Run/devices[27].Configuration.data[12]

This is defined as COMMAND_CLASS_CONFIGURATION_V2 is the documentation
Very happy that you have created this binding, and I’m ready to contribute and/or test it.

/Stein Tore


(Patrick) #50

There have been some changes in the ESH repository. At the moment the binding does not work. I’m trying to correct that until tomorrow. The device type thermostat should then also work.

What do the values for the configuration parameters 12?


(Patrick) #51

I’ve resolved the conflicts: Z-Way Binding (no longer up to date, the latest version is linked in the pull request). To run the latest version of the Z-Way binding, a snapshot of openHAB is required after 31 October 2016.

The device types for thermostat are now available. In addition, I work on a solution to change the configuration of the Z-Wave devices. This would allow the control of configuration via items.


(Tomasz Mach) #52

I was looking for app for abut 30min :stuck_out_tongue:


(Paul Muldoon) #53

Can anyone confirm if you must have a zwave.me uzb controller and license to try the binding?

I have uzb controller but no license.


(Patrick) #54

As far as I know, you can’t include devices in Z-Way without a license key.

What you can do? Install the Z-Way software, then go to “Apps” under tab “Local Apps” there is an app “Dummy Device” (please change the selection from “Featured Apps” to “All Apps” to make the App visible). With this App you can create binary switches (imitating wall plugs, switches, …) or multilevel switches (imitating dimmers, …). These virtual devices are then found by openHAB discovery and added as things. Prerequisite: You followed the steps of getting started:

  • Installing openHAB Connector in Z-Way
  • Installing the Z-Way binding in openHAB
  • Configure Z-Way server as a bridge in openHAB

This test case is also possible without Z-Wave controller. The abstraction to virtual devices would make Z-Way even with real devices. So this approach is quite close to a test setup with real devices.

Limitations:

  • Dummy devices haven’t further information about the device type, so the binding select only a default channel.
  • Sensors can’t be simulated (only actuators)

Regards,
Patrick


(Patrick) #55

:unamused: The Z-Way developers have improved this (coming in the next release). I’ll complete my descriptions.

Regards,
Patrick


(Johan Svensson) #56

I’m so excited to have found this binding! Have been painfully troubled by the zwave binding of openhab for weeks. Now I’m running z-way without openhab, but this binding will potentially bring me new powers. :slight_smile: Looking forward trying it out this weekend.

Does it only work with openhab2? If so, I’d need to upgrade.


(Patrick) #57

Yes, only openHAB2 and only with actual snapshot version (beta4 isn’t compatible).

If you tried the binding, a feedback would be great.


(Ben Patrick) #58

Great work, love this binding. Have installed it and will test on my various Z-Wave device types.

New to OpenHAB, but spent the past few days building various configurations to get them working right. Didn’t like Habmin couldn’t include devices and would have to keep turning services on and off to during configuration.

Hopefully this will work like a charm and save me some headaches :slight_smile:


(Ben Patrick) #59

Added my Fibaro & Aeon Labs multisensors and Stella Z TRV’s. They all work perfectly!! Fantastic!! Still got to look at schedules and events yet.


(Bernhard Boser) #60

Just wanted to say that I’ve installed the binding and it works great (several modules I had troubles with before work without issue now).

Is it possible to use configuration files rather than the Paper UI? Perhaps MQTT will enable this.

Thanks for a great binding!