New Z-Way Binding

binding
Tags: #<Tag:0x00007f18299240d0>

(devTechi) #141

Hi @Avner,

I cannot answer this question as I am running a RazBerry Shield. AFAIK the license is included there so that I don’t have to do anything to add it manually. Perhaps you should ask the designer of ZWay, because that is a “problem” with ZWay itself.

Selecting your Zway-server thing and editing it you need to give you password of the Zway user. This mostly should be the admin user. So what user do you use to go to http://zwayserver-IP:8083/ ?


I cannot help you with the third question. But perhaps it goes away after fixing the other questions?

regards
André


(Avner) #142

@pathec I’m trying to install the ZWay library on Ubuntu 16.04. I followed the instructions in here and I have some questions (the installation instructions here are for the RaZberry, not for Ubuntu):

  • Download Z-Way v2.2.3 or newer (further information about installing Z-Way you can find here)

I downloaded z-way-server-Ubuntu-v2.3.0.tgz into ~/Downloads and extracted it into the directory
/home/avner/Downloads/z-way-server
When I try to start the server with service z-way-server restart, I get the error message
Failed to restart z-way-server.service: Unit z-way-server.service not found.
I think that this is because the z-way-server is installed into a local directory. So instead, I’m executing it in the foreground

pushd /home/avner/Downloads/z-way-server
export LD_LIBRARY_PATH=/home/avner/Downloads/z-way-server/libs
set | grep LD_LIBRARY_PATH
/home/avner/Downloads/z-way-server/z-way-server

How do you install ZWay library such that it

  • resides in /opt/z-way-server
  • is controlled via service z-way-server restart

Thanks,


(geir) #143

@pathec or anyone else.

Shoulder dimmers from zway work with category dimmable light, which exposes both on and off and dim level?
I only get dim level to work.


(Patrick) #144

Hi,

Please post your question in the Z-Way forum. I have not tried Z-Way with Ubuntu, but maybe someone can help you right away.

Patrick


(Patrick) #145

Hi,

So I understand you right. In openHAB, a Thing is created with the Channel switchMultilevel. This should work the dimmer function (see image).

The on/off function I would have defined as a separate channel. Is this what you mean?

Patrick


(Patrick) #146

Note: Please use the description from the openHAB master branch: here, because I’ll delete the feature branch in my forked repository.

Patrick


(Patrick) #147

I have just tried the latest snapshot release, so the problem with channel linking is solved!


(geir) #148

Hi

Created it as dimmable light as this offers both dim and on off in the same function, but only dim works


(Avner) #149

I’m following the description from the openHAB master branch. In it you point to here, which mentions

Download Z-Way v2.2.3 or newer (further information about installing Z-Way you can find here)

Can you elaborate on how to deploy the Z-Way v2.2.3 package?
If I download the file to e.g. ~/Downloads and extract it, the directory ~/Downloads/z-way-server is created.
How do you make it a service? (so that it can be started with service z-way-server restart)

Thanks


(Patrick) #150

Hi,

I think you shouldn’t link a dimmer item to a channel with accepted item type number (Switch multilevel has accepted item type number). However, the UI does allow that, the binding can’t handle this, because the binding can only send state updates over the channel with a specific state type (decimal, dimmer, …). The problem is now that I have defined multilevel switches with accepted item type number and a item of type dimmer needs the state type percentage. Please correct me if I’m wrong.

A solution would be to set item type of switch multilevel channels to dimmer. But before I change that I would check that in detail.


(devTechi) #151

I think I would like to have that to. Without doing further configurations using the Control-Tab in PaperUI I just can type in a number/int to set a dimmable value. I could write a rule to handle the interaction. Or am I overseeing something?


(Patrick) #152

Yes, currently you can only type a number. The dimmer type would display a slider, with values from 0% to 100%.


(devTechi) #153

Right. And with that the handling using the app etc. would be more familiar for most people, wouldn’t it?


(Patrick) #154

Yes, I’ll check this in detail and provide a test version as soon as possible.


(Patrick) #155

Sorry, I’v never installed Z-Way on Ubuntu, only on Raspberry with the install script: http://razberry.z-wave.me/install. Please check also this topic: https://forum.z-wave.me/viewtopic.php?f=3419&t=21567&p=58456&hilit=ubuntu#p58456


(Patrick) #156

Hi @Mihai_Badea, @Schnicki,

To the latest update: Kai meant the modeling as a channel is not optimal, because only functionalities should be defined as channels. That is why we have agreed to define the information as a property of a thing. I think this is acceptable, because the quick link on the control view (PaperUI) leads directly to the thing details and there is the time of the last update.

The feature was megerd today, so it should be the next days in the snapshot release.

Patrick


(Patrick) #157

Hi @labanx, @devTechi,

I’ve created a pull request with the new channel definition for switch multilevel as dimmer. Also added On/Off commands for multilevel switches.

If you want test it, download the test version. I had to uninstall Z-Way in my production system, move the file to addons folder and recreate the multilevel things before it worked.

Patrick


(geir) #158

Great, will give it a test tonight :slight_smile:


(Mihai Badea) #159

Well, shoot… And how do I access the lastupdate property of a thing to display it on basic UI or use it in a rule?


(Patrick) #160

Do you need the information as a trigger for the rule (when last update changes) or as a condition?

The presentation in the BasicUI is difficult, but I inform myself and write again.

Patrick