New zwave device Fibaro Heat Controller (thermostat radiator)

Ok, thank you all

Hi Chris, please let me know when I could try to discover again the device, at the moment it gets following result:

2017-12-10 16:51:30.738 [WARN ] [wave.discovery.ZWaveDiscoveryService] - NODE 9: Device discovery could not resolve to a thingType! 010F:1301:1000::4.0

It was merged this morning, so try tomorrow build and it should be in there.

I’ve updated the build and now Fibaro Heat Controller is finely discovered, it matches information taken from database.
I’ve filled some textual description (inclusion, exclusion, wake-up), unfortunately I’ve added accidentally an empty channel in endpoint 1 and now I can’t remove it. I ask please to remove it in order to let update device information with other fields filled.

Moreover I’ve some questions:

  1. looking at manual the device support 2 endpoints, one is for the thermostatic head (the one I have) and one is for the external temperature sensor (I haven’t till now), however device definition in the database after xml upload reports three endpoints, endpoints 0 seems to be the collection of both endpoints 1 and 2, endpoints 1 corresponds to the thermostatic head and endpoints 1 corresponds to the external temperature sensor. Is it right to have an endpoint 0 that seems to “duplicate” command class and channels of endpoint 1 and 2?
  2. it’s not clear to me which are the rules that lead to generate channel for some device class and not for others: why for example there is no channel for SCHEDULE command class? It could be useful to get/set schedule on the thermostatic head. Why BATTERY commands (one for each endpoint) generate a channel in openhab even if there is no channel definition in the database?
  3. About BATTERY channels it’s reported three times (one for each endpoint probably) with the same channel name (battery-level) that leads to have the same value for three instances, while it should be at least different between endpoint 1 (battery of thermostatic head) and endpoint 2 (battery of temperature sensor). do I have to change the channel name in the database?

I removed this channel for you. Keep in mind that due to holidays, these changes may not propagate into the binding for a couple of weeks. And it will probably take that long to get some answers to your questions, but I will take a shot at them…

1. This does look odd and the duplicate channels can probably be removed.
2. A schedule channel does not exist yet. You may have found [this](http://www.cd-jackson.com/index.php/zwave/zwave-device-database/openhab-2-channel-types) already. Before you implement it, I'd check with Chris to see if he's already started work in this direction. As for the channels appearing even though they were not defined in the database, my guess is that Chris has started to bring in some code that will automagically create the channels for us.
3. I think the battery CC can be removed from endpoint 0, and battery channels (with appropriate names) added to endpoints 1 and 2. But if you are getting the same values for all of them, there may be something deeper to look into.

Anyway, basic commands of the device are working fine with current version of data loaded: thermostat mode off/heat switch and thermostat setpoint temperature are fine, also battery level (even if it’s duplicated), it also reacts very quickly to command changes. I think it’s already a good work.
My questions are mainly to improve it, nothing urgent. I’d like to work on schedule implementation also if it can help.

Will this make it to the 2.2 stable version ?

Thanks,
Christos

I can’t say for certain either way, but if it is in the 2.2 snapshot (which I’m pretty sure it is), then it should be in the release.

I have one of those Thermostats, too but it is shown as unknown device.
I’m on 2.2.0.008-SNAPSHOT package on synology and on 2.2.0-SNAPSHOT for the z-wave binding.

As all my things worked out-of-the-box so far, i’m a bit clueless on what to do now.
Could someone please point me in the right direction?

Thanks,
Raven

Hi Raven, I’ve updated zwave binding to the latest version published by Chris:

and it works. I’ve also restarted openhab after binding installation. After successfully discovering of the device it takes some time, few minutes, before it changes from unknown to known one.

So,

-download the newest .jar
-place in addons folder
-restart OH

or do i still have to delete all z-wave things before?

  • remove current version of unknown device thing discovered with new fibaro radiator thermostat
  • unistall current zwave binding (if you installed it from openhab package)
  • install “Serial Binding” if it’s not currently installed
  • download e copy latest zwave binding jar in addons folder
  • restart openhab
  • discover new zwave device, it could be unknown device at the beginning then it changes in correct device type
  • you don’t need to remove any of current already configured zwave device

Hey Valerio,

thanks for trying to help me, but somehow that didn’t do the trick for me…
Now my z-wave Controller shows online and is working, but
the FGT-001 still shows unknown device (~90min since i did the restart)
all other z-wave device show “initializing” and do not work… :frowning:

any more ideas?

Thanks,
Raven

In the Karaf console, type bundle:list |grep -i zwave, which will return something like the following:

15 │ Active │ 80 │ 2.2.0.201712100924 │ ZWave Binding

If you see more than one zwave bundle, do a bundle:uninstall X, where X is the ID (15 above) of the bundle. Also, all zwave Things need to be deleted when migrating to the development binding. Hopefully one of these will get you working again!

Yes - every device always contains a root endpoint which will provide some sort of consolidated functions from other endpoints.

This command class is not currently supported in the binding.

The database software does this automatically.

This will need a fix in the database software as it wasn’t expecting mulitple battery reports from a single device.

Thanks Valerio and Scott for trying to help me.
However i wasn’t really able to use your hints to solve my problem, so i went a different way.
I had OH2 installed as a spk-Package on my Synology and now went to a docker installation.
Within docker everything seems to be fine so far, the FGT-001 is recognized and i see all channels.

I am a bit confused though on how the thermostat is expected to work…
From what i read in the manual i thought the thermostat would have its own sensor for measuring the temperature and i also see a channel named “Sensor (Temperature)” but it shows 0 and i can only see the setpoint which is from my understanding the target temperature you want to reach?!?
Do i need a FGBRS-001 (extra temperature sensor) then?

Yes Raven, we need the external sensorto get temperature from fgt001. I’ve tried also both on OH and zwave binding and on Samsung smartthing , temperature is always set to 0. I’m awaiting that bundle thermostat+sensor will turn back available on store to buy it.

The internal temperature sensor is not available for use. Fibaro claims that they use it for their own stuff, calibration etc and it is true that even if it worked it would not be accurate as it is next to the radiator. You need to external temp sensor. What I am hoping for once I install them is to use them along with other temperature sensors I have deployed around the apartment using rules

Hello,
sorry for my english is not very good and a lot with translator :slight_smile:

I have such a new Fibaro Radiator Thermostat and have also included it in openhab2 (2.2) and it works great too. Only in thermostat mode are only Off and Heat … the third (in the manual MANuFACTuRERSPECIFIC) is missing. how can i activate it ?
and how can I regulate the temperature from 10 to 30 degrees? at 26 is my end
Thank you very much for answering my questions and having a merry christmas

Hi, finally I get the optional temperature sensor (endpoint 2), I confirm there is an issue with battery command classes of endpoint 1 and 2.
I generated items for both battery command class of endpoint 1 (radiator valve) and 2 (external temp sensor) and they points to the same value (probably the one of radiator valve).
I don’t know how to solve the issue, it seems it’s not in openhab configuration, since when I generate automatically item for endpoint 1 same item is limked also automatically to endpoint 2. I don’t see how to differentiate in openhab. I don’t know also if it’s possible to fix it in the database definition, could you please help me? Many thanks