New zwave device Fibaro Heat Controller (thermostat radiator)

So,

-download the newest .jar
-place in addons folder
-restart OH

or do i still have to delete all z-wave things before?

  • remove current version of unknown device thing discovered with new fibaro radiator thermostat
  • unistall current zwave binding (if you installed it from openhab package)
  • install “Serial Binding” if it’s not currently installed
  • download e copy latest zwave binding jar in addons folder
  • restart openhab
  • discover new zwave device, it could be unknown device at the beginning then it changes in correct device type
  • you don’t need to remove any of current already configured zwave device

Hey Valerio,

thanks for trying to help me, but somehow that didn’t do the trick for me…
Now my z-wave Controller shows online and is working, but
the FGT-001 still shows unknown device (~90min since i did the restart)
all other z-wave device show “initializing” and do not work… :frowning:

any more ideas?

Thanks,
Raven

In the Karaf console, type bundle:list |grep -i zwave, which will return something like the following:

15 │ Active │ 80 │ 2.2.0.201712100924 │ ZWave Binding

If you see more than one zwave bundle, do a bundle:uninstall X, where X is the ID (15 above) of the bundle. Also, all zwave Things need to be deleted when migrating to the development binding. Hopefully one of these will get you working again!

Yes - every device always contains a root endpoint which will provide some sort of consolidated functions from other endpoints.

This command class is not currently supported in the binding.

The database software does this automatically.

This will need a fix in the database software as it wasn’t expecting mulitple battery reports from a single device.

Thanks Valerio and Scott for trying to help me.
However i wasn’t really able to use your hints to solve my problem, so i went a different way.
I had OH2 installed as a spk-Package on my Synology and now went to a docker installation.
Within docker everything seems to be fine so far, the FGT-001 is recognized and i see all channels.

I am a bit confused though on how the thermostat is expected to work…
From what i read in the manual i thought the thermostat would have its own sensor for measuring the temperature and i also see a channel named “Sensor (Temperature)” but it shows 0 and i can only see the setpoint which is from my understanding the target temperature you want to reach?!?
Do i need a FGBRS-001 (extra temperature sensor) then?

Yes Raven, we need the external sensorto get temperature from fgt001. I’ve tried also both on OH and zwave binding and on Samsung smartthing , temperature is always set to 0. I’m awaiting that bundle thermostat+sensor will turn back available on store to buy it.

The internal temperature sensor is not available for use. Fibaro claims that they use it for their own stuff, calibration etc and it is true that even if it worked it would not be accurate as it is next to the radiator. You need to external temp sensor. What I am hoping for once I install them is to use them along with other temperature sensors I have deployed around the apartment using rules

Hello,
sorry for my english is not very good and a lot with translator :slight_smile:

I have such a new Fibaro Radiator Thermostat and have also included it in openhab2 (2.2) and it works great too. Only in thermostat mode are only Off and Heat … the third (in the manual MANuFACTuRERSPECIFIC) is missing. how can i activate it ?
and how can I regulate the temperature from 10 to 30 degrees? at 26 is my end
Thank you very much for answering my questions and having a merry christmas

Hi, finally I get the optional temperature sensor (endpoint 2), I confirm there is an issue with battery command classes of endpoint 1 and 2.
I generated items for both battery command class of endpoint 1 (radiator valve) and 2 (external temp sensor) and they points to the same value (probably the one of radiator valve).
I don’t know how to solve the issue, it seems it’s not in openhab configuration, since when I generate automatically item for endpoint 1 same item is limked also automatically to endpoint 2. I don’t see how to differentiate in openhab. I don’t know also if it’s possible to fix it in the database definition, could you please help me? Many thanks