Newbie, cannot access any sitemap using docker, please help!

OK, so I am using unRAID and the openhab docker

I’ve got it setup and ran in bridge mode as port 8080 was in use so have openhab running on port 8090.

I can access hadmin and the paperui fine via locahost:8090 BUT whenever I try and access any sitemap, including the demo that I unpacked into my configuration I get:


Problem accessing / Reason:

Not Found

Powered by Jetty://

I’ve tried lots and lots of things but getting nowhere, anyone any ideas?

Is the docker image missing something I need, I have these directories:-

root@Tower:/mnt/user/appdata/openhab# ls
conf/ userdata/
root@Tower:/mnt/user/appdata/openhab# ls conf
addons/ icons/ openhab.cfg persistence/ scripts/ sitemaps/ things/
html/ items/ openhab_default.cfg rules/ services/ sounds/ transform/

That url isn’t correct. You are trying to use an OH 1.x url. OH 2 supports many UIs now so the urls have changed.

First of all, if you go to localhost:8090 you should see a list of UIs that have been installed. Among these you should see BasicUI and/or ClassicUI. If not you need to install the UI of you choice (you can do this through PaperUI or adding it to addons.cfg).

Now when you go to localhost:8090 you will see these UIs listed. When you click on, lets say BasicUI, you will see the url becomes:


If you haven’t set a default sitemap you may need to supply one:


Classic UI works the same only replace basicui with classicui.

See the following for some more lessons learned on running OH in Docker.

Thank you, thank you !!!

That was it, no where else could I find that URL you just posted, I used it and it worked first time.

I was trying variants of locahost:8090/… and getting no where.

Much appreciated.