Newbie question

Hi guys,

This might be a very silly question but I am stuck adding my first zwave device to the network.

I have been using the openhab with xbmc and nest binding for a few months now, everything is working fine.

Today i have replaced my old rgbw controlled with the fibaro FBRGBW controlled. I have installed the zwave binding and habmin. The trouble is no nodes are showing up in habmin.

I know i must be missing a step as all zwave devices would not just show up in the habmin.

I have read number article but cannot seem to understand that i am doing wrong.

please help guide me along.

edit: i have been trying to include the device using the learning button. have reset the device a few times and have also pressed the include button to put the controlled in learning mode but nothing is showing up.

What controller are you using ? what is your platform behind controller (eg R Pi, Win, OS X, Linux etc) ?

Depending on many other things (especially what kind of device you are trying to include) this might be simple.
(E.G., if your device is a battery-powered device, you might have a little dance with various button-pressing actions to wake things up at inclusion time)

i am using the razberry controller running on raspberry pi.

i am trying to include a fibaro rgbw device.

i have been trying to press the include button in habmin but nothing seems to happen.

update: the device is now showing up as a node but am unable to control it with my open hab. thoughts?

how have you described it in your items file ?

item definition:
Group gRGBW “RGBW Light”

Dimmer RGBWControllerAll “RGBW Light Control [%d %%]” (gRGBW) {zwave=“3”}
Color RGBW “RGBW Light Color Picker” (gRGBW)
Dimmer RGBWControllerR “RGBW Light Red [%d %%]” {zwave=“3:2”}
Dimmer RGBWControllerG “RGBW Light Green [%d %%]” {zwave=“3:3”}
Dimmer RGBWControllerB “RGBW Light Blue [%d %%]” {zwave=“3:4”}
Dimmer RGBWControllerW “RGBW Light White [%d %%]” {zwave=“3:5”}


sitemap myhome label=“My Home” {
Frame label=“RGB”
Group item=gRGBW

import org.openhab.core.library.types.*

var HSBType hsbValue
var String redValue
var String blueValue
var String greenValue

rule “Set RGB Value”
Item RGBW changed
hsbValue = RGBW.state as HSBType
redValue =
greenValue =
blueValue =



p.s.: in habmin the packet status reads 0/345

edit 2: now the node is showing up dead.

sorry about all the posts.

So i am able to control the dimmer now. unfortunately the color wheel does not change the color of the light. thoughts? suggestions?

This is not implemented at the moment (it will be/is implemented in OH2).

Given the way you have configured the items, you should be able to define separate ‘dimmers’ for each color rather than use the color wheel, and I think this will work for the Fibaro device…

Hi Chris,

First of all thanks for all your work with habmin. much appreciated.

Will this be fixed if i upgrade to habmin 2?

No - it will only be fixed in the OH2 ZWave binding which isn’t currently available (soon hopefully)…

Did the dimmers allow you to adjust the color?

this does the job for now.

Group gRGBW “RGBW Light”

Dimmer RGBWControllerAll “RGBW Light Control [%d %%]” (gRGBW) {zwave=“2”}
Dimmer RGBWControllerR “RGBW Light Red [%d %%]” (gRGBW) {zwave=“2:2”}
Dimmer RGBWControllerG “RGBW Light Green [%d %%]” (gRGBW) {zwave=“2:3”}
Dimmer RGBWControllerB “RGBW Light Blue [%d %%]” (gRGBW) {zwave=“2:4”}
Dimmer RGBWControllerW “RGBW Light White [%d %%]” (gRGBW) {zwave=“2:5”}

is there way to make the lights turn off and on on its own to work as blinking lights?

I don’t think the device itself provides this - you’d need to create a rule in OH, using a timer to do this.

Thanks. Will look into that.

Using a Lighting2 switch using a RFXCOM transceiver, I did the following:

 Switch DebugSwitch

 rule "blink light"
         Item DebugSwitch changed from OFF to ON
         var i = 1
         while ((i=i+1) < 5) {

Apparently the commands get queued and executed in series. For zwave switches it might behave differently, I don’t know. This might slightly delay any other things you do with the RFXcom like switching off the alarm. I also think not all lamps like to be switched on and off like this.

You could add a 1 second pause after each command just to be sure:


If you want the lamp to return to its previous state, you will have to remember the state before the blinking:

Switch DebugSwitch
Switch RememberState

rule "blink light"
        Item DebugSwitch changed from OFF to ON
        var i = 1
        while ((i=i+1) < 5) {

I know it’s a rather old thread but I found this rule because I need exacly this for my alarm system.
The rule runs without these both rows:


which gives a mistake in the OpenHAB Designer. Is it a wrong order?

Of course, I have changed the SN1509020580 with my blinking light (lampe_garten)

By the way, is there a possibility to cancel the loop if the DebugSwitch changed from ON to OFF

It would be great if someone could help me.