NFS share for Amanda backup - wouldn't mount

Platform information:

  • Hardware: Raspberry Pi 4 Model B Rev 1.4 8GB
  • OS: Debian GNU/Linux 10 (buster) (openhabian)
  • Java Runtime Environment: _openjdk version “11.0.10” 2021-01-19 LTS
  • openHAB version: 3.1.0.M1 - Milestone Build


I was trying to setup Amanda backup on my hub as I am hoping I am building my final setup. Went thorugh the docs etc and it all seems fairly clear, altough I stumbled across issues while trying to mount nfs share. I bought a small Synology docking station, configured nfs share and I can connect from my mac and windows PC without issues to each share including the Backup one that is open for RW access for guest user too (not ideal but can change later once I get it to work). Now i run straight into /etc/fstab thinking it looks straight forwatd (silly me). When trying to run mount on the location it just does nothing and I have to terminate with ctrl^c. So I tried mounting manually. It actually once worked and I could see the content (created some dummy catalog and file inside), but further it would just accept command but not actually mount anything.

**openhabian@openhabian**:**/mnt/NAS $** sudo mount -t nfs /mnt/NAS

openhabian@openhabian:/mnt/NAS $ ls -l

total 0

Started digging and checked if I can see the share and it seems alright (tried to replace IP with wildcard as well as IP range or partial IP and wildcard

**openhabian@openhabian**:**/mnt/NAS $** showmount -e

Export list for


So looked into nfs-common to see about the service and it shows as masked.

**openhabian@openhabian**:**/mnt/NAS $** sudo systemctl status nfs-common

nfs-common.service - LSB: NFS support files common to client and server

Loaded: loaded (/etc/init.d/nfs-common; generated)

Active: active (exited) since Tue 2021-02-23 18:47:16 CET; 21min ago

Docs: man:systemd-sysv-generator(8)

Tasks: 0 (limit: 4915)

CGroup: /system.slice/nfs-common.service

Feb 23 18:47:16 openhabian systemd[1]: Starting LSB: NFS support files common to client and server…

Feb 23 18:47:16 openhabian nfs-common[2890]: Starting NFS common utilities: statd

Feb 23 18:47:16 openhabian nfs-common[2890]: Not starting: portmapper is not running … (warning).

Feb 23 18:47:16 openhabian systemd[1]: Started LSB: NFS support files common to client and server.

Tried to reinstall nfs-commons but it didn’t make any change. Also tried to just enable it:

**openhabian@openhabian**:**/mnt/NAS $** sudo systemctl enable nfs-common

Synchronizing state of nfs-common.service with SysV service script with /lib/systemd/systemd-sysv-install.

Executing: /lib/systemd/systemd-sysv-install enable nfs-common

Failed to enable unit: Unit file /lib/systemd/system/nfs-common.service is masked.

openhabian@openhabian:/mnt/NAS $ file /lib/systemd/system/nfs-common.service

/lib/systemd/system/nfs-common.service: symbolic link to /dev/null

Followed some tutorials and found the below that didn’t work either.

openhabian@openhabian:/mnt/NAS $ sudo update-rc.d rpcbind enable && update-rc.d nfs-common enable

==== AUTHENTICATING FOR org.freedesktop.systemd1.manage-unit-files ===

Authentication is required to manage system service or unit files.

Authenticating as: , (openhabian)



Failed to enable unit: Unit file /lib/systemd/system/nfs-common.service is masked.

==== AUTHENTICATING FOR org.freedesktop.systemd1.reload-daemon ===

Authentication is required to reload the systemd state.

Authenticating as: , (openhabian)



I am stuck now and I am unsure how to proceed further and I was hoping someone can point me in the right direction as I am unsure if I am even trying to solve the correct problem here.

In general this is a Linux and NFS issue outside of openHAB and really even openHABian. So you might have better luck looking to a generic Linux forum or the forum for your NAS.

About all I can offer is when the system already things that a file system is mounted, calling mount again will not do anything. You have to unmount first and then remount when strange problems are encountered.

have you also tried this advice: Unmask a Masked Service in Systemd - Ruan Bekker's Blog ?

I tried that guide but it didn’t work. Sorry for asking here I thought it might be specific to the setup.
Regardless I got it to work, so posting solution copied from elsewhere that fixed it:

1. Create /etc/systemd/system/nfs-common.service

cat >/etc/systemd/system/nfs-common.service <<\EOF
Description=NFS Common daemons

ExecStart=/etc/init.d/nfs-common start
ExecStop=/etc/init.d/nfs-common stop


2. Create /etc/systemd/system/rpcbind.service

cat >/etc/systemd/system/rpcbind.service <<\EOF
Description=RPC bind portmap service

ExecStart=/sbin/rpcbind -f -w


3. Create /etc/tmpfiles.d/rpcbind.conf

cat >/etc/tmpfiles.d/rpcbind.conf <<\EOF
#Type Path        Mode UID  GID  Age Argument
d     /run/rpcbind 0755 root root - -
f     /run/rpcbind/rpcbind.xdr 0600 root root - -
f     /run/rpcbind/portmap.xdr 0600 root root - -

4. Configure the services to run at startup

systemctl enable rpcbind.service
systemctl enable nfs-common

Thanks for posting the solution. Could you edit the post to use code fences so it looks better, spacing is preserved and there will be a nice “copy” button to copy it all in one click.

code goes here

Sure, one des learn something every day!
I used < code > brackets before, but I see now what you mean. Hope that looks better.

1 Like