Nikobus compatibility OH2

You have to do it from karaf console via feature install or include it in your /etc/openhab2/services/addons.cfg:

package = standard
remote = true
legacy = true
binding = nikobus1,serial1
transport = serial

Hi Stefaan,

package, remote and legacy were marked with #, unmarked them.
binding was marked too. Completed with nikobus1,serial1 (without space).

transport wasn’t there. Typed a new line.

After a restart still got the same [ERROR]:
Serial port ‘/dev/ttyUSB0’ not found

Did an apt-get update and apt-get upgrade.

Got a message (when upgrade) Failed to fetch https://openhab.ci.cloudbees.com/job/openHAB-Distribution/ws/distributions/openhab-online/target/apt-repo/openhab2-offline-2.0.0-SNAPSHOT.deb HttpError404

I guess the page/distribution adress is changed? How can i fix this?

I read somewhere I should install 1.x bindings not in Paper UI. Is that correct? Where/how should I install them?

Kind regards, vriendelijke bedankt

Willem

I do not think this is Openhab related.
Is your USB-to-serial properly configured (dmesg + lsusb) in Linux and is it a good cable (some converters do not work properly)

if this is all ok, is openhab user part of dialout group?

sudo adduser openhab dialout

Regarding the repo, see here:

I would suggest to use RC1. This works perfectly for me and I use quite some bindings and rules.

For installing compat1x you need to enter the karaf console (see https://docs.openhab.org/administration/console.html)

and run

feature:install openhab-runtime-compat1x

i hope this helps you further, met plezier gedaan! :slight_smile:

Stefaan,

It was de dialout. I’ts now possible to turn the lights on and off. But when i use wall switches openhab is not updated. I think i’m gonna read this item again to fix this?

Is it a good idea to install openHABian on a second Pi so i get the latest stable version automaticly? Maybe its easier for a non-linux user like me?

Kind regards

Another question: Is it possible to use HABpanel in combination with the Nikobus binding?

@wimu: Habpanel is just an interface and it works lovely with the nikobus binding. i created a HABpanel for using on a wall mount low budget tablet. I can control my Nikobus, yamaha AV, Squeezebox players, Vera connected alarm system,… Works great. ony thing I’m missing in HABpanel is a florplan view/interaction possibility like habmin.

Keep in mindo for Nikobus binding to work best, you read the status from the channels of a schakelmodule, but you better give commands to a drukknop (configured on nikobus schakelmodule to control a light) instead of giving the command to a schakelmodule channel (gives a lot of difficult to troubleshoot issues in rules,…)
Example below in my items file:

// schakelmodule kanaal
Switch LPgarage “Licht Garage” (Schakelmodule) { nikobus=“ABCD:1” }

// drukknop die dit kanaal aan en uit doet
Switch BP_keuken_garage_aan “Schakelaar garageverlichting” (BP) { nikobus="#NA9WXYZ[ABCD-1]" }
Switch BP_keuken_garage_uit “Schakelaar garageverlichting” (BP) { nikobus="#NEWXYZ[ABCD-1]" }

In rules stuur ik OFF / ON commands enkel naar de BP-items en lees ik de status van de overeenkomstige LP-item (en dat werkt prima)

I do not use openHABian. I use MAX2play and install on that image mosquitto, java, and openhab2. In that way the RPI also serves as a multiroom music server/player (squeezebox/DLNA)

Installing Openhab2 natively is a piece of cake (A single distro from now on!) when using

sudo apt-get install openhab2 openhab2-addons openhab2-addons-legacy

Hi Stefaan,

So, with the line

// schakelmodule…

you read the status of the channels

And with the BP (wall buttons/busdrukknoppen) you put your lights on and of?

I don’t have that much time to work all day on my configuration. Job/family/social etc take some time too!

My Openhab1 installation works stable for 6 months now. Try to get my Openhab2 installation stable now using Basic UI. Later want to go for an more fancy HABpanel userinterface and also think about try to use a Calender (Synology Caldav) to program/schedule rules. Or maybe use sunrise and sundown rules. Plans enough but time…

Hi Stefaan,

I do see some differences between your Nikobus items and mine. My code is:

Switch hobby_tl “verlichting hobbyruimte TL”(bg_hobby, Lights) {nikobus=“18D4:1”}
for switching the “schakelmodule” directly.
and

Switch BP2_A {nikobus="#N8D4526[18D4-1]"}
for feedback of button A of a “busdrukknop” of four buttons
Switch BP2_B {nikobus="#NCD4526[18D4-2]"}
for feedback of button B of the same “busdrukknop”

So I do switch in openhab directly on a “schakelmodule”. How can i switch the same port in openhab on a busdrukknop (wall-pushbutton)?

In your example above the code of your schakelmodule seems “ABCD”. Is that in real and free to choose or just an example?

I also have a “rolluikmodule”. Witch HABpanel item should i choose to control these items? Is it also possible to see on HABpanel how far a sunscreen is up or down?

Kind regards

Willem

Job/family/social etc take some time too!

Same problem here, but we still have the nights to work for personal things :slight_smile:

Indeed, ABCD is just a fake address

The rolluikmodule (and dimmer module) should behave the same, but I have none to test.

you can give commands to schakelmodule channels immediately for switching on and off the lights, but I’ve noticed when doing this through rules feedback gets out of sync after some time. The feedback behaves better when giving light on/off commands to a physical button which has been configured in Nikobus to switch on/off the lights.
In my OH config, each schakelmodule channel and each button of a drukknop module is separatly defined in my items file. though job the first time, but stable and no changes needed afterwards.

The same feedback issues did also apply with OH1.8.3 in my setup when using rules to switch Nikobus lights. Much more stable to command drukknoppen through rules and the effect is the same: light goes on/off.

I use caldav presence simulation through the google binding. i tried with caldav and Synology, but couldn’t get it to work properly. Works fine with Google calendar.
Habpanel is great, I created a cheap tablet interface and in the coming week, I’ll nail my tablet against the wall (still have to convince the wife :wink:) to control in a nice manner my lights, alarm panel, audio AV receiver and consult my weather station (all through Openhab)

Openhab is a wonderful and powerful system, but it is not easy for starters with no IT-experiences/skills and that’s a pity. In an ideal world, all should be configurable through a point and click web GUI without the need to define text files, but this is far from true today. Although a first step has been set with PaperUI and Habpanel.

Hi Stefaan,

Thx again.

Do you expect someone will develop a new Nikobus binding for OH2 soon (or sometime)?

What brands you use for your devices, and what bindings:

  • Alarm/security panel
  • AV receiver
  • weather station
    and which tablet are you gonna nail on the wall? And wich powersolution are you gonna use for your tablet?

Willem

I am afraid not. @davy indicated in the past on the old forum he won’t probably do this. He’s the creator of the initial binding. The problem is that the users of Nikobus are mainly located in Belgium (and The Netherlands maybe)

I would hope for a OH2 Nikobus binding with a Nikobus system as bridge, a schakelmodule, dimmer module, rolluikmodule and bedieningspunt as things and the Nikobus channels and bedieningspunten push buttons as channels of a thing.
This would make a lot of things easier.

I use a Caddx Alarm Panel. There is a native binding for Openhab somewhere, but I connect to it through a MIOS Vera device which has a binding for Openhab.

My AV Receiver is Yamaha and my weather station is Netatmo.

Hi everybody!
I am having similar problems with the feedback not working. The scheduled update runs perfectly but it gets not reflected in the status of the items. I am currently running SNAPSHOT 2.1.0 build #813.
What I haven’t done is declaring all the physical buttons in the .items file. I thought the scheduled update was enough or am I wrong? I use the Nikobus binding in combination with Homekit integration. This is the output of the log file:

2017-02-27 14:58:58.719 [TRACE] [ding.nikobus.internal.NikobusBinding] - Requesting scheduled status update for DD05
2017-02-27 14:58:58.720 [TRACE] [ding.nikobus.internal.NikobusBinding] - Sending command with ack $1017DD0539B1C4
2017-02-27 14:58:58.722 [TRACE] [s.internal.core.NikobusCommandSender] - Sending command $1017DD0539B1C4
2017-02-27 14:58:58.728 [DEBUG] [kobus.internal.core.NikobusInterface] - Sending : $1017DD0539B1C4
2017-02-27 14:58:58.750 [TRACE] [kobus.internal.core.NikobusInterface] - Received: $
2017-02-27 14:58:58.772 [TRACE] [kobus.internal.core.NikobusInterface] - Received: 0517
2017-02-27 14:58:58.772 [DEBUG] [internal.core.NikobusCommandReceiver] - Received NikobusCommand [command=$0517, repeats=1]
2017-02-27 14:58:58.773 [TRACE] [obus.internal.core.NikobusAckMonitor] - Processing nikobus command $0517
2017-02-27 14:58:58.946 [TRACE] [kobus.internal.core.NikobusInterface] - Received: $
2017-02-27 14:58:58.970 [TRACE] [kobus.internal.core.NikobusInterface] - Received: 1CDD0500000000000000BD6
2017-02-27 14:58:58.993 [DEBUG] [internal.core.NikobusCommandReceiver] - Received NikobusCommand [command=$1CDD0500000000000000BD6A0A, repeats=1]
2017-02-27 14:58:58.994 [TRACE] [obus.internal.core.NikobusAckMonitor] - Processing nikobus command $1CDD0500000000000000BD6A0A
2017-02-27 14:58:58.995 [TRACE] [obus.internal.core.NikobusAckMonitor] - Received expected ack '$1CDD0500000000000000BD6A0A'
2017-02-27 14:58:58.996 [TRACE] [kobus.internal.core.NikobusInterface] - Received: A0A```

Is there anything I can try?

Thanks in advance!
Ben

In fact, everything works fine for now. Except when I try to turn everything off at once with Siri, it fails. But overall it works perfect!

I’ve also got most things to work (this is really great), but I still struggle with the status updates that should occur every 10 minutes. In the logs I can see the following:

Anyone else stumbled on this?

Hi,
I’m a new to the openHAb system and installed the OH2 on an raspberry. I have the “old” nikobus with a pc link (serial). The serial is connected to the RP.

Things i figured out,
It’s not possible to install the niko binding by using paperUI. It has to be by hand. ?

Can somebody help me what is my next step(s) are ?.

you should be perfectly able to install it using paper UI, I do it all the time and it works fine

Ben, this is probably because you’re flooding the Nikobus bus. Siri will just send individual “turn off commands for each and every item”. If you have lots of lights it’s just too much for the serial bus. If you have properly installed each update (light turned off) will also generate an update for the controller section (another query to the bus).

The best way to do this is to configure a “all off” function in NIkobus and link it to a virtual button and have openhab (and Siri) call this virtual button. This way it will be only 1 command on the nikobus instead of dozens.

Another issue I ran into and haven’t found a proper solution for is status update for dimcontrollers. When changing the slider in openhab it sends the command to the dimcontroller but since dimcontrollers have a dim delay (for example 1sec) the status is not properly updated. After the command is sent the biding is polling the module for an update as with a “schakelmodule” but the dim controller has not finished the change yet (imagine you go from 100% to 0% and delay is 1 sec). When the module is polled it’s at 40% for example. The only way I managed to solve for it is by adding the same module several times a switch in the config file, so it polls it five times for example and by the fifth 5th time the status will have reached 0%

Oke, i started a new attempt from scratch.
installing openhab 2 on a rasp - check
usb to serial on the pi is working - check
install nikobus binding - check

in the inbox - no nikobus binding.
install networkbinding to test, networkbinding is in inbox.

Why isn’t the nikobusbinding not in the inbox or in the configuration ?

Do i miss an essential step or ??. Google does not provide an easy step by step so i will make one for further beginners

Peter,

I’m not at home so can’t see how it exactly looks but let’s make sure we’re talking about the same.

The Nikobus binding is an OH1 binding. You can install it through the Paper UI like the first image on this page http://docs.openhab.org/configuration/paperui.html
under extensions bindings.

The configuration however happens through config files you put in the services directory as explained here. http://docs.openhab.org/addons/bindings/nikobus1/readme.html

If by inbox you mean the Paper UI inbox where autodiscovered things show up then you’re right nikobus does not autogenerate anything. That is only the case for the newer OH2 bindings.

So when you see Nikobus in the list of bindings under extensions bindings then you can move on to configuring it through text files.

oke, here we again.

I have made some buttons according to the example in http://docs.openhab.org/addons/bindings/nikobus1/readme.html. They are not my adreses but just to see what happens

then i looked into the logging story and i can see that the button is pushed but nothing nikobus is happening.

it looks that i skipped an essentials step somewhere.

install openhab2 on raspberry
check of serialport is there (yes)
install nikobus binding
change in nikobus.cfg the serial port

make a switch in /srv/openhab2-conf/items/default.items

Switch Presence_Mobile_KK "Johns Mobile" <network> { channel="network:device:192_168_1_43:online" }
Dimmer NotificationVolume "Notification Volume [%d %%]"     {channel="squeezebox:squeezeboxplayer:9f9c26be:0004201221ad:notificationSoundVolume"}
Switch Office_Top_Left_S "Office Light On/Off Short Press" { nikobus="#N003334:SHORT" }
Switch Office_Top_Left "Office and Kitchen Light On/Off" { nikobus="#N006884[C964-1,C964-2]" }

and in /srv/openhab2-conf/sitemaps/default.sitemap

sitemap default label="My first sitemap"
{
Switch item=Presence_Mobile_KK label="KK Mobile"
Slider item=NotificationVolume label="Notification Volume"
Switch item=Office_Top_Left_S label="test nikobus"	
Switch item=Office_Top_ label="test nikobu2"

}`Preformatted text`

I see the buttons, i click the buttons and in the log it says

 11:37:22.547 [INFO ] [kobus.internal.core.NikobusInterface] - Connected to serial port '/dev/ttyUSB0'
 11:37:23.007 [INFO ] [kobus.internal.core.NikobusInterface] - Connected to Nikobus :-)

But when i push the yellow button on the nikobus module, nothing seems to happen.

complete log here

thanks