Nikobus compatibility OH2

I’m trying to test the Nikobus binding with OH2. However switching a switch does not seem to work. I’ll try to activate debug logging to troubleshoot but does somebody already have experiences with OH2 and Nikobus binding (1.8.0)?

If the very same 1.9 binding JAR file works on openHAB 1.8.1 but not on the 2.0beta2 that it was installed with, please report that on github or at least here, and thanks. Make sure to include item definitions and DEBUG logs.

I am still troubleshooting. I have the feeling that 1.8.1 version could be working. i had to install openhab-transport-serial via feature:install and then bundle:start openhab-binding-nikobus. The logs indicated that all is ok. I’ll check tonight when at home wheteher the lights are indeed responding to the commands given via de web interface.

Stefaan, did this eventually work ?

I did not try anymore. I have it working on 1.8.2 on my rpi2. In the next weeks I’ll setup OH2 on another rpi to test

Seems to work, please see details here.

I can also confirm that Nikobus works on Openhab2

I’ve got one-two questions here: are

  • copied openhab.cfg and installed feature:install openhab-runtime-compat1x - as described here
  • installed feature:install openhab-transport-serial
    Is this still needed in beta3-snapshot?

I got OH1-nikobus working, but OH2 doesn’t seem to find the binding.

[ 5.363633] usb 1-1.2: pl2303 converter now attached to ttyUSB0 in the config is OK.

I’m also trying to move my Nikobus-system from OH1 to OH2. I have installed the binding by using the OH2 interface. I also copied my items, rules and sitemap files to OH2. Should I also define Nikobus-THINGS?

thanks for your feedback!

Tijl De Waele


Not sure if this answers your question, however when I migrated from OH1 to OH2 (rpi2) no changes to items/sitemap files were required - after Nikobus binding was installed, everything worked.

One thing might be worth mentioning - in order to get it working, I had to un-comment the line:


within the conf/services/nikobus.cfg. Seems like the binding is not picking up the default value…

I could make Nikobus work with openHAB 2.0 beta4. With the newer snapshots (#600 and higher) I can confirm that the feedback is unfortunately not working anymore … Hope this can be fixed. Otherwise we won’t be able to use the next beta-version for Nikobus-based solutions …


Tijl De Waele


tried to upgrade this morning. I noticed the Nikobus binding is very sensitive to errors (even in persistence or sitemaps). I have seen that the slightest error sometimes causes the feedback to stop working. So it could be that something else is causing the feedback issue.

That being said I didn’t manage to upgrade succesfully, after upgrading I noticed the directory structure has changed and the get -apt update and get -apt upgrade scripts don’t seem to work yet.

So I had to revert to a previous image and will try upgrading once the upgrade scripts are working fine with the new directory structure.

I also have feedback issues on a running version 1 installation that I cannot get ok again.
I am now migrating my setup to an OH2 installation.
I hope that a OH2 Nikobus binding will come one day, supporting the thing concept and easy config of nikobus modules through paper UI

In order to test again, I have installed OH2 build 631 ( I have installed only the Nikobus binding and 1 single item to test with. This should avoid any interference from other bindings or misconfigured items. I can switch an item with the GUI, but feedback is not working whenever I use my wall switches.
Would be great if someone could test as well …
If this problem can’t be solved, this would jeoparidize the upgrade to OH2. Since the binding has worked in previous OH2 builds, I’m convinced the problem has been created by changes in the OH core …

I’m running OH1 with 5 nikobus modules working perfect (Just switching on/off, dimming and screens, no specialties).
Want to try OH2 on another Raspberry Pi. Can i use my items- and sitemap-file without any modification?
Will status feedback working?

Yes, they ought to work the same under OH2.

The Nikobus binding is not compatible with the latest OH2 builds. Feedback is not working …

Have you shared DEBUG or TRACE logs showing what the binding does, along with your configuration, OS, version, etc.? If not, please do! Someone here might be able to compare your settings to theirs, suggest troubleshooting steps, etc.

just installed OH2 on a MS server 2016. Nikobus & Zwave. OH version is 2b4 and i can confirm feedback is working. But the bindings poling for status every x seconds is not working.

2016-12-24 13:34:49.201 [DEBUG] [ding.nikobus.internal.NikobusBinding] - Refresh service started. Will refresh a module every 10 seconds.

But thats it

As you can see in the TRACE:

    2016-12-24 13:39:23.645 [TRACE] [obus.internal.core.NikobusAckMonitor] - Processing nikobus command $1C6644000000000000FF5D92E7
2016-12-24 13:39:23.645 [TRACE] [obus.internal.core.NikobusAckMonitor] - Received expected ack '$1C6644000000000000FF5D92E7'
2016-12-24 13:40:28.478 [TRACE] [ding.nikobus.internal.NikobusBinding] - Setting serial port to COM4
2016-12-24 13:40:28.478 [TRACE] [ding.nikobus.internal.NikobusBinding] - Setting refresh interval to 10
2016-12-24 13:40:28.479 [DEBUG] [ding.nikobus.internal.NikobusBinding] - Refresh service started. Will refresh a module every 10 seconds.
2016-12-24 13:40:28.479 [TRACE] [ding.nikobus.internal.NikobusBinding] - Starting connection
2016-12-24 13:41:25.223 [TRACE] [kobus.internal.core.NikobusInterface] - Received: #N9
2016-12-24 13:41:25.239 [TRACE] [kobus.internal.core.NikobusInterface] - Received: 61626

2016-12-24 13:41:25.324 [DEBUG] [internal.core.NikobusCommandReceiver] - Received NikobusCommand [command=#N961626, repeats=1]
2016-12-24 13:41:25.324 [TRACE] [nding.nikobus.internal.config.Button] - Processing command #N961626
2016-12-24 13:41:25.324 [TRACE] [ding.nikobus.internal.NikobusBinding] - Sending command with ack $101266444853D1
2016-12-24 13:41:25.324 [TRACE] [ding.nikobus.internal.NikobusBinding] - Sending status update to PB_GF_Keuken_LB : ON
2016-12-24 13:41:25.324 [TRACE] [s.internal.core.NikobusCommandSender] - Sending command $101266444853D1
2016-12-24 13:41:25.324 [DEBUG] [kobus.internal.core.NikobusInterface] - Sending : $101266444853D1
2016-12-24 13:41:25.350 [DEBUG] [internal.core.NikobusCommandReceiver] - Received NikobusCommand [command=$0512, repeats=1]
2016-12-24 13:41:25.350 [TRACE] [obus.internal.core.NikobusAckMonitor] - Processing nikobus command $0512
2016-12-24 13:41:25.350 [TRACE] [kobus.internal.core.NikobusInterface] - Received: $0512
2016-12-24 13:41:25.928 [TRACE] [kobus.internal.core.NikobusInterface] - Received: $1C
2016-12-24 13:41:25.944 [TRACE] [kobus.internal.core.NikobusInterface] - Received: 664400000000000
2016-12-24 13:41:25.960 [TRACE] [kobus.internal.core.NikobusInterface] - Received: 0004362FA

2016-12-24 13:41:25.960 [DEBUG] [internal.core.NikobusCommandReceiver] - Received NikobusCommand [command=$1C6644000000000000004362FA, repeats=1]
2016-12-24 13:41:25.960 [DEBUG] [s.internal.config.ModuleChannelGroup] - Processing nikobus command $1C6644000000000000004362FA for module (6644-1)
2016-12-24 13:41:25.960 [TRACE] [ding.nikobus.internal.NikobusBinding] - Sending status update to LP_GF_Kitchen : OFF
2016-12-24 13:41:25.960 [TRACE] [obus.internal.core.NikobusAckMonitor] - Processing nikobus command $1C6644000000000000004362FA
2016-12-24 13:41:25.960 [TRACE] [obus.internal.core.NikobusAckMonitor] - Received expected ack '$1C6644000000000000004362FA'

autoupdate never happens