"No connection, Item update is not sent" - maybe Java version?

I’m getting No connection, Item update is not sent all the time.
UUID and Secret are correct.
According to some other posts, I guess it might be related to Java, but I’m not sure…
Here are my versions:

 $ uname -a
Linux raspberrypi 4.4.13+ #894 Mon Jun 13 12:43:26 BST 2016 armv6l GNU/Linux
 lsb_release -a
No LSB modules are available.
Distributor ID: Raspbian
Description:    Raspbian GNU/Linux 8.0 (jessie)
Release:        8.0
Codename:       jessie
$ java -version
java version "1.7.0_60"
Java(TM) SE Runtime Environment (build 1.7.0_60-b19)
Java HotSpot(TM) Client VM (build 24.60-b09, mixed mode)

Any advice?

I’ve tried switching to Java 8, but it didn’t help.
I’ve also tried from a PC with Windows 8 (after updating the UUID and Secret, of course) - and also not working.

Maybe it’s related to the UUID and Secret changes?

Few week ago, from that Windows machine, I successfully connected to my.openhab.
Yesterday, I’ve deleted all items in my.openhab, and changed the UUID and Secret at my.openhab to the Raspberry’s.
Now, returning to the Windows credentials - but it’s not working…