No dashboard through myopenhab, no access through iOS app


(Robin Darroch) #1

For some time now I’ve been unable to get remote access to OpenHAB through either myopenhab.org or the iOS app. The cloud connector appears to be online (no errors reported in the OH2 log), and both notifications and exposed items seem to work fine (I have IFTTT triggering things remotely all the time, and receive push notifications reliably). However, when I click the “Click here to access your openHAB’s dashboard (https://home.myopenhab.org/start/index)” link, I get no content at all (the request completes, and I get a blank browser screen - if I choose “view source”, it says there is no content). Alternatively, if I try to use the iOS app, it says “Connecting to remote URL” at the bottom, then an error “Request failed: Bad request (400)”.

A long time ago while I was still setting up the system it was working, then somewhere along the way (I was concentrating on a lot of other things rather than remote access), it stopped working. I decided maybe the cloud connector was broken, so today I tried the following sequence:

  • uninstall OpenHAB cloud connector plugin in PaperUI
  • delete UUID and Secret files
  • reinstall OpenHAB cloud connector plugin in PaperUI
  • restart OpenHAB
  • enter the new UUID and Secret in my myopenhab account
  • restart OpenHAB again

… and that seems to have restored exactly the functionality I had before doing all that, i.e. entirely reliably notifications and access to exposed items, zero dashboard or iOS app access.

I think I’ve gone through and checked all the settings mentioned in other myopenhab connectivity threads, and they all appear to be correct. I can access BasicUI through a Safari bookmark on my phone when I’m on my home network, and I can also access it through Safari when connected by VPN… but my home router’s VPN server is a little flaky, so I’d like to be able to use myopenhab for somewhat more reliable remote access. Does anyone have suggestions as to how I could get this working again? It definitely worked once upon a time - soon after I set up myopenhab - but since it stopped it has never worked again.

Thanks!
Robin