No data in graph - persistence problems: can't create rrd4j database file


I’ve the latest OH-version running on an Raspi4.
It looks like persistence is not working (any more) on my system, e.g. it doesn’t show any graphs any more.
Log file says OH can’t create rrd4j database:

I can’t really remember what I’ve done to get this problem. But I installed influxdb and possibly used it as my persistence tool. Later I uninstalled it in the OH-Add-on-persistence tools.
Now I just tried other services (influxdb again and JDBC persistence MySQL) but without success. Logfile now looks like this:

Did you try to stop the OH service and remove the files that are shown in the error messages; then start OH service again ?

1 Like

I’m not familiar with linux. Just tried “sudo rm *.rrd” and it tells me I don’t have the rights to delete these files. Thought with sudo it should work. What do I need to do to delete these files?
Here are the properties:

Did you stop the openhab service before trying to delete the files ?
In the screenshot I do not see if you had a command prompt to enter the sudo command or if this was still running the previous command ( which I think is the case ).
So do one step after another.

  1. stop the OH service ( sudo systemctl stop openhab )
  2. go into the direcotry containing the files ( as you did before: cd /var/lib/openhab/persistence/rrd4j )
  3. get root: sudo bash
  4. you should have a root shell now
  5. do: id
  6. you should see that your user is root now
  7. remove a single file: rm Wetterinfo_Windgeschwindigkeit.rrd
  8. in case of an error: what kind of error is displayed. It could be that there is a general problem with your file system
  9. do: exit
    to close the root shell
1 Like

Now it works again, thank you!

1 Like