No devices were found in your openhab account when linking to Google Home

I don’t use these switches in the sitemap. These switches are only controlled by voice using the google assist and perform some real shutters action accordingly. I have noticed that if I try to press the “virtual switch” quickly after it appears on the google assist, I can toggle it, although the switches are offline in the google home app. I managed to control the shutters by voice. It also worked after RP3 reset.

I would also second what was said already. Having items with no state can lead to unexpected behaviors in Google home. As it tries to query the state of the item and interpret the value, a NULL (default for new items) will end up in an error. Still, I am unsure if this would end up in an offline state. So it not has to be the reason.

As I wrote, it worked well before with the “switchable” tags and it seems to work again.

1 Like

it just happened to my. Gonna edit my configuration now to use metadata.

It did work :slight_smile:

Still on openhab2.4, need to upgrade, but so many things to doo…

Full example:

Location: /etc/openhab2/items$
File name: Google.items

Dimmer	ZW_DI_Slaapkamer_Dimmer1	"Masterbedroom light"	{ ga="Light" [ roomHint="Masterbedroom" ] }
Switch	ZW_SW_Overloop_Switch1		"Halway light"			{ ga="Light" [ roomHint="Halway" ] }
Dimmer	ZW_DI_Entryway_Dimmer1		"Entryway light"	 	{ ga="Light" [ roomHint="Entryway" ] }
Dimmer	ZW_DI_LivingRoom_Dimmer1	"living room light"		{ ga="Light" [ roomHint="living Room" ] }
Dimmer	ZW_DI_DiningRoom_Dimmer1	"Dining room light"		{ ga="Light" [ roomHint="Dining Room" ] }
Dimmer	KitchenLight_Dimmer1		"Kitchen light"			{ ga="Light" [ roomHint="Kitchen" ] }
Dimmer	ZW_DI_Office_Dimmer1		"Office light"			{ ga="Light" [ roomHint="Office" ] }
Dimmer	ZW_DI_GardenSP_Dimmer1		"Garden spots"			{ ga="Light" [ roomHint="Back Garden" ] }
Dimmer	ZW_DI_Scullery_Dimmer1		"Scullery Light"		{ ga="Light" [ roomHint="Kitchen" ] }