No devices were found in your openhab account when linking to Google Home

So today all my stuff dissapeared, i unlinked openhab from my home and now it just says no devices were found on youre openhab account…
https://myopenhab.org/rest/items looks fine

1 Like

So found out about it (learn to dig more before asking)
Anyway, all tags even semantic tag must be removed and add metadata = google assistant and back they come, closing thread.

You need to add metadata { ga=“Light/Switch/etc” } to be able to expose the devices. Instructions: Google Assistant | openHAB

1 Like

It stopped working for me yesterday.

It depends if youre using text files or the gui.
With text files you have to remove tags= and put in ga= like the reply in the other post.
I use openhab3 and have migrated away from text files configuration. I had to edit the items i wanted, remove all the tags if any, and add metadata button, pick google assistent, choose a type e.g lights and save. Then I could add the openhab integration in Home and the devices which i had updated shows up.

Hi
You have to manually edit each item in paperui.
1.Be sure to remove all the tags on the items (I removed semantic tags as well)
2.add metadata, choose google assistant and chose the correct item (e.g. light)
3.save the item
4.tell google sync devices (if you have the openhab connection functional in google home, if not add it)

then these items should reappear in google home.

So what changed? Is it the Google end or openHAB? It seems strange that a lot of people (including me) have had the same problem at the same time.
I’ve been running for over 3 years with { 'switchable" } tags, etc and, on Saturday, Google lost everything.

I thought the OpenHab connector went down again since yesterday, so I waited, and waited, restarted my OpenHAB VM, still nothing showing up under Google Home, went into the Google Home App attempting to re-link, and it gave the error “no devices were found in your openHAB account”, so I googled that and found this thread.

Now I’m a little confused at how to convert my current items to this new format as I too have been using the [“Switchable”] tag without issues.

If anyone might be able to confirm how to re-format?

Before:

Switch    Light_UL_BedroomBedSwitch              "Bedroom Bed Light"                     (UL_Bedroom, Lights, UL_Bedroom_Lights)    ["Switchable"]    {channel="tplinksmarthome:hs105:UL_Bedroom_Bed_Light:switch"}

After:

Switch    Light_UL_BedroomBedSwitch              "Bedroom Bed Light"                     (UL_Bedroom, Lights, UL_Bedroom_Lights)    { ga="Switch" channel="tplinksmarthome:hs105:UL_Bedroom_Bed_Light:switch"}

Doesn’t seem to make a difference, forced a refresh and tried re-linking through Google Home, still says “no devices were found in your openHAB account”

Giving up for the evening and will attempt to tackle this again tomorrow, hopefully someone can chime in with suggestions. :slight_smile:

Thanks!

I think you need to separate the ga from the channel brackets but I’ve only managed to get some of the key items to work by editing the metadata in the devices in the OH3 UI.

If I get something to work I’ll report back

Right, the ga=“Light”, etc needs to be separated by a , from the rest of the channel
{ channel=“tplinksmarthome:hs105:UL_Bedroom_Bed_Light:switch”, ga=“Light”}

1 Like

While you are doing it adding roomHint puts the device directly into the room
{ channel=“tplinksmarthome:hs105:UL_Bedroom_Bed_Light:switch”, ga=“Light” [roomHint="Bedroom] }

1 Like

Thank you so very much!

It seems the roomHint doesn’t do anything in the Google Home app, although I did as you said (plus a missing quote at the end), then re-linked OpenHAB and it said it found 1 device

Switch    Light_UL_BedroomBedSwitch              "Bedroom Bed Light"                     (UL_Bedroom, Lights, UL_Bedroom_Lights)        { channel="tplinksmarthome:hs105:UL_Bedroom_Bed_Light:switch", ga="Light" [roomHint="Bedroom"] }

Woo! Now to go through and do that with everything else. :slight_smile:

I really appreciate your help, will be nice to have Google integration back again.

It inserted the items into the Rooms in Google for me (but you need to have created the rooms obviously)

That’s strange, I used all the exact room names that I previously did, but yeah, I had to re-add them to each room individually. Maybe because somehow my OpenHAB became unlinked when I tried to re-link it. (It didn’t show up under “Linked Services” under Works with Google, probably because there were no items, when I went to try to link it again before checking the forums here, maybe it cleared things.)

None the less, I really appreciate your help, all 54 devices are now back in the Google Home app and working correctly again. Took awhile to edit all my items files and add them back to their appropriate rooms and such. :slight_smile:

I unlinked too. I ended up using search and replace but, because I followed the advice to use multiple items files, I had to do it 12 times for my 60+ devices.

Just wish I knew what had changed

You need to have strucureHint too (and a ‘,’ which I missed
{ ga=“Light” [structureHint=“Home”, roomHint=“Bedroom 1”] }

Hi, so I got the same problem of google unkinking from my home some week or so ago2 , and I just sat down to fix it. Of course as I setup that years ago I still have the old format of tags like [“Switchable”]. Are those now retired and not coming back? Am I forced to upgrade to metadata descriptors in the channel?

Since I rely on one very old binding I still run on on OH 2.4 (and partialy due to the golden rule “if it ain’t broken don’t fix”)
Does anyone knows if the new format is available to OH 2.4 installs or the GA integration is now only for the OH3 users?

Yes, you need to update to metadata.

It should work in 2.4 just fine.

FYI, if you upgrade to OH3, you can use the remote binding to connect to a second server running OH2, so that you can keep your old binding running.

1 Like

Thanks, indeed it works with just a simple update to the items file, and “sync my devices” magic sentence. I was somehow over pesimistic about that.

1 Like

Hi,

Thanks for the information - it really helped to reuse google home.
However, some of the switches appear in google home application but they are offline.

I am using “virtual switches” to open shutters by voice command, each Switch triggers a rule that open/close the shutters that I want to open/close.

for some reason only the first virtual switch is working - all the rest appear offline in the google home app.

Originally it was defined with [“Switchable”]:
Switch g1F_SHUTTER_VOICE_CTRL “1F shutters” (gStam) [“Switchable”]
Switch gKITCHEN_SHUTTER_VOICE_CTRL “kitchen shutters” (gStam) [“Switchable”]
Switch gLIVING_ROOM_SHUTTER_VOICE_CTRL “Living room shutters” (gStam) [“Switchable”]

I updated the definitions according to the suggested in the topic:
Switch g1F_SHUTTER_VOICE_CTRL “1F shutters” (gStam) { ga=“Light”}
Switch gKITCHEN_SHUTTER_VOICE_CTRL “kitchen shutters” (gStam) { ga=“Light”}
Switch gLIVING_ROOM_SHUTTER_VOICE_CTRL “Living room shutters” (gStam) { ga=“Light”}

The only thing I can think of is that if the switches don’t have an on/off state, Google might not know what to do with them. Try toggling them in openHAB and then see if they show up.