No exec of Python-script


i’ve got a problem with the exec of my python script.

It already has been running, but after renaming the files, items and things it doesn’t work anymore…
Til now I tried to clean the cache, created new files and renamed it on and on but nothing was worth it.

The script itselfs runs perfectly and even through the “sudo -u openhab” command the script does what it should do. The log-files does not through any errors and just says that my item received a command and changed from old to new value.

Following my code…

sitemap colors label=“LED” {
Frame label=“RGB-Strip” {
Colorpicker item=rgbColor

Color rgbColor “Farbe” { channel=“exec:command:color-control:input”, autoupdate=“true” }

Thing exec:command:colors-control [ command=“python /etc/openhab2/scripts/ %2$s”, interval=0, autorun=true ]

My python-script receives a string that parses the hsv-values to rgb and sets the values of the rgb-strip.

Would be very thankful for any help!
I am going crazy of this problem…


I would try un-installing the Exec binding then re-install the binding, maybe even clean cache/tmp again.

Make sure you have exec binding AND exec-transformation installed.

Thing name and item channel are differnt, missing s in colors.

Ps: using code fences makes reading your code much easier.

Using VS Code and the openhab extension also helps avoiding such errors.

Thanks for helping!

I gave it a try but it didn’t fix the problem…

Thank You!

So the exec-transformation is installed and the s in colors was just missing because of my bad typing-skills…

But the problem is still not fixed…

I’ve got code fences in my code, i just leaved them by typing the code in the forum.

Got the clue!

After changing “Color rgbColor” to “String rgbColor” it finally is working!

Thanks for Your help!!

Hi Chris, the code fences are for readability in the forum. Please follow the link given earlier and adapt your first post. Nice for others who want to learn from your posts.