No Item Expose to Cloud

i am facing the Problem that since Friday my IFTTT Action in Openhab doesn´t work. It not update the Status in Openhab Cloud. So IFTTT not triggering my Blink System.

I now tryed everything but cannot get it work again. i reinstalled the Cloud Add on with new UUID and Secret. I deleted Items and try to resync them. But i didn´t get the Item back in Cloud :frowning:

can someone help me?

Any Ideas?

IFTT Actions have been temporarily disabled to ease load on myopenhab and reduce it crashing.
@digitaldan has the details.

The relevant thread to watch is Myopenhab not reachable

1 Like

any ideal when the IFTTT Function will come back?

@digitaldan explained in detail, but understandably didn’t put a timeframe on it. Unfortunately, based on what he said, I wouldn’t expect IFTTT support to come back very soon. At least, not until Dan or someone else can figure out how to reduce the traffic that’s overloading

Does this affect a new Google Assistant installation as well? Correct me if I’m wrong but I do have to expose the desired items (with the correct tag added in the .items file) through Paper UI and the Cloud Connector for Google to discover the items?
Thanks for the response!

As far as I know, you don’t need to expose items for Google Assistant. I definitely have items appearing in Google Assistant that aren’t exposed in Paper UI.

You are mixing things.

If you are integrating with IFTTT you need to expose your Items using the Cloud Connector settings. Only exposed Items will appear on showing events and their current state and all that sort of stuff.

For Google Assistant and Alexa integration you do not expose your Items in the Cloud Connector settings. In fact please don’t expose your Items in this way. It does nothing functional for you and it contributes to the overloading problem on IFTTT.

For GA and Alexa all you need to do is tag your Items as documented. These Items do not appear in You will not see events for these Items in As far as is concerned, these Items will not exist. Google Assistant and Alexa access the Items directly through the REST API.

Rich, now that we’ve come to this realization, is there a method to broadcast this to everyone in the community and/or all users?

Thanks a lot for this information. I genuinely thought I had to expose the items as well.
Looks like more people are mistaken with that one indeed.

I suspect that a lot of people exposed items when they first set up the cloud connector, and then forgot about it when they got more into Alexa/Assistant. At least, that’s what happened with me.

I think the idea of fixing the docs is the best approach for now. There is a link at the bottom of each page of the docs that will take you to the edit page on github. Anyone can propose an update to the docs. See How to file an Issue for details.

Cool, I think @Andrew_Rowe was looking into this. I’d like to contribute to documentation in the future, but not at this time.