No log entry in OpenHab.log (Raspberrypi 3+)


I recently upgrade my openhab2 to release 2.2.0. Post upgrade I don’t see any log entry in Openahb.log file however I do see an entry in events.log file.

Also , I see 3 new MQTT bindings under PaperUI>> Add-ons

  • MQTT Bindings ( binding-mqtt1-1.12.0)
  • MQTT Bindings ( binding-mqtt -2.5.0 M1)
  • MQTT Bindings 1.X ( binding-mqtt1-1.14.0 M1)

I have manually selected MQTT Bindings 1.X ( binding-mqtt1-1.14.0 M1) within adding.cfg (binding =mqtt1). Please suggest if I have to select the other and most recent one.

Appreciate your help!

Really 2.2.0? You decided to update and choose a release that is well over a year old? Or is this a typo?

The rest seems to point to you’ve installed OH 2.5 M1.

Try Clear the Cache first. You should be seeing entries in openhab.log too. This problem needs to be solved first.

Choosing the 1.x binding is appropriate for now but eventually you will want to upgrade to the 2.x version. Both versions can run in parallel but they work fundamentally different so it’s not just a simple copy and paste of configs to upgrade.

It’s not a typo mistake.
I tried installing 2.4.0 sometime back but I ran into lot of compatibility therefore I decided to stay with 2.2.0. If you know a stable 2.4.0 installing package please share the link. ( last time I used the manual installing through .

OpenHABian and apt and yum are all stable installs. The manual install is stable as well. You provide no details so I couldn’t begin to guess what your problems are.

You absolutely will not be able to run a 2.5 version binding on a 2.2 core. There have been lots of changes to the core making that impossible.

It’s also going to be hard to get support on this forum from such an old release.

Thanks for your reply.

After few struggle ,I was able to install stable version 2.4.0 ( manually) however I landed up into another issue.

  1. Slider control on all my sitemap files has stopped working - attaching an error in a separate text file.
  2. Openhab.log file is still empty.

Also, would you suggest to upgrade to 2.5. Somehow I couldn’t find the official announcement for from openhab on 2.5 stable release.OH2-4-0 Slider Error.txt (3.7 KB)

Appreciate your help.

There is no 2.5 release yet. The latest stable release is 2.4, but there have been a number of bugs fixed, especially in the MQTT binding so I would recommend the 2.5 M1 release, which, based on your OP is what you a were trying to use in the first place.

I can’t open the log file, but the first thing to try with errors like that is to Clear the Cache

Thanks for your recommendation for MQTT binding 2.5 M1 release, Hope it helps!
I normally prefer to add binding details through configuration file ( /etc/openhab/addons/MQTT.cfg ) not through Paper UI. Can you please suggest a binding tag (e.g,binding = Mqtt1 I am currently using for version1.1)

Also, as request earlier , do you know why Slider element has stopped working in sitemap since then I upgraded to 2.4.0 from 2.2.0.

Thanks !

1.x version bindings are followed by a 1. 2.x bindings are not. So mqtt would be what you put into addons.cfg to install the 2.x version binding.

I have no idea on the Slider. As far as I know you are the first and only one to report having any issues with Sliders.

Have you tried clearing the cache yet?

@rlkoshak Rick

Could you please help me with the exact text for MQTT Binding ( binding-mqtt -2.5.0 M1) that I can use in addons.cfg file. Somehow I am not able to install 2x bindings through configuration file ( also through Paper UI)
e…g, similar to binding = mqtt1 ( for mqtt -2.5.0 M1 , can I use binding = mqtt2 in addon.cfg)

Also, wanted to know why I am not getting any entry in Openhab.log file. Is there a way to enable it in any configuration file?

Thanks !

For mqtt 2 it’s just “mqtt”. Only the 1.x version bindings have the number after them.

You are probably not getting anything in openhab.log because there is no such thing as “mqtt2” so it’s just being ignored.

“Maybe” something during update went wrong.
I remember having that in the past. During an OH Upgrade, i was asked to keep configuration files or change them with newer ones. Being cautious i’ve decided to keep the old one. And voilá logging didn’t work.
As a solution i think i’ve replaced the old log4js config file with the new one and logging was working again

I tried changing the line item in ’ /etc/openhab2/services/ addons.cfg’ but I don’t see any effect.

’ binding = mqtt ’

I also tried selecting ‘binding-mqtt - 2.4.0’ through Paper UI ( Addons-> Bindings-> ) but not able to install since the installation goes on for ever. Please ref to the attached screenshots.

same is the case while uninstalling existing ‘mqtt1’ through paper UI - it’s also goes on for a indefinite waiting loop.

Please let me know if I am missing anything.

Any input / suggestion on the issue mentioned above ??

Where do I get the new log4js config file?
are you suggesting me to delete an existing /var/lib/openhab2/etc/org.ops4j.pax.logging.cfg file and replace with a new one?

You should have both in the directory.
The new one should be copied in there but with another name. So it should be easy to replace it

I am attaching the folder image here. could you please you please let me know which to replace with org.ops4j.pax.logging.cfg

Sorry for answering late - it does not look as if you have files you could copy.
When I did an upgrade and decided to kepp old files, the new ones were stored in a format like
org.ops4j.pax.logging.dpkg-config (can’t remember the correct name).
But it seems that the upgrade process copies the new files a user selects to keep the old files.

So for you I think you might face a different problem.
Try openhabian-config and let it fix the user permissions. Maybe something is wrong there.

Do you have a spare sd card? I would try a fresh start in that using openhabian and installing 2.5m1. Then copy your backup file using the openhab-cli backup and restore function.

On current system run openHAB-cli backup and save the file somewhere off the current as card. Then once new system is up install the backup using the restore function.

I had log problems when my sd card got corrupt. All I did was reimaged and copy backup and all worked great.