No longer able to Initialize Insteon Bridge

I’m running OpenHab 3.2 for my Insteon HUB 2. I set this up about 2 years ago when the old Insteon company went out of business. It’s been working fine until just last week.

Nothing has changed since I set it up. OpenHab is running on my MacMini using an older OSX. It’s been running fine.

This past weekend our internet was down for a few hours. I rebooted the router. I could no longer control the Insteon devices. I’ve rebooted the Mac several times as well as the router. The Hub shows its Green light, and I even contacted Insteon support and Rob confirmed that the Hub is ok. I’m using the OpenHab app that is on my iPhone and other IOS devices.

I went into the OpenHab User Interface for Settings/Things this morning and it shows that there’s a configuration error for the Insteon HUB Bridge. It will not initialize any longer. I have no idea what’s the problem. I even restored the OpenHab files from a backup made in November.

Sure could use some help. Thanks.

What is the configuration error? You might need to look in the log files.

It says Configuration Error-Initialization Failed, unable to start the Insteon Bridge with the port “/hub2/Zantoria…”. The last part is the IP address and name of the hub and password.

None of this has changed.

I’m getting this from the OpenHab program under Settings, Things–where it shows all the devices and their status. It shows the Things that are Insteon devices as Bridge Offline.

Yes, what do you see for the device that starts with insteon:network when you click on the >?

The identifier is 7d99a8724e

What do you see in the log files?

Can I send you the events.log if that’s what you’re interested in.

Here’s the events.log file.

events.log (11.8 KB)

What do you see in openhab.log? If you don’t see anything you might need to enable debug logging for org.openhab.binding.insteon. If needed, check out Logging | openHAB

So I went into the OpenHab Things and clicked on the + to add a new Thing, and had it scan for device it showed this:
Insteon Device 475355 47.53.55
Insteon: Device: 7d99a8724e:475355

I cancelled the procedure, but didn’t know if this helps.

Here’s the openhab.log file
openhab.log (3.4 KB)

Late this morning I decided to try to remove the Insteon Network Thing and create a new one. It said it was being removed but nothing happened. I rebooted the Mac and then tried to start OpenHab but it couldn’t be found. So I restored the OpenHab folder from a backup and now I can open it up but its showing the same errors as before.

If you need either of these logs from earlier today or yesterday before I did the restore to them this morning, I can restore these older log files. I assume though they will be showing the same error that keeps getting identified when the OpenHab server is trying to connect to the Insteon HUB.

It can’t connect to the hub, is the ip address correct?

2023-12-13 10:35:49.796 [WARN ] [teon.internal.driver.hub.HubIOStream] - open failed: connect timed out
2023-12-13 10:35:49.796 [WARN ] [ternal.handler.InsteonNetworkHandler] - Initialization failed, unable to start the Insteon bridge with the port '/hub2/***:***@'.

I just figured it out. I went into my router and checked the devices on the ethernet network, and the Insteon HUB is there but its IP is showing as not!! I changed that to 15 and rebooted the HUB and it’s working!!

I cannot imagine how its IP address got changed.

1 Like

Both the HUB and the Mac where the OpenHab server is setup have FIXED IP addresses in the router. So who knows.

Rob-Thanks for your help in working with me to resolve this problem. I felt like it had to be a network issue, but I never thought that the modem/router would somehow change the IP address for a device that has a fixed IP. Only xFinity knows what really happened.

Stephen Scott
1930 Franklin Drive
Charlottesville, VA 22911
(434) 242-9237

1 Like