No network after reboot

  • Platform information:
  • Hardware:RPi 3
  • openHAB version: 2.4
  • SSD hard drive (and not SD card)

I noticed that every few days / weeks my system stops working.
I read in many places here that this is due to the persistence service (using influxdb with Grafana).

I decided to set up my system for a daily reboot, but noticed a strange behavior.

Whenever I reboot my system, when it comes up it has no network connectivity (even the lights behind the Ethernet connection do not light up).

I reboot using the following command in putty:

sudo reboot

What may cause this?

You will have to look at the syslog to see what it gets stuck on when the RPi comes back and fails to connect to the internet. Or plug the RPi into a monitor so you can watch the messages scroll by and see where it gets stuck. Whatever the problem is, it’s not OH specific so you might find more help on an RPi forum.

1 Like

I followed your recommendation and connected the RPi to a monitor.

I found out that when it starts up it displays the following error:

Under-voltage detected!

I tried connecting the fan to a 3.3V pin (instead of a 5V pin) - but this didn’t help.

When I changed the power supply to a “cube” I got from Apple for my iPhone (it reads 5V, 1A), the error message disappeared.

This is really strange, because the power supply I was using reads 5V, 3A.

I have connected to my RPi a fan, a ZWave stick and a SDD Hard Drive.

Any insights?
(as you understand - I am a complete newbie with RPi3 and OpenHab)

It may say 5V, 3A but is it really producing that voltage? The error is pretty clear. The power supply was not sufficient to drive the RPi and everything you have plugged into it. RPis are very sensitive to the quality of their power.

What is the recommended volt & amper for the RPi power supply?

Can you recommend a reliable place to buy such a power supply?

OK - So I bought a new power supply and receive no under-voltage warnings anymore.

When I try to manually sudo reboot the system - it starts properly (tried a few times).

However, whenever the system is restarted at 03:00am by the RPi cron, I don’t it working in the morning.

Here is the system log from when the reboot process started until it “stucked”.
Seems like the last item is related to influxdb.

Thanks for your assistance.

syslog-reboot.txt (65.3 KB)

Out if curiosity, have you rebuilt your drive recently? Sometimes corrupt file system can cause these types of issue and if you had a power issue the file system may have become corrupts.

No I haven’t.

Do I do it as explained here?

Also, attached is the openhab.log file, until the system “sticked”.

openhablog-reboot.txt (28.0 KB)

Some additional updates:

I am able to reproduce the problem also when I manually execute:
sudo reboot

To better understand the issue, I connected my RPi 3B+ to a screen and it seems that when the system is stucked, there sia BLACK (blank) screen, and the RPi has only the red led on (not green).

I suspect that on those occasions the system does not / can not read the SSD HD.

Is there any way to check if the issue is indeed the SSD HD boot?
Is there any way to repair it?
Should I fully re-install everything?

I tried searching both this forum and RPi forums, and am completely confused.

Any assistance for a newbie would be appreciated.

Reading some more, could it be somehow related to the SSD using USB 3.0, or maybe not booting fast enough?

Looks relevant “How to check filesystem for errors”

If you are booting from sd. You can put an sd card with boot code.bin on it. This made my pi boot 100% of time of ssd.