No UI refreshs on iOS Safari browser

OH 4.1.0 (but problem has appeared at least since M5)
iOS 17.1.2

I am currently facing a problem that MainUI is not updated anymore correctly.

  1. When adding a new (unlinked) item, the item counter in settings menu is not updated and this newly created item does not appear under „About&Help“ → Listen for UI commands
  2. When making changes to my personal widgets, they are also not refreshed so that I cannot test them in „run mode“

I have tried to force an update in variuos ways:

  • Browser refresh
  • Browser kill and restart browser
  • Restart iPad
  • Press „Restart App“ button under Help&About
  • Restart OH server

Deleting the browser cache finally solved the problem.
Could anybody confirm this problem?

1 Like

I cannot reproduce 1, and IIRC 2 always required a refresh/reload of the page, because UI pages and components are stored in Vuex and only refreshed if MainUI reloads.
Though I am on iPadOS 17.2, so let‘s wait what happens when upgrading to iPadOS 17.2.1.
Anyway, I‘d rather suspect that the problem is not MainUI or the openHAB server, as there haven‘t been changes for a while to the relevant parts of where you experience those problems.

Hmm. This is really weird. I updated to iOS 17.2
It seems that the “first level” of MainUI does not get updated.
I changed a property of a page (adding to MainUI’s sidebar). Changes are visible on the details sheet (see screenshot)

but the order number is missing on this level and the page does not appear on the sidebar:

I am not saying that there is a problem with MainUI. At first I wanted to double check here if somebody has a similiar issue.
If it is not related to MainUI, maybe someone has an idea what the problem is.
All possible counter actions I can think of I have already done but with no luck.

My iPad is on iPadOS 17.2 (the latest one as of writing).

I haven‘t experienced such issues on 4.1.0 Relase, I just tried several times to reproduce your example, every single time I clicked save the sidebar updated and when I navigated back to the pages list, the index was displayed properly.

Have you cleaned cache and reload the web app? Do you use a reverse proxy?

No webproxy. Cache deleted, app restarted, I did the full monthy.
What I found out, the only way of forcing the app to refresh and load changes is to switch the browser to „desktop mode“

But don‘t bother. It seems to be just my device and no one else‘s. That‘s ok then.

Anyway I’d like to know what’s the problem. But as I can’t reproduce (and iOS is anyway difficult to debug), I don’t know what to do here.

@Oliver2 FYI, I have created a fix for the caching issues with Firefox, I would say, let’s wait for the merge and then check whether it solves your issues in Safari as well.
As your issues are clearly related to caching, I think there is a high chance they will also get solved.


Very kind of you - that was not really an issue for me and I could have lived with that problem easily.
Anyway, thanks a lot for taking care!
I‘ll report back once that fix will be available in the next Milestone release.

1 Like

Been having the same problem and stumbled across this thread. I’ve just cracked this:
Visit the website you’re having issues with.
Go to Safari settings in Settings.
Hit the Clear History and Website Data button and choose the last hour.
Go back to Safari and reload the page. Voila! Well - worked for me anyway when I wasn’t seeing css changes come through.