No updates after restart of homematic server

Hi there,
I would like to ask for a hand in finding a problem I have for a while now, ignoring it, because I have no clue. :slight_smile:
I am using a rasperymatic with latest software and another raspberry pi with latest OpenHAB.
My issue is: There seems to be a situation, when the homematic binding is not fully working: not doing some updates from f.e. window contacts (maybe only them).
Looks like this behavior has its cause in a restart of my raspberrymatic.

Just now it happens like this:
Yesterday evening I triggered an automatic update of the raspberrymatic, which was a smooth update with restart.
Today in the morming I opened several windows for letting in some fresh air. :slight_smile:
I saw that my heatpump was triggered to ON, what could not be, because with several opened windows, this is forbidden in a rule.
So I started an investigation, which lead to the fact, that OpenHAB was now aware of some open windows.
I disabled my homematic bridge and reenabled it.
My problem was solved. My heatpump was turned of again.
I had this issue several times now. Solved in same way.
Already thinking about a rule for automatically restarting the binding. But maybe there is a better fix for this?

My question is: Is there a known issue regarding this, or can someone point me to a direction to solve this misbehavior? Maybe a common misconfiguration on my side?

Thanks a lot for sharing some thought about this.
Most of the time I was able to solve upcoming issue by reading all the great posts in here, but this time I found only older stuff, maybe overlooked something.

Best regards,

Though I am on nearly the same setup (pivCCU on Raspi 3 and OH 3.4 on Raspi 4) I have no final solution for this problem. I know that under certain circumstances the homematic binding does not find the CCU but was too lazy to investigate further. I can confirm that it sometimes happens when the CCU is being restarted. Might be that the IP adress of the CCU is already reachable but cuxd is not ready yet and so the homematic binding “thinks” that the CCU is not reachable. Or after restarting the CCU not all devices are initialized when the homematic binding first asks for available devices? Really don’t know.
To be on the safe side I restart the homematic binding when the CCU is back online. You can do this automatically from the raspberrymatic when rebooting by adding a service which depends on successfully starting the CCU and then executes

  sudo /usr/bin/sshpass -p <your_password> ssh -p 8101 openhab@<your_OH_machine> "bundle:restart <your_HM_bundle_ID>"

Your OH raspi must have sshd enabled for this to work.

Thank you for sharing your idea. Sounds like a good workaround and I think I will give it a try next. :slight_smile: