No Z-Wave event detection from devices

Hello all.
First I have to tell everyone to assume that I know nothing about this, which isn’t far from the truth, so I’d appreciate any answers to be as comprehensible as possible.
I’m having trouble getting openHAB to detect events from my Z-Wave devices - Fibaro Smoke Sensor (FGSD-002) and Aeotec Door/Windows Sensor 7 (ZWA008).
I have a Raspberry Pi 4 with Raspbian (Buster) and the RaZberry Z-Wave controller and openHAB (version 2.5.1-2) installed through repositories. The Z-Way and Z-Wave bindings are both version 2.5.1.
Using Z-Wave.Me I successfully added my devices and the door sensor works as intended. The smoke alarm I have since found out doesn’t produce a “real” alarm using the test button, but I receive battery status and temperature.
In openHABs Paper UI I’ve gotten the devices to show up under Things. After creating a simple default.sitemap and default.items file they are visible in the Control tab. Both show battery levels (both 100%, which I assume but am not certain are correct) and switches. The smoke sensor also show the correct temperature.
That’s where my successes end. I’ve put the smoke alarm aside to shield my family from the loud beeps and have instead concentrated on the door sensor. Searching the forums and documentation I hope to have set all the devices’ channels to Number and Switch and such correctly. In the openHAB console I’ve messed a bit with the log command - setting org.openhab.binding.zwave to debug (or any other mode) and then log:tail doesn’t detect anything. I’ve loaded the openhab.log and events.log in the Z-Wave Log Viewer at but both comes up empty though the files aren’t. I’ve seen conversations about Z-Wave XML files in the userdata folder, but I can’t find that folder. The Z-Wave Configuration page at github shows images from HABmin which doesn’t look like my HABmin at all. I realize the document is six years old, but I can’t find anything that does what those images show, so I haven’t been able to configure associations which I read somewhere in the forums is necessary. In HABmin / Configuration / Things / it seems I should have an Association Group, which I haven’t, but I’ve got a Configuration tab, which only contains Node Id.


Switch FGSD002_Bt_Smoke "Alarm Bottom Floor Smoke" <smoke> {channel="zway:zwayDevice:4aaceca9:3:sensorBinary-ZWayVDev_zway_3-0-113-1-2-A"}
Switch FGSD002_Bt_Heat "Alarm Bottom Floor Heat" <fire> {channel="zway:zwayDevice:4aaceca9:9:sensorBinary-ZWayVDev_zway_9-0-113-4-2-A"}
Number FGSD002_Bt_Battery "Alarm Bottom Floor Battery [%d %%]" <battery> {channel="zway:zwayDevice:4aaceca9:9:battery-ZWayVDev_zway_9-0-128"}
Number FGSD002_Bt_Temp "Alarm Bottom Floor Temperature [%.1f °C]" <temperature> {channel="zway:zwayDevice:4aaceca9:9:sensorTemperature-ZWayVDev_zway_9-0-49-1"}

Switch ZWA008_FDr_Sens "Front Door State" <door> {channel="zway:zwayDevice:4aaceca9:10:sensorBinary-ZWayVDev_zway_10-0-113-6-Door-A"}
Number ZWA008_FDr_Battery "Front Door Battery [%d %%]" <battery> {channel="zway:zwayDevice:4aaceca9:10:battery-ZWayVDev_zway_10-0-128"}


	Frame label="Alarm"
		Default item=FGSD002_Bt_Smoke label="Alarm Bottom Floor Smoke"
		Default item=FGSD002_Bt_Heat label="Alarm Bottom Floor Heat"
		Default item=FGSD002_Bt_Battery label="Alarm Bottom Floor Battery [%d %%]"
		Default item=FGSD002_Bt_Temp label="Alarm Bottom Floor Temperature [%.1f °C]"
	Frame label="Front Door"
		Default item=ZWA008_FDr_Sens label="Front Door State"
		Default item=ZWA008_FDr_Battery label="Front Door Battery [%d %%]"

Both of these are loaded without errors. If they are incorrect or lacking I don’t know.

I’m happy to provide additional information, but please remember I’m a complete newbie.

It appears things did not go as planned. Did you follow that section of the documentation and enable debug logging? :wink:

This log viewer can help interpret them. Posting them here is a good idea too.

1 Like

You can’t have both running at the same time.

You are using zway definitions, so please change the zwave tag to zway to get attention from people using the zway binding.

Sorry, I missed that. I changed the tag.
I do not see how zway could improve on the zwave binding, especially with Chris and his dedication.

1 Like

Ah. Either from the documentation or from having read several forum threads and likely confusing and mixing together different issues I was under the impression that you first had to have the Z-Way binding to connect to Z-Wave.Me, and then the Z-Wave binding to access and integrate the devices themselves into openHAB. I figured they were just two halves working together.
I’ve read the Z-Wave and Z-Way Binding documentation more closely now, and it seems that with a RaZberry I should use Z-Way, correct? Well, I removed the Z-Wave binding but still nothing, even after an openHAB restart.

Yes I have enabled debug logging, but as previously stated that doesn’t seem to detect the sensor.
I just realized that if I’m now running Z-Way instead of Z-Wave the org.openhab.binding.zwave shouldn’t show anything related to Z-Way, right?

The log viewer is empty, even though the log files aren’t. Perhaps only relevant info is shown in the viewer and my log files are lacking that?

Perhaps tomorrow I’ll try installing the Z-Wave Binding instead and see if that works, in case I’m wrong about the RaZberry / serial stick thing.

What benefits does connecting there give you?
Just curious.

I don’t recommend this. There are only a few users running the zway binding.
I would recommend to stop the zway server permanently on your razberry and use the board with the zwave binding.

1 Like

I have no idea, I read documentation and forum threads and thought it was a requirement and didn’t think about it much further.

Well, if Z-Way isn’t required and Z-Wave is better I guess I’ll try that instead and hope for better results. Thanks for your input and clarification.

1 Like