Node-Red Issue (I think)


I hope the image helps with hardware/software

This is my first post because this community has great people and I can usually find the answers I need. I’ve been using OH for about a year and really enjoy it. I’m not much of a coder so OH3 has really helped me add some nice stuff to my very small home auto setup.

I have Node-red installed and running. When I insert a OH node, I cannot select an item. The item button is grayed out. I am wondering if there are any bindings that need to be installed or if there is something I am missing (which more than likely the case). I’m not to sure what information to supply if any so please ask if necessary.


Thank you in advance

You need to create an API token in OH3. Under the profile of your account in the dashboard, choose “create new API token”. Copy that key and paste it into the “username” of your OH node in node red.

This process has been added to the documentation:

Thank you very much. I will try that later this evening.


Sorry but I didn’t get a chance to look at this last night. I just tried making a token and am getting the same results. I looked at the debug sidebar and noticed a bunch of errors that occur every second.

I think that I will read up on MQTT and try using that instead.

I appreciate you help. Thanks

Well , I just installed Node-Red and it appears to be functioning correctly. A big :blush: on may part. Stupid me should have tried that a while ago.

Thanks again