Node Red - no item for openhab selectable (node-red-contrib-openhab2)

Hello all,

I’ve an issue with Node Red and Openhab.
I installed the package node-red-contrib-openhab2 and can successfully use “Monitor” and “Events”.
But when I use “openhab2 in” I can select any item - the connector is still the same.

I also started a new node red instance on my second raspi - still the same issue.

Any ideas?


Works for me no issues.
Did you create your items in the paperUI or with items files?

Hi @janwilke,

what was your problem? Because i have the same trouble. Don’t know why :frowning_face:


Same problem here (when creating controller, no Items are shown for all nodes with items selectors). Any idea ?

I ended up creating a new nodeRED docker container with a fresh install. That was the only way it worked for me. In fact, the plugin couldn’t see items for either of my openHAB instances (2.5.11 or 3.0.0, run in parallel in docker containers).

Thank @Dome, an update of the docker works for me. I can browse items and openhab2-in works well.
I now get an error with openhab2-get : “ReferenceError: headers is not defined”. Any idea ?

1 Like

Hi dirandad, i get exactly the same.
Get and Out Nodes don’t work, In does.

Did you figure out if we need to set some kind of input (instead of just a timestamp trigger)?

For some misterious reason it seems to work now.
Out Node wasn’t displaying the “TOPIC” once selected it worked.
Furthermore removing all payload from the trigger also mad the get work