None of my energy metering able ZWAVE devices report based on push settings, only at poll interval

  • Platform information:
    • Hardware: Raspberry Pi 3 Model B Plus Rev 1.3 - Aeotec Z-Stick GEN5
    • OS: Raspbian GNU/Linux 10 (buster)
    • openHAB version:openHAB 2.5.5-1 (Release Build)

Trying to get more out of my ZWAVE devices and use their energy metering function.
Bottom line I can’t get any of them to push energy metering based on configured thresholds or time based reporting. They all just respond to polling interval full stop.

All started when I started a project to manage my Hybrid car charging using ZMNHTD Qubino smart meter and Iskra contactor. The only way I get it to report power, energy etc is by setting polling period. If I set it to 1 day,I’ll get report once a day. If set to 30 seconds, I get a report every 30 seconds.
But it should independently from polling period also push reports based on parameters 40 (reporting watts on power change) and/or 42 (reporting on time interval) but no matter what I have tried, it does not react on these parameters and only respond to polling.

Since I have several other energy metering enabled ZWAVE nodes from FIBARO I have tried to set them to push energy metrics based on threshold and/or time but finally none of them do and all only send reports when polled based on polling interval.

I really need to get to the bottom of this and am ready to invest a lot of time to resolve it. For this I’ll need help from senior Openhab members with deep ZWAVE debugging knowledge.
I’ll be happy to post any debug level logs when required. For now, I’ll just share 1 zwave nodes XML files if that helps at this stage.

network_f7a2f339__node_18.xml (27.3 KB)

Check that the controller is included in the associations. Sometimes you need to clear the associations, save, and add it back in for the change to take effect. Your device may also have configuration parameters for energy reporting. It is also helpful to delete (not exclude) and rediscover your Things to update the Thing definitions.

Hi Scott. Txs for the hint. Where can I check whether controller is included in association? What do you mean with “clear the associations”?

I’ve tried “healing” the device to no avail. Isn’t that almost equivalent to delete and rediscover? I have mixed experience with deleting and rediscover things as it has given me headache with linked items. I’ll try that if nothing else helps.

Use Habmin for anythgin Z-Wave related. Under Configuration> Things, select the Thing for your device. You will then see a section for associations. Add the controller, if it is not there, and save. If it is there, remove it, save, add it again, and save.

Healing would not help and is nothing like deleting and rediscovering. Delete the Thing and then start discovery for the Z-Wave binding, then add the Thing from the Inbox. Your Items should all link back up. Use Habmin :slightly_smiling_face:!

Thanks for your help Scott. Yes I do admit I started in 2018 with OH2 and Paper UI. Never really got to HabMin.
I just edited my Qubino Smart Meter thing with Habmin and it looks like it finally works (push updates). I didn’t even deleted/rediscover it. Great! (good reason to definitely switch to HabMin)
Now looking at the other Fibaro devices. There, a simple edit in Habmin doesn’t do it. I’ll have to delete/rediscover. I’ll do it tomorrow.To to sleep now…

1 Like

Hi Scott. So I did remove a non properly working thing for a Fibaro FGS213 Single Switch 2 that was created in Paper UI and where current Items/links were still there.
As I expected, it did create a big mess: after rediscovering the thing, only the parameters were retained, not the Channel links. As I tried to relink them to existing items in Habmin, it just did not save the link until I created a new link to a new item and then boom, habmin would show me the new one and an empty one that could not be deleted because non existent!
So I ended up having to use rest API to clean the orphan mess in Items and links. Still busy right now to clean all orphan items and links. When done, I’ll try redo all channel-Item links in Habmin and see if it now works. My next step if not working will be to switch to file based item/links which seems to be the consensus workaround for many users after too many gray hairs using UI
I believe OpenHab developers really should pay all this a lot more attention.

Another question: I have found no way to get full Channel names in HabMin. All I can get is Channel label with the little copy/paste hoover button next to Item name on habmin Thing/Channel screen. In Paper UI it is very easy to get but in Habmin?