NOOB: Setup ZWave network on Pine64 OH2

Hi All,

I’ve bought the Pine64 2GB and Z Wave module (EU version) to automate my home using OpenHAB.

As I am a total NOOB at this, I decided to first create a small Z Wave network using 2 Domitech Z Wave smart LED light bulbs only.
I immediately got stuck:

  • I’ve installed OpenHAB on my Pine64.
  • In Paper UI on Configureation->Things page, I see the Z Wave Serial Controller: ‘online’ (connected to /dev/ttyS2).
  • I then try to get the controller to get into discovery mode by pressing the big ‘+’, select Zwave binding.
  • For 30 seconds it shows a rotating arrow, within that time I put one bulb in discovery mode.
  • The bulb does not get ‘discovered’.

Am I doing something wrong?
Is there any way to tell if the Z Wave device is really in discovery mode?

Need help here…

For zwave I highly recommend using Habmin over PaperUI. It is written by the same person who implements the binding and it had a ton more features for configuring and managing your zwave network.

Also tried with habmin, but same result.
I found the log file, even found how to create the log in debug mode.
In the log (both, through paper ui and habmin) I see that it should be in discovery. But I see no difference in if I just enter discovery or when I enter discovery and try to pair up with the bulb.
In habmin I see that I can enter some parameters, but when I do and save, next time I check it’s back to original.

So I guess that it’s one of the following:

  • pine64 z wave module not properly integrated (doubt that as Kai published the image I am using)
  • pine64 z wave module nor properly configured (could be, as I don’t have any experience with it)
  • pine64 z wave module not working (could also be, it’s new but have never seen it working, don’t know how to check)
  • bulbs not working (less likely as I have 2 that have same behavior, both new, fresh out of box, also here, do not know how to check)
  • bulbs an pine zwave module incompatible (also here I do not know how to check)
  • me doing something wrong (as said, I am a noob)

I would recommend checking the log - put it into debug mode and see what is happening - otherwise, it’s all guesswork…

You can use the log viewer here.

Finally got it to work, it was something with the sockets I’ve put the bulbs in.
With a standard light bulb, the socket worked just fine, when I hit the light switch, lamp on, hit it again lamp off.
With the smart zwave bulbs, when I turned the light on, nothing happened. ‘Knowing’ that the socket was good, I thought is was due to the bulb needed to be included in Z Wave network first. Tried a lot of things, re-flashing, analyzing log files, etc. But could not get any reaction from the bulb and could not get it discovered.
As a last resort, I tried another socket and immediately when I hit the light switch, the lamp went on :slight_smile: . Then tried discovery, it got detected and now it works!
So it wasn’t a defective Z Wave module, defective bulb or misconfiguration of openHab, just a bad contact between socket and bulb…


Can you tell me how you got the pine64 zwave module working? I keep getting:

2018-01-01 15:05:49.406 [hingStatusInfoChangedEvent] - ‘zwave:serial_zstick:ab377118’ changed from OFFLINE (COMMUNICATION_ERROR): Serial Error: Port /dev/ttyS2 does not exist to REMOVING

in OH2.2

Hi Bas,

Sorry, I cannot help you much:
Shortly after I got the ZWave to work, I ran into more problems when I tried to add some non-zwave devices (433 MHz and Sonoffs). Don’t know what the status is of OpenHAB right now, but about a year ago, status was that it still was a work in progress: unstable, difficult to configure, different UI’s where somethings needed to be done in one and others in another UI, only partially documented. Back then I decided to try Domoticz instead and found that at least to be more consistent an less confusing, so I’m now using that. I do not really recall how I got it working…