NordVPN Meshnet on openhabian

Hi all,

NordVPN just recently announced their Meshnet concept allowing devices with NordVPN to communicate securely with each other on internet. This sounds perfect for external com with RPi based openHAB units.

A NordVPN Linux Debian RPi version is available on Download the Best Linux VPN | NordVPN.

Anyone tried this Meshnet concept with openhabian yet? If so, would you mind letting us know how to set it up to a working level.

This simple (it seems) com concept should be very useful to many openHAB enthusiasts already having NordVPN installed on Win, iOS or Android devices, or planning to.

Looking forward to your response.


FWIW, openHABian comes with Tailscale VPN. Pretty much like Meshnet but free for personal use.

I’ll second the recommendation for Tailscale. All you’d have to do is install it on the machines and log in. It’s really simple but really powerful.

But if you already have NordVPN, I suspect you’d just have to follow the instructions to install and configure it. But you’d probably either want to start with the NordVPN image and install OH on that or start with the openHABian image and install NordVPN on to that. Both images will want to do stuff to the networking and I’d expect attempting to install openHABian over the NordVPN image will break things.

I wasn’t aware of Tailscale being available in the config menu. I’ll take a look.

Yes, sounds a bit scary. Tailscale sounds more promising.

I have an issue with NordVPN. It frequently blocks my internet access when a device wakes up. A dis-/reconnect fixes it, but very annoying.
Any issues with Tailscale?

Thanks for responding. Very enlightening.
Make it a good one!

None that I’ve noticed. It seems to connect a whole lot faster than OpenVPN ever did. The only problem I’ve noticed when connecting on my phone when my cell signal is bad or when I’m between disconnecting from WiFi and reconnecting to 5G there might be a slight delay in reestablishing the connection. I bet there is some timeout somewhere that has to occur before it notices it’s disconnected from one network and transferring over to the other.

I have it configured to route all the traffic through Tailscale so I get the benefit of my Adguard service even when I’m not at home so when Tailscale is on but not connected there is no internet.

The only things to watch out for is the client certificates expiring. By default they last 90 days or something like that and you have to reauthenticate to connect again when it expires. You can turn that off if you want though and have never expiring certificates.

Tailscale does depend on an account and use of Tailscale provided services which are free for one user and up to a dozen devices (or so). However, there is a FOSS implementation of their control server called Headscale: GitHub - juanfont/headscale: An open source, self-hosted implementation of the Tailscale control server. But you’ll have to host that somewhere internet accessible like a VPS.

Thanks a million!!
I now have Tailscale on my iPhone talking to my OH3->OH2.5.12. Works fine!
I then tried to install it also on my old OH2.5.9 backup RPi without success.
The log says: FAILED (update apt lists)
Is the config 3A for OH3 only, or is the attempt to install on 2 RPis the issue?
Would you know?

Tailscale has nothing to do with openHAB itself. openHABian has an option to install it, but it’s like InfluxDB or Frontail, it’s a third party app that openHABian happens to install and configure. Therefore the version of openHAB doesn’t matter.

There is no problem having more than one RPi in the network. I do this myself.

I do see that you are running a really old version of OH on this second machine. Maybe you have an older version of openHABian installed and it’s trying to use the wrong apt repos or something. What do you see if you try to install it manually? sudo apt install tailscale I think.

Usually openhabian-config will prompt you to upgrade itself when you run it, have you done that?

Try installing it following the instructions on Tailscale’s site. Pay particular attention to the installation of the apt repo and signing key.

It also could be a simple matter that the repo is temporarily down.

A manual install returns the following:

openhabian@openhab:~ $ sudo apt install tailscale
Reading package lists… Done
Building dependency tree
Reading state information… Done
E: Unable to locate package tailscale

However, openHAB 2.5.9 contains the following 2 files in ./var/lib/apt/lists/

When installing from config 3A the file/package requested seems to be
deb buster main

Can you make any sense of this?

Not really except to again recommend going to the tailscale website and follow those instructions.

No. openHAB does not contain anything of the underlying OS:
The OS in turn is badly configured in your case, probably outdated because you didn’t update it.
The repo from the config is the right one, it should do.

Thanks for the update, appreciated, but FYI the config route still doesn’t work. A manual install says among other things that repo no longer has a Release file and is disabled by default.
So that terminates my attempt to run Tilescale on OH 2.5.
Thanks for your precious time.

Any issues with Tailscale?

I’ve tried a number of different VPN options and have found that Tailscale will drain my Android battery if I leave the service on. This was as a result of the constant pinging it does with the coordination server in order to keep the udp punched hole open as it thinks the host is on the other side of a NAT.

I ended up placing my openhab server on a Cloudflare tunnel which gives me a public URL for my firewalled and locally hosted server. It also allows me to authenticate with my Google account for security. It’s not a straight forward setup by any means and it’s not compatible with the openhab app. The only advantage is I can access my openhab web front end from anywhere and on any device without the need of a VPN or other application such as nord.

Thanks J_Cat,


Exactly my need. My openHAB is fully automatic (no controls), but should be checked every now and then. I have had Z-Wave devices failing.

I’ve also noticed a higher power drain recently, but I did 2 things to my iPhone:
a) Updated the phone for security reasons.
b) Installed Tailscale.
I have not come around to test why the extra drain, but I have had Tailscale active, which might be a good part of it.
It’s off now. Thanks!