Nortek HUSBZB-1 Ember Coordinator - Serial Error: Port /dev/ttyUSB1 does not exist

Raspberry pi 4 2GB

Raspian OS

Java™ SE Runtime Environment (build 1.8.0_231-b11)

Openhab 2.5.0.M4

Aeotec Gen-5 Z-wave stick is working on ttyAMC0

dmesg log shows the device is there on ttyUSB0 and ttyUSB1

[ 987.582218] usb 1-1.3.7: new full-speed USB device number 7 using xhci_hcd
[ 987.719299] usb 1-1.3.7: New USB device found, idVendor=10c4, idProduct=8a2a, bcdDevice= 1.00
[ 987.719314] usb 1-1.3.7: New USB device strings: Mfr=1, Product=2, SerialNumber=5
[ 987.719327] usb 1-1.3.7: Product: HubZ Smart Home Controller
[ 987.719339] usb 1-1.3.7: Manufacturer: Silicon Labs
[ 987.719350] usb 1-1.3.7: SerialNumber: 5130073A
[ 987.724884] cp210x 1-1.3.7:1.0: cp210x converter detected
[ 987.734099] usb 1-1.3.7: cp210x converter now attached to ttyUSB0
[ 987.736829] cp210x 1-1.3.7:1.1: cp210x converter detected
[ 987.745846] usb 1-1.3.7: cp210x converter now attached to ttyUSB1

EXTRA_JAVA_OPTS= - configured
openhab user added to dialout group
feature: openhab-serial-transport installed 2.5.0M4
earlier I had the serial binding - 1.14.0.M4 also installed but I took it out and it didn’t appear to make any difference

openhab-cli info shows
pi@OpenHAB2:~$ openhab-cli info

Version: 2.5.0.M4 (Build)

User: openhab (Environment Variable Set)
User Groups: openhab tty dialout audio bluetooth

Directories: Folder Name | Path | User:Group
----------- | ---- | ----------
OPENHAB_HOME | /usr/share/openhab2 | openhab:openhab
OPENHAB_RUNTIME | /usr/share/openhab2/runtime | openhab:openhab
OPENHAB_USERDATA | /var/lib/openhab2 | openhab:openhab
OPENHAB_CONF | /etc/openhab2 | openhab:openhab
OPENHAB_LOGDIR | /var/log/openhab2 | openhab:openhab


The openhab log complains the port does not exist.

19:53:06.321 [ERROR] [nding.zigbee.handler.ZigBeeSerialPort] - Serial Error: Port /dev/ttyUSB1 does not exist.
19:53:06.325 [ERROR] [.zigbee.dongle.ember.ZigBeeDongleEzsp] - Unable to open Ember serial port

other posters have had trouble and I’ve tried all the hints I could find but no luck
Any ideas on what else to check?

Try it through a usb hub. The Pi 4 has USB hardware standards issues discovered after release.

I’m using a hub, had to add it to get the Aeotec stick to work.

Actually the HUSBZB was recognized before the hub was installed. Same symptoms and log errors.

On my Pi 3B+ the Z-Wave controller is at /dev/ttyUSB0 and has been working fine.

I’m using the Aeotec for z-wave and it’s working fine

The Nortek is new to me.
It has z-wave interface which I’m not planning to use on /dev/ttyUSB0, and a zigbee controller on USB1.

Any suggestions on additional logging I could enable?

I have no Zigbee devices to try mine. If it is just not being recognized by the binding I can try mine tomorrow.
That system is currently on Milestone 3. I will move it to 4 first. It is currently a test system for me.

It appears the OS sees it as USB1 but the Java machine does not. The openhab thing configuration shows USB0 and USB1 as port choices, so at some level it’s recognized.

This morning, I quickly upgraded the system to Milestone 4, added Zigbee and chose the Ember coordinator. It had issues using the serial port /dev/tty/USB1.

I will need to try more troubleshooting later. I have never used Zigbee with OH2 but had the Zigbee controller recognized with Home Assistant earlier.

Didn’t see it mentioned in first post but have you tried adding openhab user to tty group as well?

I doubt it will help. My openhab user is already working fine with the tty for Z-Wave but not Zigbee.

See your point, but it won’t hurt to try.:upside_down_face:

openhab user already in all groups

User: openhab (Environment Variable Set)
User Groups: openhab tty dialout audio bluetooth

1 Like

I don’t have any specific advice for trouble shooting. I have this dongle and it is working, or at least both the zwave and zigbee show as online.

Here are the settings I have in PaperUI for the coordinator in case it helps anyone.

  • Port: /dev/ttyUSB1 (USB0 is the Zwave controller)
  • Flow Control: Software (XOn/XOff)
  • Baud Rate: 57600
  • Power Mode: Boost
  • Transmit Power: Normal
  • Child Aging Timeout: 1 Day

Thank you for the parameters, Are you running Milestone 4?

My test controller is on a Pi 3B+ running Raspian Lite Stretch. I know the Pi 4 requires Buster.

SNAPSHOT Build #1733 (last updated around Friday of last week).

I’m running in Docker (unmodified from the official Docker Image on DockerHub) on an Ubuntu 18.4 Server VM running on ESXi.

1 Like

Between the 2 of us we should get this resolved.

My Pi 4 is running this

1 Like

@rlkoshak I tried your settings and it is br0ken. I think this is interesting: Serial Error: Port /dev/ttyUSB1 does not exist. It DOES exist though.

Trying the latest snapshot now.

pi@SmartHome:~ $ dmesg | grep tty
[    0.000000] Kernel command line: coherent_pool=1M 8250.nr_uarts=0 bcm2708_fb.fbwidth=656 bcm2708_fb.fbheight=416 bcm2708_fb.fbswap=1 vc_mem.mem_base=0x3ec00000 vc_mem.mem_size=0x40000000  dwc_otg.lpm_enable=0 console=ttyS0,115200 console=tty1 root=PARTUUID=8c2d0a42-02 rootfstype=ext4 elevator=deadline rootwait
[    0.000915] console [tty1] enabled
[    0.894024] 3f201000.serial: ttyAMA0 at MMIO 0x3f201000 (irq = 81, base_baud = 0) is a PL011 rev2
[    7.330212] usb 1-1.1.3: cp210x converter now attached to ttyUSB0
[    7.337390] usb 1-1.1.3: cp210x converter now attached to ttyUSB1

2019-10-29 18:36:33.830 [ERROR] [ding.zigbee.handler.ZigBeeSerialPort] - Serial Error: Port /dev/ttyUSB1 does not exist.

2019-10-29 18:36:33.832 [ERROR] [zigbee.dongle.ember.ZigBeeDongleEzsp] - Unable to open Ember serial port

==> /var/log/openhab2/events.log <==

2019-10-29 18:36:33.838 [hingStatusInfoChangedEvent] - 'zigbee:coordinator_ember:16e19a90ff7' changed from UNKNOWN to OFFLINE: Failed to open communications port

2019-10-29 18:36:33.849 [hingStatusInfoChangedEvent] - 'zigbee:coordinator_ember:16e19a90ff7' changed from OFFLINE: Failed to open communications port to OFFLINE (COMMUNICATION_ERROR)

After installing the latest snapshot build (1736), the Zigbee coordinator now shows as online.
That indicates a bug in Milestone 4 that was later fixed. Now we need to figure out which binding. Zigbee or something else serial or port related.

If you wish I can clean install Milestone 4 & then try to figure out what binding needs updating, starting with trying the Zigbee one.

That error can mean either it’s not there, or the binding doesn’t have permission to read/write to it.

I do recall that there was a time during the snapshots where my coordinator went offline with that Serial error. Since I’m not running any real Zigbee devices yet I put looking into that on the back burner and eventually it sorted itself out on it’s own. Perhaps there was a bug that snuck in with M4 that was fixed later?