Not able to control color in Filament LED

I am struggling with the following. I have 3 filament LEDs in my lamp. They are flashed with Tashmota firmware and work fine. I setup MQTT and am able to control all parameters from Paper UI.

To control them properly, I have a MiLight controller which can send out MQTT messages via an ESP8266. For power and dimmer, it works fine, but I cannot get the BW/WW to work from my MiLight controller. The Milight controller is converted from 153-370 (min-max) to 0-100.

In Paper UI, I use MQTT: stat/woonkamer/kroonluchter/tasmotas/CT (Stat and commands) for my LEDS with a minimum of 153 and max 500 parameter.
My Milight controller sends: milight/states/0x44C8/rgb_cct/1{“state”:“ON”,“level”:50,“color_temp”:344,“bulb_mode”:“white”}
I’m using the color_temp variable.

In my rules, I tried the following configuration:

rule "Milight Colour 01"
   Item MilightControl_01_Colour changed
   val ColourState01 = math::round(MilightControl_01_Colour.state as Number

I also used this rule: val ColourState01 = Math((MilightControl_01_Colour.state as Number - 153) * 2.17)

I am a bit lost, because it will not pick up any changes. Someone a suggestion?

Here are a few examples for using color in rules.

Search for a big thread on espmilighthub as I wrote an old method that used rules and the MQTT binding, the rules in that thread will have working and tested ways you can play with. Using HSB type from memory is the way I got it working.

Thanks all for your suggestions. I will have a look and see if I’m able to solve it