Not getting temperature from ZMNHAD / ZMNHEA1 (qubino)

Tags: #<Tag:0x00007f43480b9360> #<Tag:0x00007f43480b8a78>

Initial database contribution a year ago for endpoint one was v7, so I left it in for endpoint two.

1 Like

@sihui
Thanks for making the changes. I wasn’t sure what the next step is for me to test this. Chris indicated in his post (below) that I would only need to delete the Thing and re-discover it. I’ve done this but the unsolicited temperature updates from endpoint 2 are not getting updated in the linked Item still.

Should there now be another temperature channel for me to link to, or does ‘sensor_temperature’ effectively now get shared by both endpoints 0 and 2?
Or am I being too hasty - does the database need to build first? Still working out the mechanics of all this!

No ‘Updating channel’ message in the log

2020-01-25 15:40:09.187 [DEBUG] [ng.zwave.internal.protocol.ZWaveNode] - NODE 29: Incoming command class COMMAND_CLASS_SENSOR_MULTILEVEL, endpoint 2

2020-01-25 15:40:09.189 [DEBUG] [ng.zwave.internal.protocol.ZWaveNode] - NODE 29: SECURITY not supported

2020-01-25 15:40:09.191 [DEBUG] [tocol.commandclass.ZWaveCommandClass] - NODE 29: Received COMMAND_CLASS_SENSOR_MULTILEVEL V7 SENSOR_MULTILEVEL_REPORT

2020-01-25 15:40:09.192 [DEBUG] [ss.ZWaveMultiLevelSensorCommandClass] - NODE 29: Sensor Type = Temperature(1), Scale = 0

2020-01-25 15:40:09.195 [DEBUG] [ss.ZWaveMultiLevelSensorCommandClass] - NODE 29: Sensor Value = 24.9

2020-01-25 15:40:09.197 [DEBUG] [ding.zwave.handler.ZWaveThingHandler] - NODE 29: Got an event from Z-Wave network: ZWaveMultiLevelSensorValueEvent

2020-01-25 15:40:09.199 [DEBUG] [ding.zwave.handler.ZWaveThingHandler] - NODE 29: Got a value event from Z-Wave network, endpoint=2, command class=COMMAND_CLASS_SENSOR_MULTILEVEL, value=24.9

2020-01-25 15:40:09.201 [DEBUG] [nal.protocol.ZWaveTransactionManager] - NODE 29: Commands processed 1.

2020-01-25 15:40:09.203 [DEBUG] [nal.protocol.ZWaveTransactionManager] - NODE 29: Checking command org.openhab.binding.zwave.internal.protocol.ZWaveCommandClassPayload@115471c.

Yes, but you don’t needed to exclude it. All this does is ensures that OH reads the new database.

The binding has not been updated - I will do this tonight, and if you update your system tomorrow it should then have the updated definitions.

Exactly :+1:

I’m currently running the stabil version of OH (2.5.1) with the 2.5.1 z-wave binding. Do I have to switch the whole OH to snapshot-version in order to “update the system”? :-/

No, just the binding.

Is there a procedure for updating the binding? I’m running Openhabian. Will running Option 2 ‘Upgrade System’ achieve this?

Yes, asked about a 1000 times already: either do it manually (uninstall binding, drop the snapshot in your addons folder) or use this script:

@sihui
OK - thanks for the link.
I’ve read through the thread, but it’s not entirely clear whether I need to remove ALL my Things and re-discover them, or whether just deleting and re-discovering the devices affected by the DB change is enough? I see that @5iver has a script for removing and re-discovering all Things, but I suppose I’d like to keep to the minimum amount of potential disruption if possible!

Yes.

It worked for me!
Run the script to update the z-wave binding, delete the thing and search again in the Paper-UI Inbox.

BTW: I got always I timeout by running the script (install & upgrade zwave binding). Solution for me: Delete first (6) and install afterwards. No worries, no other things will be lost. :slight_smile:

Maybe it’s not a big issue, but why does it say [deprecated]? I didn’t enter it and when I click EDIT it doesn’t show me this text.

Device: https://www.cd-jackson.com/index.php/zwave/zwave-device-database/zwave-device-list/devicesummary/206

@TimoT

Thanks for the tip. I had the same issue (it timed out), so did the uninstall first, and it all worked fine!

@chris @sihui
I’m pleased to say that unsolicted temperature reports are now working OK on Qubino ZMNHDD & ZMNHND following latest Z-wave binding update. Thanks for your help with all this.

1 Like

Firefox issue. Use Chrome.

Tried IE, Edge, Firefox and even installed chrome - no checkbox :-/
Maybe it’s a user right? Could you remove the deprecated checkbox for me, please?
https://www.cd-jackson.com/index.php/zwave/zwave-device-database/zwave-device-list/devicesummary/206 (Endpoint 2, Temperature Sensor)

Thank you.

Maybe.

Done.

Thank you

@Morgano @Chris I’m currently also trying to use some more functions of my ZMNHAD Flush 1 relay. I would like to connect it to two wall switches. One should switch the relay and the other should switch an item in Openhab. (e.g. to control some lights)

I’ve set the configuration parameter 100 to “Sensor binary”, removed and re-added the zwave device completely. Switching the relay works and also reports the state back to Openhab. But the I2 binary sensor always stays ON. The value is also reported but never changes to OFF. I’ve tried different configurations with the association groups, but the value never changes. (Unless I change parameter 2, then it always stays OFF)

The wall switch also is a normal switch, not a push button. Any ideas what I’m doing wrong?

If the solutions in this thread did not work for you then your issue is different, even though the syptoms are similar.
Please open a new thread.

As it turns out the problem was related to my wall switch. The switches were internally wired using a bridge and this caused the binary sensor to be always on.