NTP time not send to KNX bus

Hi guys,

I found the example which should send the date and time regularly to the KNX bus, but in my case it does not :frowning:
Maybe one of you can find the issue:

This is my item:

DateTime ntpDate  "Date  [%1$td.%1$tm.%1$tY %1$tH:%1$tM]" {channel="ntp:ntp:usa:dateTime",knx="10.001:10/0/0,11.001:10/0/1"}  

This is my Thing:

Thing ntp:ntp:usa  [ hostname="nl.pool.ntp.org", refreshInterval=60, refreshNtp=30, timeZone="America/Detroit", locale="de_DE"  ]

I did on purpose set my time to a US timezone to be able to verify the sending.

In my sitemap the item:

String          USA_Datum       "USA [%s]"  { channel="ntp:ntp:usa:string" }

Is showing the correct US time and updates frequently.
I did monitor the bus for a few minutes but never received a package for group address 10/0/0

Any idea?

Thanks,
Ronny

I’m not certain how well mixing channels and 1.x style binding configs work. Theoretically, it should work just fine but I’ve been surprised in the past.

First, verify that you can sendCommand/postUpdate the time to the knx by creating a separate Item for the knx and use a Rule:

rule "Update KNX with time"
when
    Item ntpDate received update
then
    knxDate.postUpdate(ntpDate.state)
end

If this works then we know the problem is with the change coming from the channel not propagating to the update to the knx. If it doesn’t work you know the problem is with your KNX.

Hi Ronny,

I’m not sure, what went wrong in your setup. If your Item is showing the correct times, then your knx-update should work also (if your knx-connection is up and running?)

here’s my config:

things:

ntp:ntp:binder [ hostname="192.168.x.x", refreshInterval=600, refreshNtp=600 ]

items

DateTime Binder_Date "Zeit [%1$tA, %1$td.%1$tm.%1$tY %1$tH:%1$tM]"	 { channel="ntp:ntp:binder:dateTime", knx="10.001:1/0/1, 11.001:1/0/2" }

Thanks for the reply’s - I will test this out later this week.

One more question to make sure my KNX settings are right.
(All is working even the Amazon Smarthome (Alexa) integration.)

I do not have set a busaddr= for my Openhab as the knx.cfg comment says it is optional.
Do you have set a sender busaddr ?
Thanks a lot.

Mhh I have no idea why it is not working.

I implemented the rule like this:

rule "Update KNX with time"
when
    Item Datum received update
then
      logInfo(" Datum Item received Update:", Datum.toString)
      knxDate.postUpdate(Datum.state)
      logInfo(" Datum Item after sending time ...", Datum.toString) 
end

I got this knx item set up (only time for now):

DateTime knxDate  "Date  [%1$td.%1$tm.%1$tY %1$tH:%1$tM]"   { knx="10.001:10/0/0" }

and I have the ntp date item:

DateTime		Datum			"Datum [%1$tA, %1$td.%1$tm.%1$tY]"	<calendar>	{ channel="ntp:ntp:germany:dateTime" }

I see the rule gets triggert and the lines are executed, because my openhab.log shows:

2017-11-18 14:14:22.344 [INFO ] [.script. Datum Item received Update:] - Datum (Type=DateTimeItem, State=2017-11-18T14:14:22.327+0100, Label=Datum, Category=calendar)
2017-11-18 14:14:22.346 [INFO ] [t. Datum Item after sending time ...] - Datum (Type=DateTimeItem, State=2017-11-18T14:14:22.327+0100, Label=Datum, Category=calendar)

but I do not see any update on the KNX :frowning:

adding this line to the rule

  Licht_OG_Buero_Decke.sendCommand(ON)

switches on the light, so I am sure knx communication is working. All very strange.
I keep looking around …

Just FYI:
I believe the issue is solved now. Not by doing anything on the openHAB2 I switched form and remotely connected EIBD deamon to a now local running KNXD and this seem to have solved the issue.

Thanks all for the help.

1 Like

Glad it worked out now.
I think there’s some bug (or feature?) as I don’t get updated anymore on threads I participated, so I missed your posts since…

I can confirm, that date/time send to the knx bus with remotely connect/configured to eibd is not working.
All other knx actions like: switch, dimm, GA actions are working fine. The Item receives the correct NTP Date but nothing is send to the knx bus.

On the same machine, sending with groupwrite to the remote eibd works fine!
Here a sample of sending with groupwrite Date (10/0/0) and Time (10/0/1) to the remote knx:

#Time (Time: 6 20:10:28)
groupwrite ip:11.11.0.2 10/0/1 d4 a 1c
#Date 17 3 18
groupwrite ip:11.11.0.2 10/0/0 11 3 12

My item:

DateTime ntpDate  "Date & Time   [%1$td.%1$tm.%1$tY %1$tH:%1$tM]" (gSENSOR) {channel="ntp:ntp:local:dateTime",knx="11.001:10/0/1,10.001:10/0/0"}

My knx.cfg

ip=11.11.0.2
type=TUNNEL
port=3671
#All other settings are default!

Any ideas?

Switched to knxd (instead eibd) now working with remote connections.

Cheers,
GeminiServer