Odroid c4 released anyone using?

A workaround exits, that is good enough. We should try modern kernel, but it has other troubles … Not sure if its worth dealing with XU4 despite its still a nice board.

Thomas did proper scientific stress tests few days ago - you can see numbers, compared to others. This test was done with a stock 4.9.y kernel which (at this point) gives slightly better results than mainline based kernels - which I am only interested in. That’s what we are seeking explanations for at this moment.

“running properly” … if you reboot a device few times you can end up without a network. This bug was only detected on LTS 5.4.y kernel and that’s I am trying to fix … I want that basic stuff works properly on all variants.

1 Like
  • fixed networking init on both kernels
  • reset boot cycle problems are present only when using SD card (probably present only on UHS and will also be fixed soon)

If you are the one fixing the issues in the newer kernel I have to say thanks very much. The newer kernel has wireguard support built in and if I am correct, the odroid c4 has hardware acceleration built in that will save cpu power when doing VPN tasks which I am keen on looking at when I have time and the software support is done.

Regarding C4 I am responsible for a few fixes, which is still a few days of work, thanks. While the rest, majority, is a work of other people - Amlogic is hiring pros to do this work. Regarding the Wireguard … I did integration to all Armbian kernels about 1-2 years ago, but for to the rest of the world, WG came with Ubuntu 20/K5.4. Most of the single board computers has crypto hardware acceleration for many years (check numbers), only Raspberry Pi does not have it.


Nice work @igorp! I just got my C4, used the link above to download Armbian (using eMMC 32G) and OH installed in less than 5 min. :smiley:


Very nice spec. I am in similar board with Kim Anderson; too many Pis already. At this point, it is just easier to maintain the same kind of boards; less headache. But definitely for some one that hasn’t invested heavily into a platform, this is the one to try out.

I’ve used only RPI’s till now and I must admit the Odroid C4 is very nice. I’m planning to move my production server to it and will post if there are any issues or major differences. Also plan to add grafana since I have more memory and see how well it preforms.

For now the only negative (if you want to call it a negative) is the heat compared to the RPI as the Odroid seem to run a bit warmer. Guess that’s the trade off for more memory and such.

Compared to Rpi4 or Rpi3? Rpi4 seems to have higher temp readings on tests: Rpi 4 http://ix.io/271V vs. Odroid C4 http://ix.io/2kaS … but those values are anyway difficult to compare properly.

Rpi3, I chose the Odroid over the Rpi4 as upgrade.

Do you have any thoughts about adding a fan or not using the case? I normally do not leave the top cover on my Rpi3 to help with heat but the Odroid case is a bit different.

You don’t need a fan with this board.

Good to know, I will keep an eye on the temp as I start adding more load and see what it levels out to be.

Just getting started and plan to add openhabian-config tool then move everything one device at a time. Though about doing a backup/restore but I kinda want to have everything as clean as possible…lots of playing on the Rpi. :upside_down_face:

Also, any thoughts on using Docker for OH with the Odroid?

Generate a load and check temperatures. For example this way:

stress --cpu 8 --io 4 --vm 2 --vm-bytes 128M --timeout 1000s

Probably you don’t need it. In any case, don’t try to enable ZRAM since Armbian have it by default. Also skip other system fine tuning that might this tool do - that’s not needed.

Just do manual backup and restore and you are ready to roll.

Docker works on C4 perfectly well, but I am not aware how good OH works since I ran it natively. If you are using some 3rd party radio such as Z-wave or Zigbee, you might have some troubles with serial port mapping.

1 Like

Mainly want it to add frontail log, mosquitto broker, samba share and it helps with needed packages and setting permissions (lazy route I know, :smile:). What about srv mounts option in openhabian-config?

Don’t know but Samba stuff should work the same way as on Raspbian.

Just to be clear… (I could give it a shot on my Odroid C3, but it´s a bit ackward atm):

Does the Odroid suffer the same serialport issues are the Rpi´s?
I never got the sumlinks to work proberly on my Rpi´s. But I havnt tried more than one USB device on my Odroid.

1 Like

If you want to add frontail and samba mounts look for my odroid c2 script which if you open in any text editor you can copy the steps that work on Ubuntu to doing both of those things. I kept the terminal commands separate in case someone wanted to do that. Let me know what is different between Ubuntu and Armbian as some paths may be different. At least it should get you 95% of the way knowing a clear tested way all with terminal commands you can enter one at a time if u wish.

1 Like

Dang, wish I would have seen this post before installing openhabian-config tool and using it to add frontail. Guess I can see if the tool will also uninstall/remove frontail then I can help test your script.

Update, Do Not Install Openhabian if using Armbian unless your testing. I installed it and everything seemed to work just fine until I rebooted. After that the blue light never came on again. :grimacing:

Is there an advantage with using Armbian OS, over simply flashing an openhabian image to the eMMC, if planning to use only for OH? Guess I should ask, will the odriod work using an openhabian image?

No you can not use an image designed for a pi on an odroid.
Odroid has its own images for download usually Ubuntu minimal based.
Openhabian should in theory work on any Ubuntu but in practise it does not. More info on that in the thread with my script.

Also as mentioned in this thread stay away from kernel 5.x based Linux at the moment till some bugs get sorted. The odroid images are 4.x from what I have heard.

1 Like

And that device is called via its /dev/serial/by-id path, rather than the /dev/ttyACM0 path