Odroid c4 released anyone using?

These are the options:
install-openhab-arm64-options.txt (2.3 KB)

I’ll trying disabling everything and running it again.

Would it be useful to run each command from the script manually and reboot after each command to see if I can identify which command breaks the machine?


Stripping the options down to these still gives the same result:

#sudo apt-key adv --keyserver hkp://keyserver.ubuntu.com:80 --recv-keys AB19BAC9

I’m using the ubuntu-20.04-server-odroidc4-20200716.img image for a minimal sized install. It has a user ‘odroid’ instead of ‘root’ - would that make any difference to the script?

I ran each step of the script manually and then rebooted after each step. The C4 rebooted fine after each step until after this command was run:
sudo apt-get install -y mc nano build-essential udev:armhf software-properties-common

This is the log for just this command:
install2.log (37.4 KB)
Unfortunately it’s 600 lines of stuff that doesn’t mean much to me.

Would it be better to start with the Armbian image, follow the Armbian install guide and then manually pick bits from Matt’s script?

Thanks for any guidance.

I wouldn’t bother with Zulu.

I just install the default 64 bit Java.

Why don’t you try using openhabian? last time I tried it worked after I first manually installed curl.
Yes you can also try Armbian and then run the scripts lines to do what you wish, that is why I laid out the commands in an easy to follow order.

As far as the script goes you can narrow it down further by only installing one at a time from that line you already found to be problematic. Start with either of these two udev:armhf or software-properties-common.

After running “sudo apt-get install -y mc nano build-essential udev:armhf” the reboot problem persisted. I’ll move on from the script now - I don’t think my tests are adding any value and I’m sure it’s about as interesting for you as filling tax returns.

Running openhabian worked and I have a running OH system on my C4 now. :slight_smile:

Here’s a summary of the steps that worked for me (having never used an ODROID before):

Thanks again for your help.


Great news and thanks for posting what worked, just don’t forget to change the password so “odroid/odroid” no longer works. Also be great to hear how fast and smooth it runs compared to what you were using before.

1 Like


With the help of Michal at DietPi.com, I’ve got DietPi running on the C4, with openHAB2, Node-RED and optionally a full screen Chromium browser on the HDMI output, with touch screen support.

To say that its a fast machine is an understatement.

As an example, from downloading openHAB2, through selecting the package type to actually getting to an operatonal UI, took less than 10 minutes !!!

(It took my desktop machine as long to compress the 15GB IMG file into a 7z)

This DropBox folder contains the C2 and C4 images - (fully installed openHAB2, Node-RED, VelServ & Samba) - root password is dietpi
Samba username is openhab, password is habopen


Some may say, that a C4 is way overkill to run a smarthome system like openHAB2. But I disagree, (as usual :slight_smile: ). I my opinion it makes sense as long as the device beeing used has a rather a low price, and beeing costbenefit running 24/7. The more power and memory will do alot of help in many situations, like when having to restore everything from a backup. When I tested setting up openHAB2 on my Rpi 4 or my Odroid C2 using a USB drive or eMMC for Odroid, I can get the system back online within just ½ hour. Dealing with app/services which takes quite alot of recources like Grafana for charts, IP/cameras etc, the more power sure will come in hand.

Your tests sure are highly appreaciated, Stuart! Keep´em coming!

1 Like

@MDAR I got an invalid archive image when trying to flash this using etcher?

EDIT: Think I found my mistake. I just clicked download and got both, :roll_eyes: only needed c4.

1 Like


Let me know if you run into any other issues.

1 Like

Flashing now, that’s a big file. :grinning: Is there anything needed to get the webbrowser up and running?


Do you mean the Chromium kiosk browser?

If the answer is yes…

Go to a command prompt (directly or via SSH)



Then choose option 9, followed by option 11 (I think that’s the one, it’s labelled “Chromium”), click okay to everything…

Then reboot.

There is a 3 minute delay in the startup of Chromium, just so that openHAB2 can get up and running

If you need to change the screen resolution (to get full screen) then edit the Chromium settings in - - /boot/dietpi.txt

The delay / sleep time is also in the same section of that text file

1 Like

Do you plan to use frontail logging? I have failed to get the service file to work. In case you mange, I would highly appreciate a notice, thank you :slight_smile:

I just moved the frontail installing part of my script into its own, so feel free to give it a try. Backup first, backup first do I need to stress you need to backup before trialing a random untested script?

Run the script using these commands and use nano to edit your hostname with the hostname or your IP address.

wget http://pcmus.com/openhab/scripts/install-frontail.sh
nano install-frontail.sh
sudo bash ./install-frontail.sh

Yeah I did not realize just how much a big jump the RAM performance is compared to the C2 and even the PI4. Ram speed makes a big difference in how responsive a machine is and even if you don’t need the extra CPU, the rams performance will make you happy you upgraded.

Thanks for sharing the images. Looks like I will be going with a N2+ not the C4 here unless something better comes out before the N2+ is back in stock.

I say they lack imagination on what to use the extra power for :slight_smile: It is also not just about CPU, the RAM is 60% faster in the C4 vs the C2 and this you will see in a faster more responsive system even if you barely use the CPU. If your upgrading I would love to hear what you notice changes.

1 Like


It’s it working for you?

Thanks, I´ll give it a try later today, cause I´ve run into a dead-end with all the tries I have done untill now.

Well… Sometimes I think the different opinions is due to different use. I dont consider my self unique, but when I hear from others, their systems isnt quiet as busy as mine.
I have 18 bindings running on my main system (Rpi3B+), beside that I have mqtt broker and Influxdb. It doesnt really sound as much, but I have alot of times, pollings etc going on. A single screen from frontail log will be filled within just a coupple of seconds, only events and openhab standard logging.
Due to my issues I tend to run into all the time, I have come to the fact, that my Rpi3B+ is running on overtime all the time, whcih may be part of my issues. I would also like to have the ipcamera binding running on the same system, and not splitt into two systems like I run it today.

I have tried to “upgrade” to Rpi4 (4Gb Ram). But I have seen too many issues with a fresh openhabian image, that it doesnt make sense to move everything to that system. My latest idea is to use my Odroid C2 (untill I get my C4), and get my main system “transfered” to that, today actually. Unfortunalty it means I´ll have to struggle with some manual installations. But I have to try, since I can no longer depend on the Rpi3B+ will be able to do its job, and the situation with the openhabian image for Rpi4 is not a solution atm… So now I have dietPi running on my Odroid C2 - ready to take over, (which infact is why I asked for the frontail installation, cause I cant get it to work, and I desperate need it. Frontail is my most used utillity, running all the time I´m working on the system. Sometimes I just sit there look at the frontail log, to see if everything is running as expected).

So now, it´s Odroid C2. Later it´s Odroid C4… I simply have to give up the Rpi.

Just tried your script… I´m not sure if it really was a good idea though, since I already had nodejs and nmp installed… I have no idea how linux will handle such an installation… Anyway, there is the outcome, (sorry for having changing the system language to danish).

the exact distribution terms for each program are described in the
individual files in /usr/share/doc/*/copyright.

Debian GNU/Linux comes with ABSOLUTELY NO WARRANTY, to the extent
permitted by applicable law.
 DietPi v6.31.2 : 13:56 - søn 23-08-2020
 - Device model : Odroid C2 (aarch64)
 - CPU temp : 48'C : 118'F (Optimal temperature)
 - LAN IP : (eth0)
 - MOTD : Help testing the new RPi3/RPi4 64-bit image:

 DietPi Team     : MichaIng (lead), Daniel Knight (founder), Joulinar (support)
 Image           : DietPi Core Team (pre-image: Meveric)
 Web             : https://dietpi.com | https://twitter.com/dietpi_
 Patreon Legends : Bryce
 Donate          : https://dietpi.com/#donate
 DietPi Hosting  : Powered by https://myvirtualserver.com

 dietpi-launcher : All the DietPi programs in one place.
 dietpi-config   : Feature rich configuration tool for your device.
 dietpi-software : Select optimized software for installation.
 htop            : Resource monitor.
 cpu             : Shows CPU information and stats.

root@openHAB2-C2:~# wget http://pcmus.com/openhab/scripts/install-frontail.sh
--2020-08-23 13:57:02--  http://pcmus.com/openhab/scripts/install-frontail.sh
Løser pcmus.com (pcmus.com)...
Tilslutter pcmus.com (pcmus.com)||:80... forbundet.
HTTP forespørgsel sendt, afventer svar... 200 OK
Længde: 87845 (86K) [application/x-sh]
Gemmer til: 'install-frontail.sh'

install-frontail.sh 100%[===================>]  85,79K  60,6KB/s    in 1,4s

2020-08-23 13:57:05 (60,6 KB/s) - 'install-frontail.sh' gemt [87845/87845]

root@openHAB2-C2:~# nano install-frontail.sh
root@openHAB2-C2:~# sudo bash ./install-frontail.sh
Now installing Frontail
Havde:1 http://fuzon.co.uk/meveric all InRelease
Havde:2 http://fuzon.co.uk/meveric stretch InRelease
Ignorerer:3 https://deb.debian.org/debian stretch InRelease
Henter:4 https://deb.debian.org/debian stretch-updates InRelease [93,6 kB]
Ignorerer:5 https://dl.bintray.com/openhab/apt-repo2 stable InRelease
Henter:6 https://dl.bintray.com/openhab/apt-repo2 stable Release [6.051 B]
Havde:6 https://dl.bintray.com/openhab/apt-repo2 stable Release
Henter:7 https://deb.debian.org/debian-security stretch/updates InRelease [53,0 kB]
Henter:8 https://deb.debian.org/debian stretch-backports InRelease [91,8 kB]
Havde:9 https://deb.debian.org/debian stretch Release
Henter:11 https://deb.debian.org/debian-security stretch/updates/main arm64 Packages [535 kB]
Hentede 773 kB på 2s (296 kB/s)
Indlæser pakkelisterne... Færdig
Indlæser pakkelisterne... Færdig
Opbygger afhængighedstræ
Læser tilstandsoplysninger... Færdig
curl er allerede den nyeste version (7.52.1-5+deb9u11).
0 opgraderes, 0 nyinstalleres, 0 afinstalleres og 6 opgraderes ikke.


                              DEPRECATION WARNING

  Node.js 8.x LTS Carbon is no longer actively supported!

  You will not receive security or critical stability updates for this version.

  You should migrate to a supported version of Node.js as soon as possible.
  Use the installation script that corresponds to the version of Node.js you
  wish to install. e.g.

   * https://deb.nodesource.com/setup_10.x — Node.js 10 LTS "Dubnium"
   * https://deb.nodesource.com/setup_12.x — Node.js 12 LTS "Erbium" (recommended)
   * https://deb.nodesource.com/setup_14.x — Node.js 14 LTS "Fermium"

  Please see https://github.com/nodejs/Release for details about which
  version may be appropriate for you.

  The NodeSource Node.js distributions repository contains
  information both about supported versions of Node.js and supported Linux
  distributions. To learn more about usage, see the repository:


Continuing in 20 seconds ...

## Installing the NodeSource Node.js 8.x LTS Carbon repo...

## Populating apt-get cache...

+ apt-get update
Havde:1 http://fuzon.co.uk/meveric all InRelease
Havde:2 http://fuzon.co.uk/meveric stretch InRelease
Ignorerer:3 https://deb.debian.org/debian stretch InRelease
Havde:4 https://deb.debian.org/debian stretch-updates InRelease
Havde:5 https://deb.debian.org/debian-security stretch/updates InRelease
Havde:6 https://deb.debian.org/debian stretch-backports InRelease
Havde:7 https://deb.debian.org/debian stretch Release
Ignorerer:8 https://dl.bintray.com/openhab/apt-repo2 stable InRelease
Henter:9 https://dl.bintray.com/openhab/apt-repo2 stable Release [6.051 B]
Havde:9 https://dl.bintray.com/openhab/apt-repo2 stable Release
Indlæser pakkelisterne... Færdig

## Confirming "stretch" is supported...

+ curl -sLf -o /dev/null 'https://deb.nodesource.com/node_8.x/dists/stretch/Release'

## Adding the NodeSource signing key to your keyring...

+ curl -s https://deb.nodesource.com/gpgkey/nodesource.gpg.key | apt-key add -

## Creating apt sources list file for the NodeSource Node.js 8.x LTS Carbon repo...

+ echo 'deb https://deb.nodesource.com/node_8.x stretch main' > /etc/apt/sources.list.d/nodesource.list
+ echo 'deb-src https://deb.nodesource.com/node_8.x stretch main' >> /etc/apt/sources.list.d/nodesource.list

## Running `apt-get update` for you...

+ apt-get update
Havde:1 http://fuzon.co.uk/meveric all InRelease
Havde:2 http://fuzon.co.uk/meveric stretch InRelease
Henter:3 https://deb.nodesource.com/node_8.x stretch InRelease [4.620 B]
Ignorerer:4 https://deb.debian.org/debian stretch InRelease
Havde:5 https://deb.debian.org/debian stretch-updates InRelease
Havde:6 https://deb.debian.org/debian-security stretch/updates InRelease
Havde:7 https://deb.debian.org/debian stretch-backports InRelease
Havde:8 https://deb.debian.org/debian stretch Release
Ignorerer:9 https://dl.bintray.com/openhab/apt-repo2 stable InRelease
Henter:10 https://dl.bintray.com/openhab/apt-repo2 stable Release [6.051 B]
Havde:10 https://dl.bintray.com/openhab/apt-repo2 stable Release
Henter:11 https://deb.nodesource.com/node_8.x stretch/main Sources [762 B]
Henter:12 https://deb.nodesource.com/node_8.x stretch/main arm64 Packages [1.007 B]
Hentede 6.389 B på 2s (2.324 B/s)
Indlæser pakkelisterne... Færdig

## Run `sudo apt-get install -y nodejs` to install Node.js 8.x LTS Carbon and npm
## You may also need development tools to build native addons:
     sudo apt-get install gcc g++ make
## To install the Yarn package manager, run:
     curl -sL https://dl.yarnpkg.com/debian/pubkey.gpg | sudo apt-key add -
     echo "deb https://dl.yarnpkg.com/debian/ stable main" | sudo tee /etc/apt/sources.list.d/yarn.list
     sudo apt-get update && sudo apt-get install yarn

Indlæser pakkelisterne... Færdig
Opbygger afhængighedstræ
Læser tilstandsoplysninger... Færdig
Følgende NYE pakker vil blive installeret:
0 opgraderes, 1 nyinstalleres, 0 afinstalleres og 6 opgraderes ikke.
13,3 MB skal hentes fra arkiverne.
Efter denne handling, vil 70,9 MB yderligere diskplads være brugt.
Henter:1 https://deb.nodesource.com/node_8.x stretch/main arm64 nodejs arm64 8.17.0-1nodesource1 [13,3 MB]
Hentede 13,3 MB på 1s (10,8 MB/s)
Vælger tidligere fravalgt pakke nodejs.
(Læser database ... 59911 filer og kataloger installeret i øjeblikket.)
Gør klar til at udpakke .../nodejs_8.17.0-1nodesource1_arm64.deb ...
Udpakker nodejs (8.17.0-1nodesource1) ...
Sætter nodejs (8.17.0-1nodesource1) op ...
Behandler udløsere for man-db ( ...
npm WARN deprecated request@2.88.2: request has been deprecated, see https://github.com/request/request/issues/3142
npm WARN deprecated har-validator@5.1.5: this library is no longer supported
/usr/local/bin/frontail -> /usr/local/lib/node_modules/frontail/bin/frontail
+ frontail@4.9.1
updated 1 package in 11.231s

   │                                                                │
   │      New minor version of npm available! 6.13.4 → 6.14.8       │
   │   Changelog: https://github.com/npm/cli/releases/tag/v6.14.8   │
   │               Run npm install -g npm to update!                │
   │                                                                │

./install-frontail.sh: linje 12: /usr/lib/node_modules/frontail/preset/openhab.json: Ingen sådan fil eller filkatalog
./install-frontail.sh: linje 36: /usr/lib/node_modules/frontail/web/assets/styles/openhab.css: Ingen sådan fil eller filkatalog
Congrats Frontail should now be installed if there were no errors.
root@openHAB2-C2:~# systemctl status frontail
● frontail.service - Frontail openHAB instance, reachable at http://openHAB2-C2:9001
   Loaded: loaded (/lib/systemd/system/frontail.service; enabled; vendor preset: enabled)
   Active: failed (Result: exit-code) since Sun 2020-08-23 14:00:28 CEST; 56s ago
     Docs: https://github.com/mthenw/frontail
  Process: 10687 ExecStart=/usr/lib/node_modules/frontail/bin/frontail --ui-highlight --ui-highlight-preset /usr/lib/node_modules/frontail/preset/openhab.json -t openhab -l 2000 -n 200 /var/log/openhab2/open
hab.log /var/log/openhab2/events.log (code=exited, status=203/EXEC)
 Main PID: 10687 (code=exited, status=203/EXEC)

aug 23 14:00:28 openHAB2-C2 systemd[1]: frontail.service: Unit entered failed state.
aug 23 14:00:28 openHAB2-C2 systemd[1]: frontail.service: Failed with result 'exit-code'.
aug 23 14:00:28 openHAB2-C2 systemd[1]: frontail.service: Service hold-off time over, scheduling restart.
aug 23 14:00:28 openHAB2-C2 systemd[1]: Stopped Frontail openHAB instance, reachable at http://openHAB2-C2:9001.
aug 23 14:00:28 openHAB2-C2 systemd[1]: frontail.service: Start request repeated too quickly.
aug 23 14:00:28 openHAB2-C2 systemd[1]: Failed to start Frontail openHAB instance, reachable at http://openHAB2-C2:9001.
aug 23 14:00:28 openHAB2-C2 systemd[1]: frontail.service: Unit entered failed state.
aug 23 14:00:28 openHAB2-C2 systemd[1]: frontail.service: Failed with result 'exit-code'.
root@openHAB2-C2:~# ^C

Ummmm, this may impact Node-RED that was happily running on that machine / image.

Is doesn’t look like you have got any further, based on what that Status page says.

How do you feel about having one instance of Frontail for openhab.log and another for events.log?

I’m wondering if this is an ARM64 issue?

Can you reach out to the author of Frontail?

Thats why I decided to re-flash my eMMC :smiley:

Correct, I just got another error code. Before this, I got the error status code 210/CHROOT.

This is hardly an arm64 issue. Frontail runs on my Rpi4, however it was installed through the openhabian image.

Maybe. Question is what exactly to ask for. I have very limited knowlededge on this linux stuff. And from what I can tell, there is something odd going on with the installation, depending on which liniux using. Running Debian(DietPi) it seems like installing Frontail ends up in different folders than running ubuntu or even the Rpi openhabian image… Having this problem, I would have no idea how to handle it. I think I have tried almost any kind of combination.
I have a slight feeling it all boils down to user permissions and “paths”. (that seem to my over-all difficulties with linux).
Remember what I said yesterday - Trying to understand Linux is like having a chinese telling me something. Now, I need to ask questions back, in chinese :smiley: