Official Google Assistant Integration for openHAB

About my issue with the Google Assistant. I just got a confirmation from Google that other google Home users have the same issue. It may well be a software problem on the google cloud side.

Well, this is just my experience and deductions, but…

I’ve found that Google ‘generalizes’ any terms found in the names of your items.
For example, your two items both have the word kitchen in them. And both are tagged as ‘lights’ via the “Lighting” tag and the word light.
So if you tell GH to turn on the kitchen light, it will search through the ‘lights’ (which most probably includes the one called ‘kitchen light’) for any with the word kitchen in them.
I think that perhaps Google has a list of ‘lights’, which includes any switches with the word light in them, or any items tagged as “Lighting”. So both your items are included in this list, and the kitchen keyword is seen in both items’ names so it will turn them both on and off.

In future we’ll probably get more types of tags to assign to items to allow for discerning between a Light switch, a volume or other types of devices, that will prevent this type of issue.

You can assign ‘nicknames’ to synced items in Google Home. You can perhaps try to change the nickname of the volume control to something that doesn’t include the word kitchen and see if prevents google from turning it on when kitchen is mentioned. I’m not sure if Google checks both the nickname and its label, I’m not at home right now or I’d test it out for you.

I am having similar experiences, check out my posting and response at:!topic/websearch/NHI1q_8joUo

Here’s what they suggested:

Thanks for writing back to me. In this case, I’d suggest you report this directly to our Google Assistant team from the app. To send feedback, open Google Assistant on your phone, at the top right corner tap on explore > then, tap on more (3 vertical dots) option > Send Feedback.

Maybe if more people send feedback, they might fix it.

How many lights/switches are people using with Google home/mini? I have 29 lights and it does not “sync my devices” like it used to when I only had a smaller number of things to sync.

If I remove and re-add openhab it works perfectly and finds and adds all the devices, then continues to also work fine. No syntax issues otherwise it surely would not do this.

What I think is happening is to sync the number of devices I have it timesout and complains it does not know how to help with that, but if watching in the GA app, you see the action is still working after it makes this statement. The dots keep scrolling like a progress bar.

Anyone using more than 30 devices and how does it work for you? Maybe the long round trip ping is causing it to take longer than expected.

Until they’ll add more items type and/or tags, I solved my problem by moving Kitchen_TV_Volume to another “room” in GH app…
I had Kitchen_Light and Kitchen_TV_Volume - and similar items in other rooms - added to the same “room”, Kitchen.
So I moved all TV volume items to a “room” called None.
Problem solved!

I have 39 OH devices and have no problem syncing my devices.


First of all, thanks for it, Its awesome!!!
I successfully setup it and works as expected, but I have a question.
Is it possible to install a private myopenhab server, than this connect to Google assistant, or I have to use the!


I’m having exactly the same problem. I had 2 Ikea Tradfri bulbs set up about a month ago, everything was great. I got a third recently. I didn’t know about asking google to “sync my devices”, I went with what I thought was the only way which was unlink and re-link. So, I know the items file was right (something I’ve seen other comments on), because it was right for the two existing bulbs. Unlink went fine, the two lights went away, but relink does nothing. I click openHAB, it takes me through to log in to myopenhab, I click Allow for OAuth2, and it says it worked and redirects back into the Google Assistant app (I’ve tried on both iOS and Android devices). In myopenhab, I can see the app authentication show up, but in Google Home/Assistant, no bulbs come back in. And if I go back to Manage Accounts, openHAB doesn’t show as “linked”.

Here’s my items file that was working (without the new bulb in it, just the way it was before unlinking, the file that was “working fine”):

    Dimmer BackHallLight1_Brightness "Back Hall Light 1" <slider> (BackHallLights_Brightness) ["Lighting"]
    Dimmer BackHallLight2_Brightness "Back Hall Light 2" <slider> (BackHallLights_Brightness) ["Lighting"]
    Dimmer BackHallLight1_ColourTemperature "Back Hall Light 1 Colour Temperature" <colorpicker> (BackHallLights_ColourTemperature)
    Dimmer BackHallLight2_ColourTemperature "Back Hall Light 2 Colour Temperature" <colorpicker> (BackHallLights_ColourTemperature)

    Group BackHallLights_Brightness "Back Hall Lights" <slider> ["Lighting"]
    Group BackHallLights_ColourTemperature "Back Hall Lights Colour Temperature" <colorpicker>

Anyone have any ideas what could be going wrong?

@MARZIMA Awesome work! Any ETA on the Thermostat and CurrentTemperature - and possibly other - tags? I noticed a ‘scene’ icon for Philips Hue lights in Google Assistant. Would be awesome to have a similar tag for openHAB as well!


Yep. You can follow this issue.

Fantastic job with everything, and I’m really happy the work is ongoing to improve things.

My only issue is that the bindings for Google Home, Alexa, and Siri all follow the same protocol with the tagging, however they each interpret things differently, sometimes incorrectly. This makes it so I would label things one way for Google Home but another for Alexa. It would be nice if these were separate, as the way things are now it is difficult to use a combo of the technologies together without making some unnecessary compromises.

Anyone else have the issue of using more than one of these voice services?

Thank you very much, lights are working excellent even with italian commands.
Is there a way / workaround to use rollerupshutter?

Anyone able to help me?

I try to link my accounts together via iOS assitant app…but it will not work…


A strategy I used was to untag (or remark out) all HomeKit items. Make sure you have no temperature control tags - I think only Lighting and Switchable (maybe color, but I’d try that after).

Once you get the initial link up, you can slowly re-tag or un-remark the items and just say “hey Google sync devices”. Keep an eye on your device if they suddenly all disappear whatever you just untagged is causing the issue (usually an unsupported/misspelled tag).

Best of Luck

Definitely make sure you ONLY have Lighting or Switchable tags (for now, until the action gets upgraded and approved by Google)…Follow my how-to topic/video for specific connection info:

1 Like

Gents, i created all my things (items) in paper ui.
How do i edit the tags?
Tag editing is greyed out in habmin.
Editing the jsondb is not trivial either.
I want to get this working with my google home :slight_smile:

There is a new concept of thing metadata just for this purpose being worked on. Hopefully this helps.

As far as I know, current way is to use karaf console … type smarthome:items addtag [Lighting]

1 Like

Cool. Still working out the specifics, I can see where some seemingly harmless choices now would make compatibility issues later. I’m sure every choice to be made is a simplicity vs. flexibility issue. Seems like it would have great potential if done right.

My fix for the very annoying “Couldn’t update the setting. Check your connection” bug:

I spent about 6 hours over 2 weeks trying to see why I couldn’t connect anymore after one successful connection. It turns out I deleted (commented out) an Item that had previously been tagged without deleting it from Openhab properly.

I figured it out by:

ssh -p 8101 openhab@localhost
openhab> items list|grep -i tag                                                                                  
lampDeck1 (Type=DimmerItem, State=0, Label=null, Category=null, Tags=[Lighting])
lampDeck2 (Type=DimmerItem, State=0, Label=null, Category=null, Tags=[Lighting])
lamp2FR_T (Type=DimmerItem, State=NULL, Label=FR Lamp Temperature, Category=hue, Tags=[Lighting], Groups=[ltgFR])

As you can see, lampDeck1 and LampDeck2 (which used to be Hue lights I replaced with a single Zwave switch) were still listed even though I had commented them out in the .items file. I’m guessing the State=0 or Category=null was throwing it off?

I uncommented it (it had not Tag anymore in the file) and was able to connect finally.

Success after long hours. I have to remember to check the console first when debugging, there’s a lot of info there that’s otherwise inaccessible.