[OH 2.4.0 M7] Testing Results

openhab2
testing
milestone
Tags: #<Tag:0x00007f016d01caa0> #<Tag:0x00007f016d021578> #<Tag:0x00007f016d027018>

(Christian) #23

Thanks Stefan, but I’ve already done that though :confused:


(Stefan) #24

yeah, that’s what i experience myself after upgrading to m7… Sorry, last time that solved the problem… i’m looking into it!

Edit: I can confirm having the following error messages every minute and can’t get rid of them so far (i set org.eclipse.jetty to ERROR so i don’t deal with these messages at the moment, but there are some more):

2018-12-02 11:56:00.708 [ERROR] [e.internal.WriterInterceptorExecutor] - MessageBodyWriter not found for media type=text/event-stream, type=class org.glassfish.jersey.media.sse.OutboundEvent, genericType=class org.glassfish.jersey.media.sse.OutboundEvent.
2018-12-02 11:56:37.250 [ERROR] [core.karaf.internal.FeatureInstaller] - Failed installing 'openhab-binding-weather, openhab-binding-http': Error restarting bundles:
        Exception in org.eclipse.smarthome.io.rest.sse.internal.SseActivator.start() of bundle org.eclipse.smarthome.io.rest.sse.

Edit2:
The first idea was the correct one, i tried cleaning the cache again, this time using the openhab-cli clean-cache method and this time that worked out and both of the entries are gone!

@sjef86: You should try that as well (if you installed openhab via apt or yum), but i can’t tell you what the difference to removing the content of tmp/cache is.


(mattnl ) #25

Anyone having troubles accessing the REST API through a web browser with the M7 build? I just get the following message:

fetching resource list: http://xx.xxx.xxx.xxx:8081/rest/swagger.json; Please wait.

but nothing happens.

I just did a clean install of the M7 build, same effect.

Regards,
Matt


[OH2.4.0.S1447] Browser based REST API stalled
(Angelos) #26

Yeah, I can reproduce this one also in both M7 & S1447. It works fine on M6.

URL: http://OH2_IP:8080/doc/index.html
(don’t worry about the URL in the image below, I have changed my default 8080 to 8081)

Chrome dev tools show:

swagger-ui.min.js:3 Uncaught TypeError: Cannot read property '$ref' of undefined
    at t.exports.a.resolveTo (swagger-ui.min.js:3)
    at t.exports.a.resolveTo (swagger-ui.min.js:3)
    at t.exports.a.resolve (swagger-ui.min.js:2)
    at response (swagger-ui.min.js:2)
    at i (swagger-ui.min.js:2)
    at e.on.response (swagger-ui.min.js:2)
    at swagger-ui.min.js:2
    at f.callback (swagger-ui.min.js:13)
    at f.<anonymous> (swagger-ui.min.js:13)
    at f.r.emit (swagger-ui.min.js:13)

This one definetly deserves a github issue @ https://github.com/openhab/openhab2-addons/issues (I think! that it belongs there :stuck_out_tongue:)

Can you open it up @mstehle ?


(mattnl ) #27

Thank you @Dim.

I have created a github issue and included your info from the chrome dev tools as well: https://github.com/openhab/openhab2-addons/issues/4302


(Scott Rushworth) #28

Same on S1445.

Also, M7 users that use the Hue Emulation binding will likely have some trouble. Here is a discussion post and an issue. Short version… groups can no longer be used, and people have reported issues discovering Items tagged Switchable.


(Kim Andersen) #29

I cant even update to M7…
However I updated using openhabian-config and I now have the build #1447. But thats not the M7, right?

When I try to use apt-get in terminal, I get this error:

[20:34:07] openhabian@openHABianPi:~$ apt-get update && sudo apt-get install openhab2=2.4.0~M7-1
Reading package lists... Done
W: chmod 0700 of directory /var/lib/apt/lists/partial failed - SetupAPTPartialDirectory (1: Operation not permitted)
E: Could not open lock file /var/lib/apt/lists/lock - open (13: Permission denied)
E: Unable to lock directory /var/lib/apt/lists/
W: Problem unlinking the file /var/cache/apt/pkgcache.bin - RemoveCaches (13: Permission denied)
W: Problem unlinking the file /var/cache/apt/srcpkgcache.bin - RemoveCaches (13: Permission denied)
[20:34:14] openhabian@openHABianPi:~$


(Cyril Jaquier) #30

Seems like there is a problem with the Debian repo. openhab2-addons is still at M6 in https://dl.bintray.com/openhab/apt-repo2/dists/testing/main/binary-arm64/:Packages and actually I noticed right now that I’m running openhab2-addons M5 but openhab2 M6!!?? Seems like openhab2-addons is off by one in the repo metadata.

All the M7 packages are available though: https://dl.bintray.com/openhab/apt-repo2/pool/main/2.4.0~M7/


(Cyril Jaquier) #31

You need to run apt-get update as root also:

$ sudo apt-get update

(Kim Andersen) #32

I did… Doesn´t make any differences.

[20:52:51] openhabian@openHABianPi:~$ sudo apt-get update
Ign:1 http://repos.azulsystems.com/debian stable InRelease
Hit:2 http://raspbian.raspberrypi.org/raspbian stretch InRelease
Hit:3 http://archive.raspberrypi.org/debian stretch InRelease
Hit:4 http://repos.azulsystems.com/debian stable Release
Hit:5 https://deb.nodesource.com/node_8.x stretch InRelease
Ign:6 https://dl.bintray.com/openhab/apt-repo2 testing InRelease
Hit:7 https://dl.bintray.com/openhab/apt-repo2 testing Release
Reading package lists... Done
[20:53:09] openhabian@openHABianPi:~$ apt-get update && sudo apt-get install openhab2=2.4.0~M7-1
Reading package lists... Done
W: chmod 0700 of directory /var/lib/apt/lists/partial failed - SetupAPTPartialDirectory (1: Operation not permitted)
E: Could not open lock file /var/lib/apt/lists/lock - open (13: Permission denied)
E: Unable to lock directory /var/lib/apt/lists/
W: Problem unlinking the file /var/cache/apt/pkgcache.bin - RemoveCaches (13: Permission denied)
W: Problem unlinking the file /var/cache/apt/srcpkgcache.bin - RemoveCaches (13: Permission denied)
[20:53:24] openhabian@openHABianPi:~$


[OH 2.4.0 M6] Testing Results
(Angelos) #33

forgot the first sudo

either 2 separate commands

sudo apt-get update
sudo apt-get install openhab2=2.4.0~M7-1

or all in 1 line (&& is for lazy people like me :slight_smile: )

sudo apt-get update && sudo apt-get install openhab2=2.4.0~M7-1

or even for more lazy:

sudo su

switch perma to root… be careful… with great power comes great responsibility :stuck_out_tongue:


(Cyril Jaquier) #34

Ok, let me try again. Just type this now:

$ sudo apt-get update && sudo apt-get install openhab2=2.4.0~M7-1

or just remove the apt-get update since you did it already:

$ sudo apt-get install openhab2=2.4.0~M7-1

(Angelos) #35

correct
somehow the “normal” addons package was not build against M7
The legacy is there though :slight_smile:


(Kim Andersen) #36

Ahh ofcouse… Forgot sudo…
Seems like it´s doing somehting now :slight_smile:


(Angelos) #37

by the way: if you were already at M6 (and using the testing repo), you could also use: sudo apt-get update && sudo apt-get upgrade (does the same thing)


(Kim Andersen) #38

Okay nice to know… I´m on my testing Rpi… My main Rpi is still on 2.3 stable… I´m thinking of trying M7 on it, but I still have a few doubts…


(Cyril Jaquier) #39

It rather seems that the metadata are not updated correctly. Now I’m just getting the update to M6 for openhab2-addons and realizes that I have openhab2-addons M5 installed. However, if I look at PaperUI it shows me that I’m using M6 for all my bindings!!?? I guess this is because openHAB2 can download bindings automatically from the web. So my question is: do I need to install the openhab2-addons package at all???


(Angelos) #40

not really.
I never do. I use the online repo to pull whatever binding I need (it’s automatically downloaded for you when you install the addon from PaperUI or place it in addons.cfg)

Just make sure that you have: PaperUI->Configuration->System->Add-on Management->Access Remote Repository enabled (it’s on by default)


(Angelos) #41

Note to @Benjy : can you please take a look when you can at the openhab2-addons_2.4.0~M7-1_all.deb package? it seems that we are missing it from the repo metadata. I only checked amd64 & arm64

root@rpi3:~# apt-cache madison openhab2-addons
openhab2-addons | 2.4.0~M6-1 | https://dl.bintray.com/openhab/apt-repo2/ testing/main armhf Packages
openhab2-addons | 2.4.0~M5-1 | https://dl.bintray.com/openhab/apt-repo2/ testing/main armhf Packages
openhab2-addons | 2.4.0~M4-1 | https://dl.bintray.com/openhab/apt-repo2/ testing/main armhf Packages
openhab2-addons | 2.4.0~M3-1 | https://dl.bintray.com/openhab/apt-repo2/ testing/main armhf Packages
openhab2-addons | 2.4.0~M2-1 | https://dl.bintray.com/openhab/apt-repo2/ testing/main armhf Packages
openhab2-addons | 2.3.0.RC1-1 | https://dl.bintray.com/openhab/apt-repo2/ testing/main armhf Packages
openhab2-addons |    2.3.0-1 | https://dl.bintray.com/openhab/apt-repo2/ testing/main armhf Packages
openhab2-addons | 2.3.0~RC2-1 | https://dl.bintray.com/openhab/apt-repo2/ testing/main armhf Packages
openhab2-addons | 2.3.0~RC1-1 | https://dl.bintray.com/openhab/apt-repo2/ testing/main armhf Packages
openhab2-addons |    2.2.0-1 | https://dl.bintray.com/openhab/apt-repo2/ testing/main armhf Packages
openhab2-addons |    2.1.0-2 | https://dl.bintray.com/openhab/apt-repo2/ testing/main armhf Packages
openhab2-addons | 2.0.0~RC1-1 | https://dl.bintray.com/openhab/apt-repo2/ testing/main armhf Packages

(Cyril Jaquier) #42

Nice thank you. I’ll remove it then. Remote Access is enabled, that’s actually why I’m running M6 addons despite the fact that I have openhab2-addons M5 installed (I see both versions in PaperUI, now I understand why). Thank you again.