OH 3.0.0M1 Installation of add-ons failed

I installed OPENHAB 3.0.0M1 with obenhabian 1.6 by using openhabian-config menu on Raspberyy Pi 4.

Now I cant’t install any add-ons. I get the error “Installation of xyz failed”

Has anybody ideas to solve the problem…

some examples:

2020-11-01 19:14:24.952 [home.event.StartlevelEvent] - Startlevel ‘20’ reached.

2020-11-01 19:14:52.761 [smarthome.event.AddonEvent] - binding-avmfritz: Operation failed.

2020-11-01 19:15:24.227 [smarthome.event.AddonEvent] - misc-openhabcloud: Operation failed.

2020-11-01 19:14:52.751 [ERROR] [t.core.internal.addons.AddonResource] - Exception while installing add-on: null

2020-11-01 19:15:24.223 [ERROR] [t.core.internal.addons.AddonResource] - Exception while installing add-on: null

Thank you


hi, i have exactly the same problem also on raspberry 4, openhabian 1.6 and OPENHAB 3.0.0M2.
I can’t install any addons.
I get the same errors, did you then solve it?

Same problem here. Raspbi 3B. Had to reinstall OH2.5 due tot he fact that i cant install Bindings…

Same setup, same issue.

Please verify you have installed Java11.

When you do what exactly ?

I had this with a fresh install on OH3.0.0.M2 running within docker. The error disappeared after I set the network interface, cleared cache/tmp and restarted. Not sure if that was what solved it.

Not sure it has to do with anything. I face the same issue.
Did a manual
sudo apt purge openhab2
sudo apt update
sudo apt purge openhab
sudo apt install openhab

After that it works installing addons again.

I had the same issue and reinstalled multiple times.
Finally I figured out how to avoid that error (on my installation of OH3 M5):
By default the Remote Repository Access was enabled.
You find it under “Settings -> "AddOns Management
After disabling it, the installation of the components works fine.

Hope this works for you too.


same issue using openhab-3.0.1.zip
even if .kar stored in sub-folder addons/

Settings -> "AddOns Management” work around disabling solved it

seems to be fixed in
downloaded today


@peter_demus’ tip helped.

I had the same issue with a fresh setup of openhab 3.1 as docker container on a new raspberry pi 4: Trying to install any addon through the UI brought this message

“Installation of add-on xy failed”.

The logs contained this line:

[ERROR] [t.core.internal.addons.AddonResource] - Exception while installing add-on: null

… which isn’t that useful.

User and group ids where setup correctly to the id of a host user (1000) ans passed to the container. I could verify this, as the userdata (logs and openhab settings) was written to the relevant host directory. I’ve also tried to give all users write access to the userdata directory, but it didn’t help.

In the end it was solved by disabling access to remote repository as decribed by @peter_demus, though I do not understand why this solves the problem and why I’m still able to install addons without manually downloading them.

Further on I needed to manually create the items, rules, scripts, services, sitemaps and things directories in openhab/conf.