OH 3.0.1 icalendar and caldav [SOLVED]

I am using OH 3.0.1 in docker and can’t get my icalendar binding to connect to caldav.
The URL, user and password is 100% is correct. Calling the URL from a PC asks for user and password. Then the ics file is downloaded.
In the log file I get the following error
2021-02-05 17:01:24.176 [WARN ] [g.icalendar.internal.handler.PullJob] - Response status for getting “http://correctIP/baikal/html/cal.php/calendars/correctuser/openhabEG/?export” was 401 instead of 200. Ignoring it.

Thing is defined as follows. Same happens if I define the Calendar through the UI
Thing icalendar:calendar:deadbeef2 “openhabEG” @ “Internet” [ url=“http://correctIP/baikal/html/cal.php/calendars/correctuser/openhabEG/?export”, username=“correctuser”, password=“correctpassword”, refreshTime=60 ]

What am I doing wrong? Does the docker not allow http to go out?
I have seen other posts and there the issue was the missing ?export at the end of the URL. So I have run out of ideas…

Solved it. I had to change the caldav authorization to basic. Not really sure what I am doing here but as the calendar is only accessible locally I think I will survivie
#define(“BAIKAL_DAV_AUTH_TYPE”, ‘Digest’);
define(“BAIKAL_DAV_AUTH_TYPE”, ‘Basic’);

1 Like

Where did you put this line? I notice you mention using Docker, but that doesn’t look like anything from a docker-compose file.

I’m in the same boat as you were: saw this thread noting the ?export, I can successfully download from the correct URL with the correct credentials using a browser, but I can’t from openHAB:

Bridge icalendar:calendar:mycalendar "My Calendar"[
		url="http://192.168.1.166/dav.php/calendars/me/default?export",
		username="myusername",
		password="mypassword",
		refreshTime=60
		]
Response status for getting "http://192.168.1.166/dav.php/calendars/me/default?export" was 401 instead of 200. Ignoring it.

Docker log doesn’t say much new either:

baikal_1  | 192.168.1.153 - me [22/Nov/2021:19:53:29 +0000] "GET /dav.php/calendars/me/default?export HTTP/1.1" 401 436 "-" "Jetty/9.4.40.v20210413" "-"

Well I have a frustrating problem with Baikal. Either I can synchronize with IOS and use digest authentication or can synchronize with Openhab and use basic authentication. Does anyone know how to solve it ? Thx